aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-16 18:56:46 +0800
committermiwi <miwi@FreeBSD.org>2009-01-16 18:56:46 +0800
commitfee2edef75e9eafe32f4de76df6505f6db94ae1e (patch)
treeb850177889727a5f317c0a0ddfeecc05892cac6b
parent1603489c73611fa606bd805525a5f723d8d698a4 (diff)
downloadfreebsd-ports-gnome-fee2edef75e9eafe32f4de76df6505f6db94ae1e.tar.gz
freebsd-ports-gnome-fee2edef75e9eafe32f4de76df6505f6db94ae1e.tar.zst
freebsd-ports-gnome-fee2edef75e9eafe32f4de76df6505f6db94ae1e.zip
- Update to 0.6.3
PR: 130436 Submitted by: Ports Fury
-rw-r--r--textproc/soothsayer/Makefile30
-rw-r--r--textproc/soothsayer/distinfo6
-rw-r--r--textproc/soothsayer/pkg-plist8
3 files changed, 29 insertions, 15 deletions
diff --git a/textproc/soothsayer/Makefile b/textproc/soothsayer/Makefile
index a814e1246614..cf0607c88205 100644
--- a/textproc/soothsayer/Makefile
+++ b/textproc/soothsayer/Makefile
@@ -6,28 +6,40 @@
#
PORTNAME= soothsayer
-PORTVERSION= 0.6
+PORTVERSION= 0.6.3
CATEGORIES= textproc
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Intelligent predictive text entry platform
-BUILD_DEPENDS= swig>=1.3.31:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
-USE_LDCONFIG= yes
-USE_SQLITE= 3
USE_GNOME= pkgconfig
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-static --localstatedir=${PREFIX}/var/${PORTNAME}
-CPPFLAGS+= -I${LOCALBASE}/include
+USE_SQLITE= 3
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ ac_cv_path_CPPUNIT_CONFIG=no \
+ ac_cv_path_PYTHON=no \
+ ac_cv_path_SWIG=no \
+ ac_cv_prog_HAVE_DOT=no \
+ ac_cv_prog_HAVE_DOXYGEN=no
+CONFIGURE_ARGS= --disable-python-binding
+USE_LDCONFIG= yes
+
+MAN1= soothsayer_demo.1 soothsayer_demo_text.1 \
+ soothsayer_simulator.1 text2ngram.1
+
+CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PORT_VERBS= ${PORTNAME} text2ngram
post-patch:
- @${REINPLACE_CMD} -e 's|\$$\^|$${.ALLSRC}|' ${WRKSRC}/resources/Makefile.in
+ @${REINPLACE_CMD} -e 's|\$$\^|$${.ALLSRC}| ; \
+ s|lib/soothsayer|soothsayer|g' ${WRKSRC}/resources/Makefile.in
+ @${REINPLACE_CMD} -e 's|lib/soothsayer|soothsayer|' \
+ ${WRKSRC}/resources/profiles/Makefile.in
@${REINPLACE_CMD} -e '1s|/.*|/bin/sh|'\
${WRKSRC}/resources/profiles/generate_soothsayer_config.sh
@${REINPLACE_CMD} -E -e "s|(LIBS=.*)-lsqlite3(.*)|\1\`pkg-config --static --libs sqlite3\`\2|" \
diff --git a/textproc/soothsayer/distinfo b/textproc/soothsayer/distinfo
index efdfcfb9c72c..1117d5e272ee 100644
--- a/textproc/soothsayer/distinfo
+++ b/textproc/soothsayer/distinfo
@@ -1,3 +1,3 @@
-MD5 (soothsayer-0.6.tar.gz) = 297ad7fa764db679b247a70fc1f94214
-SHA256 (soothsayer-0.6.tar.gz) = 63f770e24c020a40ab3e0af287dd83f2665e5ae434feb52c4d227a6bb8be84a1
-SIZE (soothsayer-0.6.tar.gz) = 1353669
+MD5 (soothsayer-0.6.3.tar.gz) = e66eddfd82de087aff56b4a1d99987f1
+SHA256 (soothsayer-0.6.3.tar.gz) = 4385d0010b82e845b3622cfe6651c669e9bc3bde57c90e7b8c34044bb9406b2e
+SIZE (soothsayer-0.6.3.tar.gz) = 1119435
diff --git a/textproc/soothsayer/pkg-plist b/textproc/soothsayer/pkg-plist
index 5341ac461c5f..5eee202c4967 100644
--- a/textproc/soothsayer/pkg-plist
+++ b/textproc/soothsayer/pkg-plist
@@ -1,9 +1,11 @@
-bin/soothsayerDemo
-bin/soothsayerDemoText
-bin/soothsayerSimulator
+bin/soothsayer_demo
+bin/soothsayer_demo_text
+bin/soothsayer_simulator
bin/text2ngram
etc/soothsayer.xml
include/soothsayer.h
+include/soothsayerException.h
+lib/libsoothsayer.a
lib/libsoothsayer.la
lib/libsoothsayer.so
lib/libsoothsayer.so.0