aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmd <jmd@FreeBSD.org>2019-04-26 22:21:02 +0800
committerjmd <jmd@FreeBSD.org>2019-04-26 22:21:02 +0800
commit04b15234784f351c6e95c1c1a078afb1f315daae (patch)
tree4788c23d437c5b88eff0eba4b3f67540bcb0bf26
parentf1fd84dcedd6f3a890f794b4f06b291e30619763 (diff)
downloadfreebsd-ports-gnome-04b15234784f351c6e95c1c1a078afb1f315daae.tar.gz
freebsd-ports-gnome-04b15234784f351c6e95c1c1a078afb1f315daae.tar.zst
freebsd-ports-gnome-04b15234784f351c6e95c1c1a078afb1f315daae.zip
new port: devel/f18
f18 is the work in process successor to flang, a LLVM-based Fortran compiler. It recently was accepted as an official LLVM project and while hence likely change drastically (also in distribution) in the future. This port tracks FreeBSD support/development.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/f18/Makefile33
-rw-r--r--devel/f18/distinfo3
-rw-r--r--devel/f18/pkg-descr4
-rw-r--r--devel/f18/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 70ae9b0c1236..a7b445d79346 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -616,6 +616,7 @@
SUBDIR += eventxx
SUBDIR += evolution-gconf-tools
SUBDIR += exercisix
+ SUBDIR += f18
SUBDIR += f77flow
SUBDIR += fam
SUBDIR += fastcrc
diff --git a/devel/f18/Makefile b/devel/f18/Makefile
new file mode 100644
index 000000000000..61903e63fa2c
--- /dev/null
+++ b/devel/f18/Makefile
@@ -0,0 +1,33 @@
+# Created by: Johannes M Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= f18
+DISTVERSION= g20190422
+CATEGORIES= devel
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= Fortran compiler targeting LLVM
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+
+BUILD_DEPENDS= llvm80>=0:devel/llvm80
+RUN_DEPENDS= llvm80>=0:devel/llvm80
+
+USES= cmake:noninja compiler:c++11-lib libedit perl5 tar:xz \
+ shebangfix
+_USES_PYTHON?= python:build
+USES+= ${_USES_PYTHON}
+
+USE_GITHUB= yes
+GH_ACCOUNT= flang-compiler
+GH_TAGNAME= 9e178f2
+
+CMAKE_ARGS+= -DLLVM_DIR=${LOCALBASE}/llvm80/lib/cmake/llvm \
+ -DBUILD_WITH_CLANG=${LOCALBASE}/llvm80
+
+MAKE_JOBS_UNSAFE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/f18/distinfo b/devel/f18/distinfo
new file mode 100644
index 000000000000..9757790c031e
--- /dev/null
+++ b/devel/f18/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1555981638
+SHA256 (flang-compiler-f18-g20190422-9e178f2_GH0.tar.gz) = 4140ac6647733f2fa13936f4efcef44ef8abc3bbc00c77fbee3791069576296d
+SIZE (flang-compiler-f18-g20190422-9e178f2_GH0.tar.gz) = 582704
diff --git a/devel/f18/pkg-descr b/devel/f18/pkg-descr
new file mode 100644
index 000000000000..f9033763977c
--- /dev/null
+++ b/devel/f18/pkg-descr
@@ -0,0 +1,4 @@
+F18 is a ground-up implementation of a Fortran front end written in modern C++.
+F18, when combined with LLVM, is intended to replace the Flang compiler.
+
+WWW: https://github.com/flang-compiler/f18
diff --git a/devel/f18/pkg-plist b/devel/f18/pkg-plist
new file mode 100644
index 000000000000..19285bac0100
--- /dev/null
+++ b/devel/f18/pkg-plist
@@ -0,0 +1,7 @@
+bin/f18
+bin/f18-parse-demo
+lib/libFortranCommon.a
+lib/libFortranEvaluate.a
+lib/libFortranFIR.a
+lib/libFortranParser.a
+lib/libFortranSemantics.a