aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-11-12 07:54:06 +0800
committerjbeich <jbeich@FreeBSD.org>2018-11-12 07:54:06 +0800
commit099f4463b98cf0c419884225f01163d13ba1de95 (patch)
tree20c52047cb1565cae324ba193aee376544012794
parenta6d52b91b5d5ccbbd39860d3dd969426f56b7144 (diff)
downloadfreebsd-ports-gnome-099f4463b98cf0c419884225f01163d13ba1de95.tar.gz
freebsd-ports-gnome-099f4463b98cf0c419884225f01163d13ba1de95.tar.zst
freebsd-ports-gnome-099f4463b98cf0c419884225f01163d13ba1de95.zip
graphics/mesa-libs: enable WAYLAND by default here and in consumers
PR: 227509 Requested by: Johannes Lundberg, Greg V Reviewed by: tobik (earlier version) Approved by: madpilot, x11 (zeising), maintainer timeout (2 weeks) Exp-run by: antoine
-rw-r--r--UPDATING12
-rw-r--r--deskutils/cairo-dock/Makefile4
-rw-r--r--devel/sdl20/Makefile4
-rw-r--r--emulators/ppsspp/Makefile3
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile3
-rw-r--r--graphics/mesa-dri/Makefile4
-rw-r--r--graphics/mesa-libs/Makefile3
-rw-r--r--graphics/piglit/Makefile2
-rw-r--r--graphics/waffle/Makefile3
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--multimedia/libva-utils/Makefile2
-rw-r--r--multimedia/libva/Makefile2
-rw-r--r--multimedia/mpv/Makefile4
-rw-r--r--multimedia/vlc3/Makefile4
-rw-r--r--sysutils/gnome-control-center/Makefile2
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/Makefile.options2
-rw-r--r--www/webkit2-gtk3/Makefile3
-rw-r--r--x11-toolkits/gtk30/Makefile4
20 files changed, 46 insertions, 19 deletions
diff --git a/UPDATING b/UPDATING
index bc1f9ed8e47c..2a67c1b27ee8 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,18 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20181111
+ AFFECTS: users of graphics/mesa-libs
+ AUTHOR: jbeich@FreeBSD.org
+
+ Wayland support has been enabled in ports where it doesn't exclude
+ X11 support in order to make the binary packages usable with Wayland
+ compositors. If you get strange build failures re-run "make config"
+ to pick up the new defaults. If the extra dependencies are not
+ desired add the following to make.conf:
+
+ OPTIONS_UNSET += WAYLAND
+
20181109
AFFECTS: users of security/ossec-hids-server
AUTHOR: dominik.lisiak@bemsoft.pl
diff --git a/deskutils/cairo-dock/Makefile b/deskutils/cairo-dock/Makefile
index 186510f2d7e4..ea93940c1023 100644
--- a/deskutils/cairo-dock/Makefile
+++ b/deskutils/cairo-dock/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cairo-dock
PORTVERSION= 3.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MAINTAINER= ports@FreeBSD.org
@@ -34,7 +34,7 @@ CMAKE_ARGS= -Dinstall-pc-path:STRING="${LOCALBASE}/libdata/pkgconfig" \
-DCMAKE_INSTALL_MANDIR:PATH=man \
OPTIONS_DEFINE= X11 WAYLAND
-OPTIONS_DEFAULT=GLX X11
+OPTIONS_DEFAULT=EGL WAYLAND X11
OPTIONS_RADIO= GL
OPTIONS_RADIO_GL= GLX EGL
diff --git a/devel/sdl20/Makefile b/devel/sdl20/Makefile
index c1a264ca9fc8..6ddc1c1102e6 100644
--- a/devel/sdl20/Makefile
+++ b/devel/sdl20/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sdl2
PORTVERSION= 2.0.9
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.libsdl.org/release/
DISTNAME= SDL2-${PORTVERSION}
@@ -63,7 +64,8 @@ OPTIONS_DEFAULT= ASM DLOPEN OSS PTHREADS SDL_ATOMIC SDL_AUDIO \
SDL_CPUINFO SDL_EVENTS SDL_FILE SDL_HAPTIC \
SDL_JOYSTICK SDL_LOADSO SDL_POWER SDL_RENDER \
SDL_THREADS SDL_TIMERS SDL_VIDEO VIDEO_KMSDRM \
- VIDEO_OPENGL VIDEO_X11
+ VIDEO_OPENGL VIDEO_OPENGLES2 VIDEO_WAYLAND \
+ VIDEO_X11
ALSA_DESC= Audio output via the ALSA audio architecture
DLOPEN_DESC= Use dlopen for loading 3rd party libraries
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 427020fc71a8..10f4e6e82816 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -69,8 +69,7 @@ SDL_BUILD_DEPENDS= png>=1.6:graphics/png
SDL_LIB_DEPENDS= libpng.so:graphics/png
SDL_VARS= EXENAME=PPSSPPSDL
VULKAN_DESC= Vulkan renderer
-VULKAN_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
-VULKAN_CFLAGS= -DSDL_VIDEO_DRIVER_WAYLAND # XXX bug 223018, bug 227509
+VULKAN_RUN_DEPENDS= ${LOCALBASE}/lib/libvulkan.so:graphics/vulkan-loader
post-patch:
@${REINPLACE_CMD} -e 's/Linux/${OPSYS}/' \
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
index 3f5e02edb2ce..4e611f134ce6 100644
--- a/graphics/gstreamer1-plugins-gl/Makefile
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
COMMENT= GStreamer GL graphics plugin
@@ -14,6 +14,7 @@ PLIST= ${.CURDIR}/pkg-plist
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
OPTIONS_DEFINE= WAYLAND
+OPTIONS_DEFAULT=WAYLAND
OPTIONS_SUB= yes
WAYLAND_CONFIGURE_ENABLE= wayland
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index c60841cda610..fa2395640a09 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mesa-dri
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
COMMENT= OpenGL hardware acceleration drivers for DRI2+
@@ -11,7 +11,7 @@ COMMENT= OpenGL hardware acceleration drivers for DRI2+
USE_XORG= xorgproto x11 xdamage xext xfixes xshmfence xv xvmc
OPTIONS_DEFINE= TEXTURE VAAPI VDPAU WAYLAND
-OPTIONS_DEFAULT=TEXTURE
+OPTIONS_DEFAULT=TEXTURE WAYLAND
OPTIONS_SUB= yes
TEXTURE_DESC= Enable texture-float support (patent encumbered)
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index b4f97c21fb8b..ccac2ee952f9 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mesa-libs
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
COMMENT= OpenGL libraries that support GLX and EGL clients
@@ -12,6 +12,7 @@ USE_XORG= xorgproto x11 xcb xdamage xext \
xfixes xshmfence xxf86vm
OPTIONS_DEFINE= WAYLAND
+OPTIONS_DEFAULT=WAYLAND
OPTIONS_SUB= yes
WAYLAND_DESC= Enable support for the Wayland platform in EGL
diff --git a/graphics/piglit/Makefile b/graphics/piglit/Makefile
index cc5e6ca9b6fc..e4b806f31188 100644
--- a/graphics/piglit/Makefile
+++ b/graphics/piglit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= piglit
PORTVERSION= 20180910
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= x11@FreeBSD.org
@@ -45,6 +46,7 @@ DATADIR= ${PREFIX}/lib/piglit
PORTDATA= *
OPTIONS_DEFINE= DOCS WAYLAND
+OPTIONS_DEFAULT=WAYLAND
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
diff --git a/graphics/waffle/Makefile b/graphics/waffle/Makefile
index 0843783a2ad7..39258b51d42f 100644
--- a/graphics/waffle/Makefile
+++ b/graphics/waffle/Makefile
@@ -3,7 +3,7 @@
PORTNAME= waffle
PORTVERSION= 1.5.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://www.waffle-gl.org/files/release/waffle-${PORTVERSION}/
@@ -26,6 +26,7 @@ CMAKE_ARGS+= -Dwaffle_has_glx=ON \
PLIST_SUB+= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= DOCS WAYLAND
+OPTIONS_DEFAULT=WAYLAND
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
WAYLAND_CMAKE_BOOL= waffle_has_wayland
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index dea9d3179816..0b9e11c562e4 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 60.3.0
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
diff --git a/multimedia/libva-utils/Makefile b/multimedia/libva-utils/Makefile
index 5c5000875c86..0662d0125d23 100644
--- a/multimedia/libva-utils/Makefile
+++ b/multimedia/libva-utils/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libva-utils
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= madpilot@FreeBSD.org
@@ -22,6 +23,7 @@ USE_GITHUB= yes
GH_ACCOUNT= intel
OPTIONS_DEFINE= DEBUG WAYLAND
+OPTIONS_DEFAULT=WAYLAND
WAYLAND_DESC= Support wayland protocol
OPTIONS_SUB= yes
diff --git a/multimedia/libva/Makefile b/multimedia/libva/Makefile
index 5e9d29b3607b..3d7783326c3b 100644
--- a/multimedia/libva/Makefile
+++ b/multimedia/libva/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libva
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= madpilot@FreeBSD.org
@@ -30,6 +31,7 @@ LDFLAGS+= -lpthread
CFLAGS+= -DHAVE_LINUX_INTEGER_TYPES
OPTIONS_DEFINE= DEBUG WAYLAND
+OPTIONS_DEFAULT=WAYLAND
WAYLAND_DESC= Support wayland protocol
OPTIONS_SUB= yes
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index 2d825d3717de..9db991e9e84f 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -4,7 +4,7 @@
PORTNAME= mpv
PORTVERSION= 0.29.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= multimedia audio
MASTER_SITES= https://waf.io/:waf
@@ -44,7 +44,7 @@ CONFIGURE_ARGS= --docdir="${EXAMPLESDIR}" \
OPTIONS_DEFINE= ARCHIVE ASS DOCS LCMS2 LUAJIT MANPAGES TEST UCHARDET ZSH EXAMPLES
OPTIONS_DEFAULT= ARCHIVE ASS DVDREAD DVDNAV MANPAGES OPENGL UCHARDET \
- V4L VAAPI VDPAU X11 YTDL
+ V4L VAAPI VDPAU WAYLAND X11 YTDL
OPTIONS_GROUP= IN VO AO
OPTIONS_GROUP_IN= CDIO DVDREAD DVDNAV LIBBLURAY V4L YTDL SMB
OPTIONS_GROUP_VO= CACA OPENGL VAAPI VDPAU WAYLAND X11
diff --git a/multimedia/vlc3/Makefile b/multimedia/vlc3/Makefile
index 670c965cea3d..5542d4447682 100644
--- a/multimedia/vlc3/Makefile
+++ b/multimedia/vlc3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlc
DISTVERSION= 3.0.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
@@ -76,7 +76,7 @@ OPTIONS_DEFINE= A52 AALIB ASS AVAHI CACA CHROMECAST DBUS DCA DOCS DVDREAD \
OPTIONS_DEFAULT=A52 AVAHI DBUS DCA DVDREAD DVDNAV FAAD FLAC GNUTLS \
LIVEMEDIA LUA MAD MPEG2 OGG OPTIMIZED_CFLAGS \
OPUS PNG QT5 SAMPLERATE STREAM SPEEX TAGLIB THEORA TWOLAME \
- V4L VAAPI VCD VDPAU VORBIS X11
+ V4L VAAPI VCD VDPAU VORBIS WAYLAND X11
OPTIONS_SUB= yes
ASS_DESC= ASS/SSA subtitle rendering
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index acab83da349b..c5997c479791 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnome-control-center
PORTVERSION= 3.28.2
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -54,6 +55,7 @@ GLIB_SCHEMAS= org.gnome.ControlCenter.gschema.xml
OPTIONS_SUB= yes
OPTIONS_DEFINE= WAYLAND
+OPTIONS_DEFAULT=WAYLAND
OPTIONS_DEFINE_i386= CHEESE
OPTIONS_DEFAULT_i386= CHEESE
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 73c2ae04913a..b8abc3929ef0 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 60.3.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 266b3814bb8f..2404572592a5 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 63.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index 5a6d5ad16a27..694607dec0b0 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -4,7 +4,7 @@ OPTIONS_DEFINE+= BUNDLED_CAIRO CANBERRA DBUS DEBUG DTRACE FFMPEG GCONF \
INTEGER_SAMPLES LIBPROXY \
OPTIMIZED_CFLAGS PROFILE TEST WAYLAND
-OPTIONS_DEFAULT+= DBUS FFMPEG GCONF OPTIMIZED_CFLAGS PROFILE \
+OPTIONS_DEFAULT+= DBUS FFMPEG GCONF OPTIMIZED_CFLAGS PROFILE WAYLAND \
${OPTIONS_MULTI_AUDIO:NSNDIO} \
${MACHINE_CPU:Msoftfp:C/.+/INTEGER_SAMPLES/}
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index 1978e31e1003..ea9540242559 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webkit
PORTVERSION= 2.22.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= 2-gtk3
@@ -63,7 +64,7 @@ INSTALL_TARGET= install
BROWSER_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_plugins/symlinks/webkit-gtk3
OPTIONS_DEFINE= DEBUG GEOIP NPAPI WAYLAND
-OPTIONS_DEFAULT= GEOIP
+OPTIONS_DEFAULT= GEOIP WAYLAND
OPTIONS_DEFAULT_i386= NPAPI
OPTIONS_DEFAULT_amd64= NPAPI
OPTIONS_SUB= yes
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index ef9ba24ef73c..3fa34ee03b32 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -5,7 +5,7 @@
PORTNAME= gtk
PORTVERSION= 3.22.30
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME/sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMESUFFIX= 3
@@ -54,7 +54,7 @@ GLIB_SCHEMAS= org.gtk.Demo.gschema.xml \
org.gtk.Settings.FileChooser.gschema.xml
OPTIONS_DEFINE= CUPS CLOUDPRINT COLORD DEBUG BROADWAY WAYLAND
-OPTIONS_DEFAULT=CUPS COLORD BROADWAY
+OPTIONS_DEFAULT=CUPS COLORD BROADWAY WAYLAND
OPTIONS_SUB= yes
BROADWAY_DESC= Enable GDK Broadway backend for showing GTK+ in the webbrowser using HTML5 and web sockets.