diff options
author | asami <asami@FreeBSD.org> | 1999-01-26 11:58:58 +0800 |
---|---|---|
committer | asami <asami@FreeBSD.org> | 1999-01-26 11:58:58 +0800 |
commit | 303a5a6e927607f3fe07c290daa1bbf8ba6cc470 (patch) | |
tree | d5bd0d5034a5f29e6f3018b40922b5048aef95ef | |
parent | c5600d88b12f864615b303f2d1997f332cd245f3 (diff) | |
download | freebsd-ports-gnome-303a5a6e927607f3fe07c290daa1bbf8ba6cc470.tar.gz freebsd-ports-gnome-303a5a6e927607f3fe07c290daa1bbf8ba6cc470.tar.zst freebsd-ports-gnome-303a5a6e927607f3fe07c290daa1bbf8ba6cc470.zip |
(1) Rename "templates" to "Templates". The toplevel is getting
crowded and I don't want to confuse cvsup about what's in
ports-base and what is not. (I.e., all uppercase
files/directories are, all lowercase ones are not.) While I'm
here, move the make_index script from templates to Tools.
(2) Adjust the MASTER_SITE_OVERRIDE logic a bit. Formerly, it was not
possible to specify both MASTER_SITE_OVERRIDE while still using
MASTER_SITE_BACKUP as a backup, as they were tied in the
implementation of MASTER_SITE_FREEBSD. You can now specify them
independently if MASTER_SITE_FREEBSD is not set (in which case
MASTER_SITE_BACKUP will be moved to the beginning of the list,
like before).
-rw-r--r-- | Makefile | 4 | ||||
-rw-r--r-- | Mk/bsd.port.mk | 21 |
2 files changed, 12 insertions, 13 deletions
@@ -1,4 +1,4 @@ -# $Id: Makefile,v 1.44 1999/01/13 04:08:05 jkh Exp $ +# $Id: Makefile,v 1.45 1999/01/22 10:32:32 asami Exp $ # SUBDIR += archivers @@ -54,7 +54,7 @@ index: ${.CURDIR}/INDEX: @echo -n "Generating INDEX - please wait.." @make describe ECHO_MSG="echo > /dev/null" | \ - perl ${.CURDIR}/templates/make_index > ${.CURDIR}/INDEX + perl ${.CURDIR}/Tools/make_index > ${.CURDIR}/INDEX @echo " Done." print-index: ${.CURDIR}/INDEX diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk index 1b6428627223..ee98ea25217e 100644 --- a/Mk/bsd.port.mk +++ b/Mk/bsd.port.mk @@ -1,7 +1,7 @@ #-*- mode: Fundamental; tab-width: 4; -*- # ex:ts=4 # -# $Id: bsd.port.mk,v 1.301 1999/01/11 13:04:18 asami Exp $ +# $Id: bsd.port.mk,v 1.302 1999/01/20 01:55:05 asami Exp $ # $NetBSD: $ # # bsd.port.mk - 940820 Jordan K. Hubbard. @@ -458,7 +458,7 @@ DISTDIR?= ${PORTSDIR}/distfiles _DISTDIR?= ${DISTDIR}/${DIST_SUBDIR} EXTRACT_SUFX?= .tar.gz PACKAGES?= ${PORTSDIR}/packages -TEMPLATES?= ${PORTSDIR}/templates +TEMPLATES?= ${PORTSDIR}/Templates .if exists(${MASTERDIR}/patches.${ARCH}-${OPSYS}) PATCHDIR?= ${MASTERDIR}/patches.${ARCH}-${OPSYS} @@ -854,24 +854,23 @@ PATCH_SITES:= ${PATCH_SITES:S/%SUBDIR%/${PATCH_SITE_SUBDIR}/} MASTER_SITE_BACKUP?= \ ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${DIST_SUBDIR}/ -# If the user has this set, go to the FreeBSD repository for everything. -.if defined(MASTER_SITE_FREEBSD) -MASTER_SITE_OVERRIDE= ${MASTER_SITE_BACKUP} -.endif - # Where to put distfiles that don't have any other master site MASTER_SITE_LOCAL?= \ ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/LOCAL_PORTS/ -# I guess we're in the master distribution business! :) As we gain mirror -# sites for distfiles, add them to this list. -.if !defined(MASTER_SITE_OVERRIDE) +# If the user has MASTER_SITE_FREEBSD set, go to the FreeBSD repository +# for everything, but don't search it twice by appending it to the end. +.if !defined(MASTER_SITE_FREEBSD) MASTER_SITES+= ${MASTER_SITE_BACKUP} PATCH_SITES+= ${MASTER_SITE_BACKUP} -.else +.if defined(MASTER_SITE_OVERRIDE) MASTER_SITES:= ${MASTER_SITE_OVERRIDE} ${MASTER_SITES} PATCH_SITES:= ${MASTER_SITE_OVERRIDE} ${PATCH_SITES} .endif +.else +MASTER_SITES:= ${MASTER_SITE_BACKUP} ${MASTER_SITES} +PATCH_SITES:= ${MASTER_SITE_BACKUP} ${MASTER_SITES} +.endif # Search CDROM first if mounted, symlink instead of copy if # FETCH_SYMLINK_DISTFILES is set |