aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-04-18 02:48:58 +0800
committerKoop Mast <koop@beyonit.nl>2019-04-23 03:01:53 +0800
commit498897888915822feba367302748db7c3a904f75 (patch)
tree835263ba335cee75255dc2c94926e39fdab1e142
parentb3e5f985a0a111cad0b56f471d1197e6e67ba953 (diff)
downloadfreebsd-ports-gnome-498897888915822feba367302748db7c3a904f75.tar.gz
freebsd-ports-gnome-498897888915822feba367302748db7c3a904f75.tar.zst
freebsd-ports-gnome-498897888915822feba367302748db7c3a904f75.zip
Update to 0.3.0
- Add LICENSE_FILE - Update pkg-descr Changes: https://github.com/imageio/imageio-ffmpeg/releases https://github.com/imageio/imageio-ffmpeg/commits/master
-rw-r--r--graphics/py-imageio-ffmpeg/Makefile3
-rw-r--r--graphics/py-imageio-ffmpeg/distinfo6
-rw-r--r--graphics/py-imageio-ffmpeg/files/patch-setup.py10
-rw-r--r--graphics/py-imageio-ffmpeg/pkg-descr14
4 files changed, 21 insertions, 12 deletions
diff --git a/graphics/py-imageio-ffmpeg/Makefile b/graphics/py-imageio-ffmpeg/Makefile
index 4acde9050f21..35bd1fcc9034 100644
--- a/graphics/py-imageio-ffmpeg/Makefile
+++ b/graphics/py-imageio-ffmpeg/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= imageio-ffmpeg
-PORTVERSION= 0.2.0
+PORTVERSION= 0.3.0
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +11,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= FFMPEG wrapper for Python
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ffmpeg:multimedia/ffmpeg
diff --git a/graphics/py-imageio-ffmpeg/distinfo b/graphics/py-imageio-ffmpeg/distinfo
index 4ee51f07de0e..64955a24ff89 100644
--- a/graphics/py-imageio-ffmpeg/distinfo
+++ b/graphics/py-imageio-ffmpeg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1549567303
-SHA256 (imageio-ffmpeg-0.2.0.tar.gz) = 2beacb11b121440cfd0bc0caf80da54a3729956002707251ab8e26d3e03933a4
-SIZE (imageio-ffmpeg-0.2.0.tar.gz) = 10865
+TIMESTAMP = 1555202509
+SHA256 (imageio-ffmpeg-0.3.0.tar.gz) = 28500544acdebc195159d53a4670b76d596f368b218317bad5d3cbf43b00d6c2
+SIZE (imageio-ffmpeg-0.3.0.tar.gz) = 13055
diff --git a/graphics/py-imageio-ffmpeg/files/patch-setup.py b/graphics/py-imageio-ffmpeg/files/patch-setup.py
new file mode 100644
index 000000000000..23b28b39b1c4
--- /dev/null
+++ b/graphics/py-imageio-ffmpeg/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2019-04-12 09:07:51 UTC
++++ setup.py
+@@ -57,7 +57,6 @@ setup(
+ platforms="any",
+ provides=["imageio_ffmpeg"],
+ python_requires=">=3.4",
+- setup_requires=["pip>19"],
+ install_requires=[], # todo: maybe numpy
+ packages=["imageio_ffmpeg"],
+ package_dir={"imageio_ffmpeg": "imageio_ffmpeg"},
diff --git a/graphics/py-imageio-ffmpeg/pkg-descr b/graphics/py-imageio-ffmpeg/pkg-descr
index bdad2461f615..990693234cff 100644
--- a/graphics/py-imageio-ffmpeg/pkg-descr
+++ b/graphics/py-imageio-ffmpeg/pkg-descr
@@ -1,13 +1,11 @@
The purpose of this project is to provide a simple and reliable ffmpeg wrapper
-for working with video files. It takes care of producing platform-specific
-wheels that include the binary executables of ffmpeg. These can then be
-installed (and updated or uninstalled) easily with pip.
-
-It also provides simple generator functions for reading and writing data from/to
-ffmpeg, which reliably terminate the ffmpeg process when done.
+for working with video files. It implements two simple generator functions for
+reading and writing data from/to ffmpeg, which reliably terminate the ffmpeg
+process when done. It also takes care of publishing platform-specific wheels
+that include the binary ffmpeg executables.
This library is used as the basis for the imageio ffmpeg plugin, but it can also
-be used by itself. Imageio provides a friendlier (higher level) API, and adds
-support for e.g. cameras and seeking.
+be used by itself. Imageio provides a higher level API, and adds support for
+e.g. cameras and seeking.
WWW: https://github.com/imageio/imageio-ffmpeg