aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-05-21 14:20:14 +0800
committerantoine <antoine@FreeBSD.org>2016-05-21 14:20:14 +0800
commit5ff033205375214b5ed843fc6df114805a2e0994 (patch)
tree5975964c0bce7d85a6f75b766125bef4a76e3f4d
parent59f3d5ae2aff9756a1a8a34d3ddaa4d4d20ffc51 (diff)
downloadfreebsd-ports-gnome-5ff033205375214b5ed843fc6df114805a2e0994.tar.gz
freebsd-ports-gnome-5ff033205375214b5ed843fc6df114805a2e0994.tar.zst
freebsd-ports-gnome-5ff033205375214b5ed843fc6df114805a2e0994.zip
Fix patching when OPENMP is disabled
Reported by: pkg-fallout
-rw-r--r--devel/llvm37/Makefile2
-rw-r--r--devel/llvm37/files/openmp-patch-tools_openmp_runtime_tools_expand-vars.pl (renamed from devel/llvm37/files/patch-tools_openmp_runtime_tools_expand-vars.pl)0
2 files changed, 2 insertions, 0 deletions
diff --git a/devel/llvm37/Makefile b/devel/llvm37/Makefile
index 7cdc84165e38..b8ca8e9c3969 100644
--- a/devel/llvm37/Makefile
+++ b/devel/llvm37/Makefile
@@ -68,6 +68,8 @@ LLDB_BUILD_DEPENDS= swig:devel/swig13
LLDB_DISTFILES= lldb-${DISTVERSION}.src${EXTRACT_SUFX}
OPENMP_DESC= Install libomp, the LLVM OpenMP runtime library
OPENMP_DISTFILES= openmp-${DISTVERSION}.src${EXTRACT_SUFX}
+OPENMP_EXTRA_PATCHES= \
+ ${PATCHDIR}/openmp-patch-tools_openmp_runtime_tools_expand-vars.pl
GOLD_DESC= Build the LLVM Gold plugin for LTO
GOLD_CMAKE_ON= -DLLVM_BINUTILS_INCDIR=${LOCALBASE}/include
GOLD_BUILD_DEPENDS= ld.gold:devel/binutils
diff --git a/devel/llvm37/files/patch-tools_openmp_runtime_tools_expand-vars.pl b/devel/llvm37/files/openmp-patch-tools_openmp_runtime_tools_expand-vars.pl
index 9df4ab1c0a41..9df4ab1c0a41 100644
--- a/devel/llvm37/files/patch-tools_openmp_runtime_tools_expand-vars.pl
+++ b/devel/llvm37/files/openmp-patch-tools_openmp_runtime_tools_expand-vars.pl