aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfernape <fernape@FreeBSD.org>2019-04-18 03:01:02 +0800
committerKoop Mast <koop@beyonit.nl>2019-04-23 03:01:56 +0800
commit8319382e8d090ea7304b550e9c596e03bfd6d6aa (patch)
treedebcb094ab62c6d2f637362d29183671e32707e5
parent910d231a17b4de5c7756f89590d9b2868642a3ff (diff)
downloadfreebsd-ports-gnome-8319382e8d090ea7304b550e9c596e03bfd6d6aa.tar.gz
freebsd-ports-gnome-8319382e8d090ea7304b550e9c596e03bfd6d6aa.tar.zst
freebsd-ports-gnome-8319382e8d090ea7304b550e9c596e03bfd6d6aa.zip
deskutils/go-for-it: Update to 1.7.1
While here, regenerate patch with makepatch and move some variables to their sections. ChangeLog: https://github.com/mank319/Go-For-It/releases/tag/1.7.1 * The application id can now be set with -DAPP_ID=some_id * For some widgets Go For It! did not properly load a fallback icon. PR: 237339 Submitted by: neel@neelc.org (maintainer)
-rw-r--r--deskutils/go-for-it/Makefile7
-rw-r--r--deskutils/go-for-it/distinfo6
-rw-r--r--deskutils/go-for-it/files/patch-CMakeLists.txt6
3 files changed, 10 insertions, 9 deletions
diff --git a/deskutils/go-for-it/Makefile b/deskutils/go-for-it/Makefile
index cbbff6cbcd24..3c6f41472cfb 100644
--- a/deskutils/go-for-it/Makefile
+++ b/deskutils/go-for-it/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= go-for-it
-DISTVERSION= 1.7.0
+DISTVERSION= 1.7.1
CATEGORIES= deskutils
MAINTAINER= neel@neelc.org
@@ -13,12 +13,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:lang/vala
LIB_DEPENDS= libnotify.so:devel/libnotify
-USES= cmake gettext pkgconfig
-GNU_CONFIGURE= yes
+USES= cmake gnome gettext pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= JMoerman
GH_PROJECT= Go-For-It
USE_GNOME= cairo glib20 gtk30 intltool
+
+GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
.include <bsd.port.mk>
diff --git a/deskutils/go-for-it/distinfo b/deskutils/go-for-it/distinfo
index 0008900df3d4..189813d58f55 100644
--- a/deskutils/go-for-it/distinfo
+++ b/deskutils/go-for-it/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1552867966
-SHA256 (JMoerman-Go-For-It-1.7.0_GH0.tar.gz) = 492c43597582de3f63965e819697ad7c02ec5330da3e993497e6e5c80189de21
-SIZE (JMoerman-Go-For-It-1.7.0_GH0.tar.gz) = 249545
+TIMESTAMP = 1555517081
+SHA256 (JMoerman-Go-For-It-1.7.1_GH0.tar.gz) = c7783736dd7c1182d2c7d51ab05176588b1c09372def731d3f0b2d4fa2234540
+SIZE (JMoerman-Go-For-It-1.7.1_GH0.tar.gz) = 249317
diff --git a/deskutils/go-for-it/files/patch-CMakeLists.txt b/deskutils/go-for-it/files/patch-CMakeLists.txt
index 93ea8b3baa68..d77b40548f52 100644
--- a/deskutils/go-for-it/files/patch-CMakeLists.txt
+++ b/deskutils/go-for-it/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2018-02-28 21:31:57 UTC
+--- CMakeLists.txt.orig 2019-04-17 16:52:02 UTC
+++ CMakeLists.txt
@@ -8,7 +8,7 @@ include (GNUInstallDirs)
set (INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")
set (DATADIR "${INSTALL_PREFIX}/share")
--set (APP_ID "com.github.jmoerman.go-for-it")
-+set (APP_ID "go-for-it")
+-set (APP_ID "com.github.jmoerman.go-for-it" CACHE STRING "The application id")
++set (APP_ID "go-for-it" CACHE STRING "The application id")
set (APP_SYSTEM_NAME ${APP_ID} CACHE STRING "Name to used for file names. For example the file name of the .desktop file.")
set (PKGDATADIR ${DATADIR}/${APP_SYSTEM_NAME})