aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author0mp <0mp@FreeBSD.org>2019-03-04 23:39:16 +0800
committer0mp <0mp@FreeBSD.org>2019-03-04 23:39:16 +0800
commita020415c147f330857713bf4bac6f80729937b04 (patch)
tree5e17a86b2d5c2c58282b743b428a3dee26c4b59b
parentddf6dd6148416bec415678371ccd8bcbcb2fa251 (diff)
downloadfreebsd-ports-gnome-a020415c147f330857713bf4bac6f80729937b04.tar.gz
freebsd-ports-gnome-a020415c147f330857713bf4bac6f80729937b04.tar.zst
freebsd-ports-gnome-a020415c147f330857713bf4bac6f80729937b04.zip
New port: x11/find-cursor: Simple XLib program to highlight the cursor position
Simple XLib program to highlight the cursor position. This is similar to the feature found in Windows XP (and possibly later?). Reviewed by: krion, mat Approved by: krion (mentor), mat (mentor) Differential Revision: https://reviews.freebsd.org/D19440
-rw-r--r--x11/Makefile1
-rw-r--r--x11/find-cursor/Makefile35
-rw-r--r--x11/find-cursor/distinfo3
-rw-r--r--x11/find-cursor/pkg-descr4
4 files changed, 43 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b72844186a22..1eead7b082ac 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -63,6 +63,7 @@
SUBDIR += evilvte
SUBDIR += fbdesk
SUBDIR += fbpanel
+ SUBDIR += find-cursor
SUBDIR += fireflies
SUBDIR += florence
SUBDIR += flruler
diff --git a/x11/find-cursor/Makefile b/x11/find-cursor/Makefile
new file mode 100644
index 000000000000..50b33804e331
--- /dev/null
+++ b/x11/find-cursor/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= find-cursor
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1
+CATEGORIES= x11
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Simple XLib program to highlight the cursor position
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= Carpetsmoker
+USE_XORG= x11 xdamage xext xfixes xrender
+
+PLIST_FILES= bin/${PORTNAME}
+
+PORTDOCS= README.markdown screenshot.gif
+
+OPTIONS_DEFINE= DOCS
+
+post-configure:
+ ${REINPLACE_CMD} -E 's/(.CC.)/\1 $${LDFLAGS}/' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/find-cursor/distinfo b/x11/find-cursor/distinfo
new file mode 100644
index 000000000000..241a01efe114
--- /dev/null
+++ b/x11/find-cursor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1551700730
+SHA256 (Carpetsmoker-find-cursor-v1.1_GH0.tar.gz) = 02bef496b99956440b40ade5a6bf77706b298d6af6e7a1260d4a71729e343f02
+SIZE (Carpetsmoker-find-cursor-v1.1_GH0.tar.gz) = 73554
diff --git a/x11/find-cursor/pkg-descr b/x11/find-cursor/pkg-descr
new file mode 100644
index 000000000000..27f3cfdfb58f
--- /dev/null
+++ b/x11/find-cursor/pkg-descr
@@ -0,0 +1,4 @@
+Simple XLib program to highlight the cursor position. This is similar to the
+feature found in Windows XP (and possibly later?).
+
+WWW: https://github.com/Carpetsmoker/find-cursor