aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-19 02:30:44 +0800
committerantoine <antoine@FreeBSD.org>2014-02-19 02:30:44 +0800
commita1802b5c8b966f0aa4323cad7fb334c6d19bc891 (patch)
tree3bc263ad181d7126dc23c5c5fd884b04212ed44e
parentcdd86c19cdf17bf3fe910cce16c71e0fca384a28 (diff)
downloadfreebsd-ports-gnome-a1802b5c8b966f0aa4323cad7fb334c6d19bc891.tar.gz
freebsd-ports-gnome-a1802b5c8b966f0aa4323cad7fb334c6d19bc891.tar.zst
freebsd-ports-gnome-a1802b5c8b966f0aa4323cad7fb334c6d19bc891.zip
Stage support
-rw-r--r--sysutils/foremost/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/sysutils/foremost/Makefile b/sysutils/foremost/Makefile
index a3f924940b4c..62ee9835f261 100644
--- a/sysutils/foremost/Makefile
+++ b/sysutils/foremost/Makefile
@@ -9,22 +9,20 @@ MASTER_SITES= http://foremost.sourceforge.net/pkg/
MAINTAINER= onatan@gmail.com
COMMENT= Console program to recover files based on their headers and footers
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= freebsd
-MAN8= foremost.8
-PLIST_FILES= bin/foremost etc/foremost.conf.sample
+PLIST_FILES= bin/foremost etc/foremost.conf.sample man/man8/foremost.8.gz
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-Wall -O2|${CFLAGS}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/config.c
- @${GZCAT} ${WRKSRC}/${MAN8}.gz | ${SED} -e 's|/etc|${PREFIX}/etc|' \
- > ${WRKSRC}/${MAN8}
+ @${GZCAT} ${WRKSRC}/foremost.8.gz | ${SED} -e 's|/etc|${PREFIX}/etc|' \
+ > ${WRKSRC}/foremost.8
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/foremost.conf ${PREFIX}/etc/foremost.conf.sample
- ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MAN8PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/foremost.conf ${STAGEDIR}${PREFIX}/etc/foremost.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/foremost.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
.include <bsd.port.mk>