aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-05-23 00:28:40 +0800
committerbapt <bapt@FreeBSD.org>2016-05-23 00:28:40 +0800
commitd44e12abb47a95eb80d19dee92b90804ee582de3 (patch)
treeb8d2a1d5a38a3cf986ad05faa89250c6ad4d8941
parent8a83072061e479efc16f7f083784a3390cbfa940 (diff)
downloadfreebsd-ports-gnome-d44e12abb47a95eb80d19dee92b90804ee582de3.tar.gz
freebsd-ports-gnome-d44e12abb47a95eb80d19dee92b90804ee582de3.tar.zst
freebsd-ports-gnome-d44e12abb47a95eb80d19dee92b90804ee582de3.zip
Prevent collision with getline(3)
Obtained from: Upstream
-rw-r--r--sysutils/ldapvi/Makefile2
-rw-r--r--sysutils/ldapvi/files/0010-renamed-getline.patch53
2 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/ldapvi/Makefile b/sysutils/ldapvi/Makefile
index de36f9d5bbb3..d8deaefc5f51 100644
--- a/sysutils/ldapvi/Makefile
+++ b/sysutils/ldapvi/Makefile
@@ -21,6 +21,8 @@ USE_GNOME= glib20
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
+EXTRA_PATCHES= ${FILESDIR}/0010-renamed-getline.patch:-p2
+
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
diff --git a/sysutils/ldapvi/files/0010-renamed-getline.patch b/sysutils/ldapvi/files/0010-renamed-getline.patch
new file mode 100644
index 000000000000..ea7cfa5f7054
--- /dev/null
+++ b/sysutils/ldapvi/files/0010-renamed-getline.patch
@@ -0,0 +1,53 @@
+From 256ced029c235687bfafdffd07be7d47bf7af39b Mon Sep 17 00:00:00 2001
+From: David Lichteblau <david@lichteblau.com>
+Date: Thu, 18 Jun 2009 20:07:42 +0200
+Subject: [PATCH 10/15] renamed getline
+
+---
+ ldapvi/common.h | 2 +-
+ ldapvi/ldapvi.c | 2 +-
+ ldapvi/misc.c | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/ldapvi/common.h b/ldapvi/common.h
+index 4c264e8..f731e62 100644
+--- a/ldapvi/common.h
++++ b/ldapvi/common.h
+@@ -273,7 +273,7 @@ void pipeview_wait(int pid);
+ char *home_filename(char *name);
+ void read_ldapvi_history(void);
+ void write_ldapvi_history(void);
+-char *getline(char *prompt, char *value);
++char *ldapvi_getline(char *prompt, char *value);
+ char *get_password();
+ char *append(char *a, char *b);
+ void *xalloc(size_t size);
+diff --git a/ldapvi/ldapvi.c b/ldapvi/ldapvi.c
+index 9d7d77c..7b312f8 100644
+--- a/ldapvi/ldapvi.c
++++ b/ldapvi/ldapvi.c
+@@ -470,7 +470,7 @@ change_mechanism(bind_options *bo)
+ bo->authmethod = LDAP_AUTH_SASL;
+ puts("Switching to SASL authentication.");
+ }
+- bo->sasl_mech = getline("SASL mechanism", bo->sasl_mech);
++ bo->sasl_mech = ldapvi_getline("SASL mechanism", bo->sasl_mech);
+ }
+
+ static int
+diff --git a/ldapvi/misc.c b/ldapvi/misc.c
+index 0a9dba9..3b6896e 100644
+--- a/ldapvi/misc.c
++++ b/ldapvi/misc.c
+@@ -315,7 +315,7 @@ write_ldapvi_history()
+ }
+
+ char *
+-getline(char *prompt, char *value)
++ldapvi_getline(char *prompt, char *value)
+ {
+ tdialog d;
+ init_dialog(&d, DIALOG_DEFAULT, prompt, value);
+--
+2.8.1
+