aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-10-19 15:50:53 +0800
committermva <mva@FreeBSD.org>2014-10-19 15:50:53 +0800
commitdc3d0650673d81132ee89d472a4c21d49328fa91 (patch)
treee02fe0a758ee3fd52b58a10326bb7c498ab3c957
parentf0650650659a9d0d05c3b1ccd3d4949aee1bc9c2 (diff)
downloadfreebsd-ports-gnome-dc3d0650673d81132ee89d472a4c21d49328fa91.tar.gz
freebsd-ports-gnome-dc3d0650673d81132ee89d472a4c21d49328fa91.tar.zst
freebsd-ports-gnome-dc3d0650673d81132ee89d472a4c21d49328fa91.zip
- Convert ports from cad/, chinese/, comms/ and converters/ to new
USES=python Approved by: portmgr (implicit)
-rw-r--r--cad/brickutils/Makefile2
-rw-r--r--cad/geda-utils/Makefile3
-rw-r--r--cad/kicad-devel/Makefile5
-rw-r--r--cad/pythoncad/Makefile4
-rw-r--r--chinese/bg5ps/Makefile2
-rw-r--r--chinese/ibus-pinyin/Makefile4
-rw-r--r--chinese/ydict/Makefile7
-rw-r--r--comms/congruity/Makefile3
-rw-r--r--comms/gammu/Makefile3
-rw-r--r--comms/gnuradio/Makefile3
-rw-r--r--comms/hamlib/Makefile3
-rw-r--r--comms/py-bulksms/Makefile4
-rw-r--r--comms/py-libconcord/Makefile5
-rw-r--r--comms/py-lirc/Makefile5
-rw-r--r--comms/py-serial/Makefile9
-rw-r--r--comms/pyla/Makefile2
-rw-r--r--comms/quisk/Makefile5
-rw-r--r--converters/gbsdconv/Makefile2
-rw-r--r--converters/py-bsdconv/Makefile4
-rw-r--r--converters/py-unidecode/Makefile5
-rw-r--r--converters/py-zfec/Makefile5
-rw-r--r--converters/zbase32/Makefile5
22 files changed, 41 insertions, 49 deletions
diff --git a/cad/brickutils/Makefile b/cad/brickutils/Makefile
index 74abe7c32096..313f56ab8f02 100644
--- a/cad/brickutils/Makefile
+++ b/cad/brickutils/Makefile
@@ -25,8 +25,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/ldraw/models/car.dat:${PORTSDIR}/cad/ldraw \
WRKSRC= ${WRKDIR}/BrickUtils-${PORTVERSION}
+USES= python
USE_GNOME= pygtk2
-USE_PYTHON= yes
PORTDOCS= *
diff --git a/cad/geda-utils/Makefile b/cad/geda-utils/Makefile
index 6e4d4cf01670..ceb1146bbdd6 100644
--- a/cad/geda-utils/Makefile
+++ b/cad/geda-utils/Makefile
@@ -20,12 +20,11 @@ LIB_DEPENDS= libgeda.so:${PORTSDIR}/cad/libgeda
DOCSDIR= ${PREFIX}/share/doc/geda
DATADIR= ${PREFIX}/share/geda
-USES= gmake perl5 pkgconfig shebangfix
+USES= gmake perl5 pkgconfig python:run shebangfix
SHEBANG_FILES= scripts/gnet_hier_verilog.sh
GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_PERL5= run
-USE_PYTHON_RUN= yes
CONFIGURE_ARGS= --with-docdir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 2e79ecf25330..2d05f8af476b 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -27,7 +27,6 @@ USE_GL= glew glu
USE_WX= 3.0
WX_UNICODE= yes
USE_GNOME= atk # Required by libwx_gtk2_aui-2.8.so
-USE_PYTHON= yes
OPTIONS_DEFINE= DOCS
@@ -37,7 +36,9 @@ PLIST_SUB= OPSYS=${OPSYS} \
BINS= cvpcb eeschema gerbview kicad pcbnew
EXTRAS2RM= linux-non_unicode linux wings3d LINUX.README \
contrib_makefiles.txt running_kicad_under_W98.txt
-USES= desktop-file-utils shared-mime-info compiler:c++11-lang tar:bzip2 cmake gettext
+USES= desktop-file-utils shared-mime-info compiler:c++11-lang tar:bzip2 cmake \
+ gettext python
+
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_BUILD_TYPE="Debug" \
diff --git a/cad/pythoncad/Makefile b/cad/pythoncad/Makefile
index c39a3d28000c..ffd64f9d32a0 100644
--- a/cad/pythoncad/Makefile
+++ b/cad/pythoncad/Makefile
@@ -16,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= PythonCAD
PYDISTUTILS_PKGVERSION= DS1-R${PORTVERSION}
diff --git a/chinese/bg5ps/Makefile b/chinese/bg5ps/Makefile
index ea80c1d8d1fe..a2b8d9c0ab25 100644
--- a/chinese/bg5ps/Makefile
+++ b/chinese/bg5ps/Makefile
@@ -14,7 +14,7 @@ COMMENT= Convert Chinese-Big5/GB encoded files to Postscript, using TTF fonts
LIB_DEPENDS= libttf.so:${PORTSDIR}/print/freetype
-USE_PYTHON= yes
+USES= python
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/chinese/ibus-pinyin/Makefile b/chinese/ibus-pinyin/Makefile
index 93b93c8da651..3ee68ed9446f 100644
--- a/chinese/ibus-pinyin/Makefile
+++ b/chinese/ibus-pinyin/Makefile
@@ -18,9 +18,7 @@ LIB_DEPENDS= libpyzy-1.0.so:${PORTSDIR}/chinese/pyzy \
libibus-1.0.so:${PORTSDIR}/textproc/ibus \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
-USE_PYTHON= yes
-
-USES= gmake pkgconfig compiler:c++11-lib
+USES= compiler:c++11-lib gmake pkgconfig python
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking --disable-lua-extension
diff --git a/chinese/ydict/Makefile b/chinese/ydict/Makefile
index 8b0c29a2b9f2..60b18d24395f 100644
--- a/chinese/ydict/Makefile
+++ b/chinese/ydict/Makefile
@@ -11,10 +11,15 @@ COMMENT= Command line tool of Yahoo! Dict
LICENSE= GPLv3
+USES= python:2,run shebangfix
+
NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_FILES= bin/ydict
-USE_PYTHON_RUN= yes
+
+SHEBANG_FILES= ${WRKSRC}/ydict
+python_OLD_CMD= /usr/bin/env python
+python_CMD= /usr/bin/env python2
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ydict ${STAGEDIR}${PREFIX}/bin/
diff --git a/comms/congruity/Makefile b/comms/congruity/Makefile
index 94abd82b69e9..dafd4713f961 100644
--- a/comms/congruity/Makefile
+++ b/comms/congruity/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libconcord>=0:${PORTSDIR}/comms/py-libconcord
MAKE_ARGS= MANDIR=${PREFIX}/man
-USES= tar:bzip2 gmake desktop-file-utils
-USE_PYTHON= 2.7+
+USES= desktop-file-utils gmake tar:bzip2 python:2.7+
USE_WX= 2.8+
WANT_UNICODE= yes
WX_COMPS= python
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 7efddf05cef9..768800570111 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -22,10 +22,9 @@ OPTIONS_DEFINE= BASH
CMAKE_ARGS+= -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
-USES= cmake gettext pkgconfig shebangfix
+USES= cmake gettext pkgconfig python shebangfix
SHEBANG_FILES= utils/jadmaker utils/gammu-config
bash_CMD= /bin/sh
-USE_PYTHON= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 14a559322765..30e45636ee32 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -38,7 +38,7 @@ LIB_DEPENDS= libcppunit.so:${PORTSDIR}/devel/cppunit \
libgsl.so:${PORTSDIR}/math/gsl
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= iconv cmake:outsource perl5 shebangfix
+USES= iconv cmake:outsource perl5 python:2.7 shebangfix
SHEBANG_FILES= grc/freedesktop/grc_setup_freedesktop.in
CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"
CMAKE_ARGS+= -DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
@@ -47,7 +47,6 @@ CMAKE_ARGS+= -DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
# for detailed debugging uncomment the next line
#CMAKE_ARGS+= --debug-output --trace
DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
-USE_PYTHON= 2.6-2.8
USE_WX= 3.0+
USE_QT4= gui xml qmake moc rcc uic
WX_COMPS= wx wx:build wx:run python:build python:run
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 1c96f2a4f220..12f143a8bab3 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -15,9 +15,8 @@ LICENSE= LGPL20
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
-USES= perl5 libtool:keepla pkgconfig pathfix tcl
+USES= perl5 libtool:keepla pkgconfig pathfix python tcl
USE_GNOME= libxml2
-USE_PYTHON= yes
USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/py-bulksms/Makefile b/comms/py-bulksms/Makefile
index 4dc0afbc1794..b07d58a0b3f1 100644
--- a/comms/py-bulksms/Makefile
+++ b/comms/py-bulksms/Makefile
@@ -10,8 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= craig001@lerwick.hopto.org
COMMENT= Python client for the BulkSMS.co.uk HTTP API
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= BulkSMS
PYDISTUTILS_PKGVERSION= 1.0
diff --git a/comms/py-libconcord/Makefile b/comms/py-libconcord/Makefile
index 64b8cf4af554..695f8fc14729 100644
--- a/comms/py-libconcord/Makefile
+++ b/comms/py-libconcord/Makefile
@@ -16,9 +16,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libconcord.so:${PORTSDIR}/comms/libconcord
USE_LDCONFIG= yes
-USES= tar:bzip2
+USES= python:2.7+ tar:bzip2
WRKSRC_SUBDIR= libconcord/bindings/python
-USE_PYTHON= 2.7+
-USE_PYDISTUTILS=yes
+USE_PYTHON= distutils
.include <bsd.port.mk>
diff --git a/comms/py-lirc/Makefile b/comms/py-lirc/Makefile
index 265942d2985e..43278768844b 100644
--- a/comms/py-lirc/Makefile
+++ b/comms/py-lirc/Makefile
@@ -19,9 +19,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= %%PYTHON_SITELIBDIR%%/pylircmodule.so
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-USE_PYTHON_PREFIX= yes
+USES= python
+USE_PYTHON= distutils pythonprefix
PYDISTUTILS_PKGNAME= pylirc
.include <bsd.port.mk>
diff --git a/comms/py-serial/Makefile b/comms/py-serial/Makefile
index 3278a3a8a87c..df96188749d2 100644
--- a/comms/py-serial/Makefile
+++ b/comms/py-serial/Makefile
@@ -11,13 +11,12 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= sbz@FreeBSD.org
COMMENT= Serial port encapsulation library for Python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-USE_PYTHON_PREFIX= yes
+USES= python
+USE_PYTHON= distutils pythonprefix
PYDISTUTILS_PKGNAME= py${PORTNAME}
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/comms/pyla/Makefile b/comms/pyla/Makefile
index 1970c7f814ac..34aadfd68b73 100644
--- a/comms/pyla/Makefile
+++ b/comms/pyla/Makefile
@@ -19,7 +19,7 @@ COMMENT= Hylafax client written in Python
WRKSRC= ${WRKDIR}/${PORTNAME}
DATADIR= ${PREFIX}/lib/pyla
-USE_PYTHON= yes
+USES= python
PLIST= ${WRKDIR}/pkg-plist
.include <bsd.port.pre.mk>
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index 6447bbe342a9..d3915da0cfcf 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -19,11 +19,10 @@ LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
libasound.so:${PORTSDIR}/audio/alsa-lib \
libpulse.so:${PORTSDIR}/audio/pulseaudio
-USE_PYTHON= yes
+USES= python
+USE_PYTHON= distutils autoplist
USE_WX= 3.0+
WX_COMPS= python
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
post-extract:
${RM} ${WRKSRC}/_quisk.so ${WRKSRC}/sdriqpkg/sdriq.so
diff --git a/converters/gbsdconv/Makefile b/converters/gbsdconv/Makefile
index ce70905bef6a..40d9d75a9e9c 100644
--- a/converters/gbsdconv/Makefile
+++ b/converters/gbsdconv/Makefile
@@ -18,8 +18,8 @@ USE_GITHUB= yes
GH_ACCOUNT= buganini
GH_COMMIT= 0a9ad34
+USES= python
USE_GNOME= gtk30 introspection:run
-USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/converters/py-bsdconv/Makefile b/converters/py-bsdconv/Makefile
index 7c58e8140443..554508e1ec1d 100644
--- a/converters/py-bsdconv/Makefile
+++ b/converters/py-bsdconv/Makefile
@@ -19,8 +19,8 @@ GH_ACCOUNT= buganini
GH_COMMIT= 075a20e
GH_PROJECT= python-${PORTNAME}
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
diff --git a/converters/py-unidecode/Makefile b/converters/py-unidecode/Makefile
index d273cd2be9d0..9c4890565861 100644
--- a/converters/py-unidecode/Makefile
+++ b/converters/py-unidecode/Makefile
@@ -13,8 +13,7 @@ COMMENT= ASCII transliterations of Unicode text
LICENSE= GPLv2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/converters/py-zfec/Makefile b/converters/py-zfec/Makefile
index 7670f64cd23b..881207fe88e9 100644
--- a/converters/py-zfec/Makefile
+++ b/converters/py-zfec/Makefile
@@ -18,9 +18,8 @@ BUILD_DEPENDS= darcsver:${PORTSDIR}/devel/py-darcsver \
unsort:${PORTSDIR}/devel/py-pyutil
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/converters/zbase32/Makefile b/converters/zbase32/Makefile
index 4cb8ceb71506..9da85a5017ec 100644
--- a/converters/zbase32/Makefile
+++ b/converters/zbase32/Makefile
@@ -14,8 +14,7 @@ COMMENT= Base32 Encoder/Decoder
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_darcs>=1.2.11:${PORTSDIR}/devel/py-setuptools_darcs
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distuils autoplist
.include <bsd.port.mk>