aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-09-21 20:02:02 +0800
committermva <mva@FreeBSD.org>2013-09-21 20:02:02 +0800
commit023a7bf1df9f803386f4ee71c1c75e292cbc16fd (patch)
treea039bbabdd109f0d48c0857bbe1404efcf8990b1
parentc6b0811d2e0c68464ea97a11a2b0024423f836d4 (diff)
downloadfreebsd-ports-gnome-023a7bf1df9f803386f4ee71c1c75e292cbc16fd.tar.gz
freebsd-ports-gnome-023a7bf1df9f803386f4ee71c1c75e292cbc16fd.tar.zst
freebsd-ports-gnome-023a7bf1df9f803386f4ee71c1c75e292cbc16fd.zip
- Add mikmod support for audio/sdl_mixer and audio/sdl2_mixer
- While here, simplify the OPTIONS usage PR: ports/181695 Submitted by: Jan Beich <jbeich@tormail.org>
-rw-r--r--audio/sdl2_mixer/Makefile50
-rw-r--r--audio/sdl_mixer/Makefile46
2 files changed, 38 insertions, 58 deletions
diff --git a/audio/sdl2_mixer/Makefile b/audio/sdl2_mixer/Makefile
index 9bfac18b889e..cf32948206a9 100644
--- a/audio/sdl2_mixer/Makefile
+++ b/audio/sdl2_mixer/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sdl2_mixer
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL2_mixer-${PORTVERSION}
@@ -19,42 +20,31 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
-OPTIONS_DEFINE= FLUIDSYNTH MODPLUG FLAC VORBIS
+OPTIONS_DEFINE= FLUIDSYNTH FLAC VORBIS
OPTIONS_DEFAULT= FLUIDSYNTH MODPLUG FLAC VORBIS
+OPTIONS_RADIO= MOD
+OPTIONS_RADIO_MOD= MIKMOD MODPLUG
FLUIDSYNTH_DESC= Enable SoundFont2 Midi support via fluidsynth
+MIKMOD_DESC= Enable MOD music via libMikMod
MODPLUG_DESC= Enable MOD music via libModPlug
FLAC_DESC= Enable FLAC encoding support via flac
VORBIS_DESC= Enable Ogg Vorbis music
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMODPLUG}
-LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
-CONFIGURE_ARGS+= --enable-music-mod --enable-music-mod-modplug
-.else
-CONFIGURE_ARGS+= --disable-music-mod --disable-music-mod-modplug
-.endif
-
-.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
-CONFIGURE_ARGS+= --enable-music-flac
-.else
-CONFIGURE_ARGS+= --disable-music-flac
-.endif
-
-.if ${PORT_OPTIONS:MFLUIDSYNTH}
-LIB_DEPENDS+= fluidsynth:${PORTSDIR}/audio/fluidsynth
-CONFIGURE_ARGS+= --enable-music-midi --enable-music-midi-fluidsynth
-.else
-CONFIGURE_ARGS+= --disable-music-midi --disable-music-midi-fluidsynth
-.endif
-
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
-CONFIGURE_ARGS+= --enable-music-ogg
-.else
-CONFIGURE_ARGS+= --disable-music-ogg
-.endif
+MIKMOD_LIB_DEPENDS= libmikmod.so:${PORTSDIR}/audio/libmikmod
+MIKMOD_CONFIGURE_ENABLE= music-mod-mikmod
+
+MODPLUG_LIB_DEPENDS= libmodplug.so:${PORTSDIR}/audio/libmodplug
+MODPLUG_CONFIGURE_ENABLE= music-mod-modplug
+
+FLAC_LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac
+FLAC_CONFIGURE_ENABLE= music-flac
+
+FLUIDSYNTH_LIB_DEPENDS= fluidsynth:${PORTSDIR}/audio/fluidsynth
+FLUIDSYNTH_CONFIGURE_ON= --enable-music-midi --enable-music-midi-fluidsynth
+FLUIDSYNTH_CONFIGURE_OFF= --disable-music-midi --disable-music-midi-fluidsynth
+
+VORBIS_LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis
+VORBIS_CONFIGURE_ENABLE= music-ogg
.include <bsd.port.mk>
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 3df68689813c..eaf95a76398f 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sdl_mixer
PORTVERSION= 1.2.12
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL_mixer-${PORTVERSION}
@@ -22,44 +22,34 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
-OPTIONS_DEFINE= MIKMOD SMPEG FLAC VORBIS TIMIDITYPLUS
-OPTIONS_DEFAULT= MIKMOD SMPEG FLAC VORBIS
+OPTIONS_DEFINE= SMPEG FLAC VORBIS TIMIDITYPLUS
+OPTIONS_DEFAULT= SMPEG FLAC VORBIS
+OPTIONS_RADIO= MOD
+OPTIONS_RADIO_MOD= MIKMOD MODPLUG
MIKMOD_DESC= Enable MOD music via libMikMod
+MODPLUG_DESC= Enable MOD music via libModPlug
SMPEG_DESC= Enable MP3 music via SMPEG
FLAC_DESC= Enable FLAC encoding support via flac
VORBIS_DESC= Enable Ogg Vorbis music
TIMIDITYPLUS_DESC= Use Timidity++ instead of Timidity (soundfont)
-.include <bsd.port.pre.mk>
+MIKMOD_LIB_DEPENDS= libmikmod.so:${PORTSDIR}/audio/libmikmod
+MIKMOD_CONFIGURE_ENABLE= music-mod
-.if ${PORT_OPTIONS:MMIKMOD}
-LIB_DEPENDS+= mikmod:${PORTSDIR}/audio/libmikmod
-CONFIGURE_ARGS+= --enable-music-mod
-.else
-CONFIGURE_ARGS+= --disable-music-mod
-.endif
+MODPLUG_LIB_DEPENDS= libmodplug.so:${PORTSDIR}/audio/libmodplug
+MODPLUG_CONFIGURE_ENABLE= music-mod-modplug
-.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
-CONFIGURE_ARGS+= --enable-music-flac
-.else
-CONFIGURE_ARGS+= --disable-music-flac
-.endif
+FLAC_LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac
+FLAC_CONFIGURE_ENABLE= music-flac
-.if ${PORT_OPTIONS:MSMPEG}
-LIB_DEPENDS+= smpeg:${PORTSDIR}/multimedia/smpeg
-CONFIGURE_ARGS+= --enable-music-mp3
-.else
-CONFIGURE_ARGS+= --disable-music-mp3
-.endif
+SMPEG_LIB_DEPENDS= smpeg:${PORTSDIR}/multimedia/smpeg
+SMPEG_CONFIGURE_ENABLE= music-mp3
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
-CONFIGURE_ARGS+= --enable-music-ogg
-.else
-CONFIGURE_ARGS+= --disable-music-ogg
-.endif
+VORBIS_LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis
+VORBIS_CONFIGURE_ENABLE= music-ogg
+
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MTIMIDITYPLUS}
RUN_DEPENDS+= ${LOCALBASE}/share/timidity/timidity.cfg-eawpats:${PORTSDIR}/audio/eawpats