aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-09-13 01:03:57 +0800
committerrene <rene@FreeBSD.org>2011-09-13 01:03:57 +0800
commit1088d00fd0c42696290fd4722bcfff9f437ff5f3 (patch)
tree7ad866f8329dc23aa3e72946150d2f1007ee4206
parentcb629017dd67282263d929a8181c2a7160f52656 (diff)
downloadfreebsd-ports-gnome-1088d00fd0c42696290fd4722bcfff9f437ff5f3.tar.gz
freebsd-ports-gnome-1088d00fd0c42696290fd4722bcfff9f437ff5f3.tar.zst
freebsd-ports-gnome-1088d00fd0c42696290fd4722bcfff9f437ff5f3.zip
Switch to system ICU, this should fix building on 8.0-i386
Submitted by: pointyhat via erwin Obtained from: http://trillian.chruetertee.ch/chromium/changeset/218
-rw-r--r--www/chromium/Makefile4
-rw-r--r--www/chromium/files/patch-third_party__icu__icu.gyp12
-rw-r--r--www/chromium/files/patch-third_party__libphonenumber__libphonenumber.gyp24
-rw-r--r--www/chromium/files/patch-v8__src__extensions__experimental__experimental.gyp18
4 files changed, 57 insertions, 1 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index df313a06ec25..e3bedbeda56d 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -35,7 +35,8 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
freetype.9:${PORTSDIR}/print/freetype2 \
nss3.1:${PORTSDIR}/security/nss \
gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
- cups.2:${PORTSDIR}/print/cups-client
+ cups.2:${PORTSDIR}/print/cups-client \
+ icudata.48:${PORTSDIR}/devel/icu
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins \
${LOCALBASE}/lib/X11/fonts/Droid/fonts.dir:${PORTSDIR}/x11-fonts/droid-fonts-ttf \
@@ -66,6 +67,7 @@ GYP_DEFINES+= use_system_ffmpeg=0
#GYP_DEFINES+= use_system_sqlite=0
GYP_DEFINES+= use_system_yasm=1
#GYP_DEFINES+= use_system_zlib=1
+GYP_DEFINES+= use_system_icu=1
GYP_DEFINES+= python_ver=${PYTHON_VER}
GYP_DEFINES+= disable_nacl=1
GYP_DEFINES+= linux_use_heapchecker=1
diff --git a/www/chromium/files/patch-third_party__icu__icu.gyp b/www/chromium/files/patch-third_party__icu__icu.gyp
new file mode 100644
index 000000000000..12ce04006392
--- /dev/null
+++ b/www/chromium/files/patch-third_party__icu__icu.gyp
@@ -0,0 +1,12 @@
+--- third_party/icu/icu.gyp.orig 2011-09-11 20:07:49.787935237 +0300
++++ third_party/icu/icu.gyp 2011-09-11 20:09:30.972764759 +0300
+@@ -524,6 +524,9 @@
+ 'defines': [
+ 'USE_SYSTEM_ICU',
+ ],
++ 'include_dirs': [
++ '<!@(icu-config --prefix)/include',
++ ],
+ },
+ 'link_settings': {
+ 'ldflags': [
diff --git a/www/chromium/files/patch-third_party__libphonenumber__libphonenumber.gyp b/www/chromium/files/patch-third_party__libphonenumber__libphonenumber.gyp
new file mode 100644
index 000000000000..791458bc9730
--- /dev/null
+++ b/www/chromium/files/patch-third_party__libphonenumber__libphonenumber.gyp
@@ -0,0 +1,24 @@
+--- third_party/libphonenumber/libphonenumber.gyp.orig 2011-09-11 22:49:01.224163225 +0300
++++ third_party/libphonenumber/libphonenumber.gyp 2011-09-11 22:50:12.446499446 +0300
+@@ -14,8 +14,6 @@
+ 'cpp/src',
+ '<(protoc_out_dir)',
+ '../protobuf/src',
+- '../icu/public/common',
+- '../icu/public/i18n',
+ ],
+ 'defines': [
+ 'U_USING_ICU_NAMESPACE=0',
+@@ -26,6 +24,12 @@
+ 'U_STATIC_IMPLEMENTATION',
+ ],
+ }],
++ ['use_system_icu == 0', {
++ 'include_dirs': [
++ '../icu/public/common',
++ '../icu/public/i18n',
++ ],
++ }],
+ ],
+ },
+ 'targets': [{
diff --git a/www/chromium/files/patch-v8__src__extensions__experimental__experimental.gyp b/www/chromium/files/patch-v8__src__extensions__experimental__experimental.gyp
new file mode 100644
index 000000000000..c63a78205ab6
--- /dev/null
+++ b/www/chromium/files/patch-v8__src__extensions__experimental__experimental.gyp
@@ -0,0 +1,18 @@
+--- v8/src/extensions/experimental/experimental.gyp.orig 2011-09-03 12:13:16.000000000 +0300
++++ v8/src/extensions/experimental/experimental.gyp 2011-09-11 21:16:10.407508099 +0300
+@@ -51,8 +51,14 @@
+ 'language-matcher.h',
+ '<(SHARED_INTERMEDIATE_DIR)/i18n-js.cc',
+ ],
++ 'conditions': [
++ ['use_system_icu == 0', {
++ 'include_dirs': [
++ '<(icu_src_dir)/public/common',
++ ],
++ }],
++ ],
+ 'include_dirs': [
+- '<(icu_src_dir)/public/common',
+ '../..',
+ ],
+ 'dependencies': [