aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-01-13 07:05:00 +0800
committerlinimon <linimon@FreeBSD.org>2019-01-13 07:05:00 +0800
commit135b5ed4fd4c56821b28a222b03f0d03faaaf67c (patch)
tree8a00913f60a3dfc64e442b72913c8d60cd555e67
parenta013f9b55aace5e50fda5a0fd462a1bef7a30233 (diff)
downloadfreebsd-ports-gnome-135b5ed4fd4c56821b28a222b03f0d03faaaf67c.tar.gz
freebsd-ports-gnome-135b5ed4fd4c56821b28a222b03f0d03faaaf67c.tar.zst
freebsd-ports-gnome-135b5ed4fd4c56821b28a222b03f0d03faaaf67c.zip
Fix build on gcc-based architectures by removing the assumption that FreeBSD
must imply clang. While here, remove duplicate definition from USES. PR: 234580 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
-rw-r--r--databases/percona57-server/Makefile8
-rw-r--r--databases/percona57-server/files/patch-cmake_os_FreeBSD.cmake11
2 files changed, 16 insertions, 3 deletions
diff --git a/databases/percona57-server/Makefile b/databases/percona57-server/Makefile
index 1e48068509ab..177dcb34cbb9 100644
--- a/databases/percona57-server/Makefile
+++ b/databases/percona57-server/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libevent.so:devel/libevent \
SLAVEDIRS= databases/percona57-client \
databases/percona57-pam-for-mysql
-USES= bison:build cmake:insource,noninja compiler:c11 compiler:c++11-lib \
+USES= bison:build cmake:insource,noninja compiler:c11 \
cpe libedit localbase perl5 shebangfix
MY_DBDIR= /var/db/mysql
@@ -83,8 +83,6 @@ USES+= libedit
.else
LIB_DEPENDS+= libcurl.so:ftp/curl
-BROKEN_powerpc64= Does not configure: CMake Error at cmake/os/FreeBSD.cmake:34 (MESSAGE): Unsupported compiler!
-
# MySQL-Server part
OPTIONS_DEFINE= OPENSSL FASTMTX INNODBMEMCACHED TOKUDB
OPTIONS_DEFAULT= OPENSSL INNODBMEMCACHED
@@ -151,6 +149,10 @@ post-patch:
.include <bsd.port.pre.mk>
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+CXXFLAGS+= -fpermissive
+.endif
+
.if ${ARCH} == "arm"
BROKEN= Does not compile on arm
.endif
diff --git a/databases/percona57-server/files/patch-cmake_os_FreeBSD.cmake b/databases/percona57-server/files/patch-cmake_os_FreeBSD.cmake
new file mode 100644
index 000000000000..69ba328de060
--- /dev/null
+++ b/databases/percona57-server/files/patch-cmake_os_FreeBSD.cmake
@@ -0,0 +1,11 @@
+--- cmake/os/FreeBSD.cmake.orig 2018-12-16 19:27:57 UTC
++++ cmake/os/FreeBSD.cmake
+@@ -30,8 +30,6 @@ IF(NOT FORCE_UNSUPPORTED_COMPILER)
+ IF(NOT HAVE_SUPPORTED_CLANG_VERSION)
+ MESSAGE(FATAL_ERROR "Clang 3.3 or newer is required!")
+ ENDIF()
+- ELSE()
+- MESSAGE(FATAL_ERROR "Unsupported compiler!")
+ ENDIF()
+ ENDIF()
+