aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-09-01 20:42:19 +0800
committerfeld <feld@FreeBSD.org>2016-09-01 20:42:19 +0800
commit155831981a80dc5171a15b822fcbe4dd56474e7e (patch)
treed51d4cf25e288d7190fc4a0c323ecad1afe6cc41
parent96e99fc63500e74deb70fe4efd28e236fb785e75 (diff)
downloadfreebsd-ports-gnome-155831981a80dc5171a15b822fcbe4dd56474e7e.tar.gz
freebsd-ports-gnome-155831981a80dc5171a15b822fcbe4dd56474e7e.tar.zst
freebsd-ports-gnome-155831981a80dc5171a15b822fcbe4dd56474e7e.zip
This is a collection of modules ("vmods") extending Varnish VCL used for
describing HTTP request/response policies with additional capabilities. WWW: https://github.com/varnish/varnish-modules
-rw-r--r--www/Makefile1
-rw-r--r--www/varnish-modules/Makefile36
-rw-r--r--www/varnish-modules/distinfo3
-rw-r--r--www/varnish-modules/files/patch-src_Makefile.am22
-rw-r--r--www/varnish-modules/pkg-descr4
-rw-r--r--www/varnish-modules/pkg-plist9
6 files changed, 75 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 447610dd4316..926e8010a62c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2261,6 +2261,7 @@
SUBDIR += validator
SUBDIR += varnish-libvmod-maxminddb
SUBDIR += varnish-libvmod-saintmode
+ SUBDIR += varnish-modules
SUBDIR += varnish-nagios
SUBDIR += varnish4
SUBDIR += vdr-plugin-live
diff --git a/www/varnish-modules/Makefile b/www/varnish-modules/Makefile
new file mode 100644
index 000000000000..2ec9ec8f7509
--- /dev/null
+++ b/www/varnish-modules/Makefile
@@ -0,0 +1,36 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= modules
+DISTVERSION= 0.9.1
+CATEGORIES= www
+PKGNAMEPREFIX= varnish-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Collection of Varnish Cache modules by Varnish Software
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= varnish4>=4.1.0:www/varnish4 \
+ rst2man:textproc/py-docutils
+
+USES= autoreconf:build gmake libtool pkgconfig python:2,build
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
+INSTALL_TARGET= install-strip
+
+USE_GITHUB= yes
+GH_ACCOUNT= varnish
+GH_TAGNAME= varnish-modules-${DISTVERSION}
+
+MAKE_JOBS_UNSAFE= yes
+
+WRKSRC= ${WRKDIR}/varnish-modules-varnish-modules-${DISTVERSION}
+
+pre-configure:
+ cd ${WRKSRC} && ./bootstrap
+
+.include <bsd.port.mk>
diff --git a/www/varnish-modules/distinfo b/www/varnish-modules/distinfo
new file mode 100644
index 000000000000..b94b12a61e36
--- /dev/null
+++ b/www/varnish-modules/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469368533
+SHA256 (varnish-modules-0.9.1_GH0.tar.gz) = 4fa7d042968a372c0fd0efa7925f94640ad180e3d667697fe521e485134eb728
+SIZE (varnish-modules-0.9.1_GH0.tar.gz) = 46364
diff --git a/www/varnish-modules/files/patch-src_Makefile.am b/www/varnish-modules/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..d8a428d88f5e
--- /dev/null
+++ b/www/varnish-modules/files/patch-src_Makefile.am
@@ -0,0 +1,22 @@
+--- src/Makefile.am.orig 2016-08-01 13:40:08 UTC
++++ src/Makefile.am
+@@ -5,7 +5,6 @@ vmod_LTLIBRARIES = libvmod_cookie.la \
+ libvmod_header.la \
+ libvmod_saintmode.la \
+ libvmod_softpurge.la \
+- libvmod_tcp.la \
+ libvmod_var.la \
+ libvmod_vsthrottle.la \
+ libvmod_xkey.la
+@@ -40,11 +39,6 @@ libvmod_softpurge_la_SOURCES = \
+ vcc_softpurge_if.c vcc_softpurge_if.h: @VMODTOOL@ $(top_srcdir)/src/vmod_softpurge.vcc
+ @VMODTOOL@ -w ../docs/ -o vcc_softpurge_if $(top_srcdir)/src/vmod_softpurge.vcc
+
+-libvmod_tcp_la_LDFLAGS = $(AM_LDFLAGS) -module -export-dynamic -avoid-version -shared
+-libvmod_tcp_la_SOURCES = vcc_tcp_if.c vcc_tcp_if.h vmod_tcp.c
+-vcc_tcp_if.c vcc_tcp_if.h: @VMODTOOL@ $(top_srcdir)/src/vmod_tcp.vcc
+- @VMODTOOL@ -w ../docs/ -o vcc_tcp_if $(top_srcdir)/src/vmod_tcp.vcc
+-
+ libvmod_var_la_LDFLAGS = $(AM_LDFLAGS) -module -export-dynamic -avoid-version -shared
+ libvmod_var_la_SOURCES = vcc_var_if.c vcc_var_if.h vmod_var.c
+ vcc_var_if.c vcc_var_if.h: @VMODTOOL@ $(top_srcdir)/src/vmod_var.vcc
diff --git a/www/varnish-modules/pkg-descr b/www/varnish-modules/pkg-descr
new file mode 100644
index 000000000000..3d683fa9658f
--- /dev/null
+++ b/www/varnish-modules/pkg-descr
@@ -0,0 +1,4 @@
+This is a collection of modules ("vmods") extending Varnish VCL used for
+describing HTTP request/response policies with additional capabilities.
+
+WWW: https://github.com/varnish/varnish-modules
diff --git a/www/varnish-modules/pkg-plist b/www/varnish-modules/pkg-plist
new file mode 100644
index 000000000000..9f957b77c843
--- /dev/null
+++ b/www/varnish-modules/pkg-plist
@@ -0,0 +1,9 @@
+lib/varnish/vmods/libvmod_cookie.so
+lib/varnish/vmods/libvmod_header.so
+lib/varnish/vmods/libvmod_saintmode.so
+lib/varnish/vmods/libvmod_softpurge.so
+lib/varnish/vmods/libvmod_var.so
+lib/varnish/vmods/libvmod_vsthrottle.so
+lib/varnish/vmods/libvmod_xkey.so
+%%PORTDOCS%%share/doc/varnish-modules/LICENSE
+%%PORTDOCS%%share/doc/varnish-modules/README.rst