aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-07-20 09:16:56 +0800
committerhrs <hrs@FreeBSD.org>2015-07-20 09:16:56 +0800
commit19d054661044b81c1a61b49121a5578588bc81d2 (patch)
tree28396d5fd3e3bfc5ceaddf70c1b4310cd9350619
parentecfc32f5935d98ef6a3ee315ddd2d125ddf38e4f (diff)
downloadfreebsd-ports-gnome-19d054661044b81c1a61b49121a5578588bc81d2.tar.gz
freebsd-ports-gnome-19d054661044b81c1a61b49121a5578588bc81d2.tar.zst
freebsd-ports-gnome-19d054661044b81c1a61b49121a5578588bc81d2.zip
- Add print/latex-biber, a biblatex replacement which supports Unicode.
- Add or update the following ports which latex-biber depends on: japanese/p5-Encode-EUCJPASCII (added, eucJP-open encoding support) misc/p5-Business-ISMN (added, ISMN support) textproc/p5-Text-BibTeX (updated to 0.71) textproc/p5-Text-Roman (added, conversion of Roman numerals)
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/p5-Encode-EUCJPASCII/Makefile24
-rw-r--r--japanese/p5-Encode-EUCJPASCII/distinfo2
-rw-r--r--japanese/p5-Encode-EUCJPASCII/pkg-descr13
-rw-r--r--japanese/p5-Encode-EUCJPASCII/pkg-plist2
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Business-ISMN/Makefile18
-rw-r--r--misc/p5-Business-ISMN/distinfo2
-rw-r--r--misc/p5-Business-ISMN/pkg-descr3
-rw-r--r--misc/p5-Business-ISMN/pkg-plist4
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-biber/Makefile49
-rw-r--r--print/latex-biber/distinfo2
-rw-r--r--print/latex-biber/pkg-descr4
-rw-r--r--print/latex-biber/pkg-plist66
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-BibTeX/Makefile13
-rw-r--r--textproc/p5-Text-BibTeX/distinfo4
-rw-r--r--textproc/p5-Text-Roman/Makefile18
-rw-r--r--textproc/p5-Text-Roman/distinfo2
-rw-r--r--textproc/p5-Text-Roman/pkg-descr5
-rw-r--r--textproc/p5-Text-Roman/pkg-plist2
22 files changed, 232 insertions, 5 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index fbdaec0b1cf7..3b0bd1ac95ae 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -190,6 +190,7 @@
SUBDIR += p5-Date-Japanese-Holiday
SUBDIR += p5-DateTime-Calendar-Japanese-Era
SUBDIR += p5-DateTime-Format-Japanese
+ SUBDIR += p5-Encode-EUCJPASCII
SUBDIR += p5-Encode-EUCJPMS
SUBDIR += p5-Encode-ISO2022
SUBDIR += p5-Encode-JP-Emoji
diff --git a/japanese/p5-Encode-EUCJPASCII/Makefile b/japanese/p5-Encode-EUCJPASCII/Makefile
new file mode 100644
index 000000000000..b43a2536704c
--- /dev/null
+++ b/japanese/p5-Encode-EUCJPASCII/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= Encode-EUCJPASCII
+PORTVERSION= 0.03
+CATEGORIES= japanese converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= ja-p5-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Perl5 module for eucJP-open
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ for F in ${SITE_ARCH}/auto/Encode/EUCJPASCII/EUCJPASCII.so; do \
+ ${CHMOD} +w ${STAGEDIR}$$F; \
+ ${STRIP_CMD} ${STAGEDIR}$$F; \
+ done
+
+.include <bsd.port.mk>
diff --git a/japanese/p5-Encode-EUCJPASCII/distinfo b/japanese/p5-Encode-EUCJPASCII/distinfo
new file mode 100644
index 000000000000..03660b45f19c
--- /dev/null
+++ b/japanese/p5-Encode-EUCJPASCII/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Encode-EUCJPASCII-0.03.tar.gz) = f998d34d55fd9c82cf910786a0448d1edfa60bf68e2c2306724ca67c629de861
+SIZE (Encode-EUCJPASCII-0.03.tar.gz) = 131775
diff --git a/japanese/p5-Encode-EUCJPASCII/pkg-descr b/japanese/p5-Encode-EUCJPASCII/pkg-descr
new file mode 100644
index 000000000000..0fbd4f5098ea
--- /dev/null
+++ b/japanese/p5-Encode-EUCJPASCII/pkg-descr
@@ -0,0 +1,13 @@
+This is a Perl5 module that defines eucJP-open encodings.
+
+Encodings supported are as follows:
+
+ Canonical Alias Description
+ --------------------------------------------------------------
+ eucJP-ascii eucJP-ascii
+ qr/\beuc-?jp(-?open)?(-?19970715)?-?ascii$/i
+ x-iso2022jp-ascii 7-bit counterpart
+ qr/\b(x-)?iso-?2022-?jp-?ascii$/i
+ --------------------------------------------------------------
+
+WWW: http://search.cpan.org/dist/Unicode-Japanese/
diff --git a/japanese/p5-Encode-EUCJPASCII/pkg-plist b/japanese/p5-Encode-EUCJPASCII/pkg-plist
new file mode 100644
index 000000000000..683ba9a3c7f3
--- /dev/null
+++ b/japanese/p5-Encode-EUCJPASCII/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_ARCH%%/Encode/EUCJPASCII.pm
+%%SITE_ARCH%%/auto/Encode/EUCJPASCII/EUCJPASCII.so
diff --git a/misc/Makefile b/misc/Makefile
index 8dc1df3d4c35..0699f0a6696a 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -301,6 +301,7 @@
SUBDIR += p5-Business-ISBN
SUBDIR += p5-Business-ISBN-Data
SUBDIR += p5-Business-ISIN
+ SUBDIR += p5-Business-ISMN
SUBDIR += p5-Business-ISSN
SUBDIR += p5-Business-UPS
SUBDIR += p5-Chatbot-Eliza
diff --git a/misc/p5-Business-ISMN/Makefile b/misc/p5-Business-ISMN/Makefile
new file mode 100644
index 000000000000..026b1d85d765
--- /dev/null
+++ b/misc/p5-Business-ISMN/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= Business-ISMN
+PORTVERSION= 1.13
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Work with International Standard Music Numbers
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Business-ISMN/distinfo b/misc/p5-Business-ISMN/distinfo
new file mode 100644
index 000000000000..77e1f527d59b
--- /dev/null
+++ b/misc/p5-Business-ISMN/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Business-ISMN-1.13.tar.gz) = 89b598dcde116732f8621b18660fec9a6989b1ad5bf96599b98fbcaecad9a132
+SIZE (Business-ISMN-1.13.tar.gz) = 9703
diff --git a/misc/p5-Business-ISMN/pkg-descr b/misc/p5-Business-ISMN/pkg-descr
new file mode 100644
index 000000000000..6e4135ec524d
--- /dev/null
+++ b/misc/p5-Business-ISMN/pkg-descr
@@ -0,0 +1,3 @@
+Work with International Standard Music Numbers.
+
+WWW: http://search.cpan.org/dist/Business-ISMN/
diff --git a/misc/p5-Business-ISMN/pkg-plist b/misc/p5-Business-ISMN/pkg-plist
new file mode 100644
index 000000000000..8d1b95453d24
--- /dev/null
+++ b/misc/p5-Business-ISMN/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Business/ISMN.pm
+%%SITE_PERL%%/Business/ISMN/Data.pm
+%%PERL5_MAN3%%/Business::ISMN.3.gz
+%%PERL5_MAN3%%/Business::ISMN::Data.3.gz
diff --git a/print/Makefile b/print/Makefile
index cc4a9ddefc01..c5bd2294e2b6 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -105,6 +105,7 @@
SUBDIR += kover
SUBDIR += kpdftool
SUBDIR += latex-beamer
+ SUBDIR += latex-biber
SUBDIR += latex-ltablex
SUBDIR += latex-resume
SUBDIR += latex2rtf
diff --git a/print/latex-biber/Makefile b/print/latex-biber/Makefile
new file mode 100644
index 000000000000..38926ed38b71
--- /dev/null
+++ b/print/latex-biber/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= biber
+PORTVERSION= 2.1
+CATEGORIES= print perl5
+PKGNAMEPREFIX= latex-
+DIST_SUBDIR= TeX
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= BibTeX replacement for users of biblatex
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+__DEPENDS= \
+ ja-p5-Encode-EUCJPASCII>0:${PORTSDIR}/japanese/p5-Encode-EUCJPASCII \
+ p5-Business-ISBN>0:${PORTSDIR}/misc/p5-Business-ISBN \
+ p5-Business-ISMN>0:${PORTSDIR}/misc/p5-Business-ISMN \
+ p5-Business-ISSN>0:${PORTSDIR}/misc/p5-Business-ISSN \
+ p5-Config-AutoConf>0:${PORTSDIR}/devel/p5-Config-AutoConf \
+ p5-Data-Compare>0:${PORTSDIR}/devel/p5-Data-Compare \
+ p5-Date-Simple>0:${PORTSDIR}/devel/p5-Date-Simple \
+ p5-Encode-HanExtra>0:${PORTSDIR}/chinese/p5-Encode-HanExtra \
+ p5-Encode-JIS2K>0:${PORTSDIR}/converters/p5-Encode-JIS2K \
+ p5-ExtUtils-LibBuilder>0:${PORTSDIR}/devel/p5-ExtUtils-LibBuilder \
+ p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-IPC-Run3>0:${PORTSDIR}/devel/p5-IPC-Run3 \
+ p5-Log-Log4perl>0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Module-Build>=0.4206:${PORTSDIR}/devel/p5-Module-Build \
+ p5-Regexp-Common>0:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Text-BibTeX>0:${PORTSDIR}/textproc/p5-Text-BibTeX \
+ p5-Text-Roman>0:${PORTSDIR}/textproc/p5-Text-Roman \
+ p5-Unicode-Collate>0:${PORTSDIR}/textproc/p5-Unicode-Collate \
+ p5-Unicode-LineBreak>0:${PORTSDIR}/textproc/p5-Unicode-LineBreak \
+ p5-XML-LibXML-Simple>0:${PORTSDIR}/textproc/p5-XML-LibXML-Simple \
+ p5-XML-LibXSLT>0:${PORTSDIR}/textproc/p5-XML-LibXSLT \
+ p5-XML-Writer>0:${PORTSDIR}/textproc/p5-XML-Writer \
+ p5-autovivification>0:${PORTSDIR}/devel/p5-autovivification
+BUILD_DEPENDS= ${__DEPENDS}
+RUN_DEPENDS= ${__DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild
+USE_TEX= texmf
+USE_GITHUB= yes
+GH_ACCOUNT= plk
+GH_TAGNAME= v${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/print/latex-biber/distinfo b/print/latex-biber/distinfo
new file mode 100644
index 000000000000..175b26cc12dc
--- /dev/null
+++ b/print/latex-biber/distinfo
@@ -0,0 +1,2 @@
+SHA256 (TeX/plk-biber-2.1-v2.1_GH0.tar.gz) = 7b20049557869a994ed9e0373f620720370981b6412ca415f0408d1af893f8f4
+SIZE (TeX/plk-biber-2.1-v2.1_GH0.tar.gz) = 2222706
diff --git a/print/latex-biber/pkg-descr b/print/latex-biber/pkg-descr
new file mode 100644
index 000000000000..8721ba869dc6
--- /dev/null
+++ b/print/latex-biber/pkg-descr
@@ -0,0 +1,4 @@
+Biber is a BibTeX replacement for users of biblatex, with full Unicode
+support.
+
+WWW: http://biblatex-biber.sourceforge.net/
diff --git a/print/latex-biber/pkg-plist b/print/latex-biber/pkg-plist
new file mode 100644
index 000000000000..b42e25672b0e
--- /dev/null
+++ b/print/latex-biber/pkg-plist
@@ -0,0 +1,66 @@
+bin/biber
+man/man1/biber.1.gz
+%%PERL5_MAN3%%/Biber.3.gz
+%%PERL5_MAN3%%/Biber::Config.3.gz
+%%PERL5_MAN3%%/Biber::Constants.3.gz
+%%PERL5_MAN3%%/Biber::DataModel.3.gz
+%%PERL5_MAN3%%/Biber::Entries.3.gz
+%%PERL5_MAN3%%/Biber::Entry.3.gz
+%%PERL5_MAN3%%/Biber::Entry::Name.3.gz
+%%PERL5_MAN3%%/Biber::Entry::Names.3.gz
+%%PERL5_MAN3%%/Biber::Input::file::biblatexml.3.gz
+%%PERL5_MAN3%%/Biber::Input::file::bibtex.3.gz
+%%PERL5_MAN3%%/Biber::Input::file::endnotexml.3.gz
+%%PERL5_MAN3%%/Biber::Input::file::ris.3.gz
+%%PERL5_MAN3%%/Biber::Input::file::zoterordfxml.3.gz
+%%PERL5_MAN3%%/Biber::Internals.3.gz
+%%PERL5_MAN3%%/Biber::LaTeX::Recode.3.gz
+%%PERL5_MAN3%%/Biber::Output::base.3.gz
+%%PERL5_MAN3%%/Biber::Output::bbl.3.gz
+%%PERL5_MAN3%%/Biber::Output::biblatexml.3.gz
+%%PERL5_MAN3%%/Biber::Output::bibtex.3.gz
+%%PERL5_MAN3%%/Biber::Output::dot.3.gz
+%%PERL5_MAN3%%/Biber::Output::test.3.gz
+%%PERL5_MAN3%%/Biber::Section.3.gz
+%%PERL5_MAN3%%/Biber::Sections.3.gz
+%%PERL5_MAN3%%/Biber::SortList.3.gz
+%%PERL5_MAN3%%/Biber::SortLists.3.gz
+%%PERL5_MAN3%%/Biber::UCollate.3.gz
+%%PERL5_MAN3%%/Biber::Utils.3.gz
+%%SITE_PERL%%/Biber.pm
+%%SITE_PERL%%/Biber/Config.pm
+%%SITE_PERL%%/Biber/Constants.pm
+%%SITE_PERL%%/Biber/DataModel.pm
+%%SITE_PERL%%/Biber/Entries.pm
+%%SITE_PERL%%/Biber/Entry.pm
+%%SITE_PERL%%/Biber/Entry/Name.pm
+%%SITE_PERL%%/Biber/Entry/Names.pm
+%%SITE_PERL%%/Biber/Input/file/biblatexml.pm
+%%SITE_PERL%%/Biber/Input/file/bibtex.pm
+%%SITE_PERL%%/Biber/Input/file/endnotexml.pm
+%%SITE_PERL%%/Biber/Input/file/ris.pm
+%%SITE_PERL%%/Biber/Input/file/zoterordfxml.pm
+%%SITE_PERL%%/Biber/Internals.pm
+%%SITE_PERL%%/Biber/LaTeX/Recode.pm
+%%SITE_PERL%%/Biber/LaTeX/recode_data.xml
+%%SITE_PERL%%/Biber/Output/base.pm
+%%SITE_PERL%%/Biber/Output/bbl.pm
+%%SITE_PERL%%/Biber/Output/biblatexml.pm
+%%SITE_PERL%%/Biber/Output/bibtex.pm
+%%SITE_PERL%%/Biber/Output/dot.pm
+%%SITE_PERL%%/Biber/Output/test.pm
+%%SITE_PERL%%/Biber/Section.pm
+%%SITE_PERL%%/Biber/Sections.pm
+%%SITE_PERL%%/Biber/SortList.pm
+%%SITE_PERL%%/Biber/SortLists.pm
+%%SITE_PERL%%/Biber/UCollate.pm
+%%SITE_PERL%%/Biber/Utils.pm
+%%SITE_PERL%%/Biber/bcf.rnc
+%%SITE_PERL%%/Biber/bcf.rng
+%%SITE_PERL%%/Biber/bcf.xsl
+%%SITE_PERL%%/Biber/biber-tool.conf
+%%SITE_PERL%%/Biber/biblatexml.rnc
+%%SITE_PERL%%/Biber/biblatexml.rng
+%%SITE_PERL%%/Biber/config.rnc
+%%SITE_PERL%%/Biber/config.rng
+%%SITE_PERL%%/Unicode/Collate/latinkeys.txt
diff --git a/textproc/Makefile b/textproc/Makefile
index 459156223c2b..51d3adf3e35e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -870,6 +870,7 @@
SUBDIR += p5-Text-Reform
SUBDIR += p5-Text-Report
SUBDIR += p5-Text-Repository
+ SUBDIR += p5-Text-Roman
SUBDIR += p5-Text-Sass
SUBDIR += p5-Text-Shellwords
SUBDIR += p5-Text-Similarity
diff --git a/textproc/p5-Text-BibTeX/Makefile b/textproc/p5-Text-BibTeX/Makefile
index 6e4cb644068c..343954aa9a4b 100644
--- a/textproc/p5-Text-BibTeX/Makefile
+++ b/textproc/p5-Text-BibTeX/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= Text-BibTeX
-PORTVERSION= 0.69
-PORTREVISION= 1
+PORTVERSION= 0.71
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:AMBS/Text
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
@@ -29,4 +27,13 @@ USE_LDCONFIG= yes
CFLAGS+= -fPIC
.endif
+STRIP_FILES= bin/dumpnames bin/biblex bin/bibparse \
+ ${SITE_ARCH_REL}/auto/Text/BibTeX/BibTeX.so \
+ lib/libbtparse.so
+
+post-install:
+ cd ${STAGEDIR}${PREFIX} && \
+ ${CHMOD} +w ${STRIP_FILES} && \
+ ${STRIP_CMD} ${STRIP_FILES}
+
.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-BibTeX/distinfo b/textproc/p5-Text-BibTeX/distinfo
index 46e0e9e2159b..55fb6de9f244 100644
--- a/textproc/p5-Text-BibTeX/distinfo
+++ b/textproc/p5-Text-BibTeX/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Text-BibTeX-0.69.tar.gz) = 7fccd930786c0fd0c5f23b36b960fd95e03c43beefd4587009d7bd27e02ff0bf
-SIZE (Text-BibTeX-0.69.tar.gz) = 285395
+SHA256 (Text-BibTeX-0.71.tar.gz) = cd0cc875b011aba4923b91caf65e448ed39148652e62c3fc4d4e074a982791cb
+SIZE (Text-BibTeX-0.71.tar.gz) = 285938
diff --git a/textproc/p5-Text-Roman/Makefile b/textproc/p5-Text-Roman/Makefile
new file mode 100644
index 000000000000..941beb250bba
--- /dev/null
+++ b/textproc/p5-Text-Roman/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= Text-Roman
+PORTVERSION= 3.5
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Allows conversion between Roman and Arabic algarisms
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Roman/distinfo b/textproc/p5-Text-Roman/distinfo
new file mode 100644
index 000000000000..f00c269c98a9
--- /dev/null
+++ b/textproc/p5-Text-Roman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Text-Roman-3.5.tar.gz) = cb4a08a3b151802ffb2fce3258a416542ab81db0f739ee474a9583ffb73e046a
+SIZE (Text-Roman-3.5.tar.gz) = 18122
diff --git a/textproc/p5-Text-Roman/pkg-descr b/textproc/p5-Text-Roman/pkg-descr
new file mode 100644
index 000000000000..7de2b6ac10d7
--- /dev/null
+++ b/textproc/p5-Text-Roman/pkg-descr
@@ -0,0 +1,5 @@
+This package supports both conventional Roman algarisms (which range
+from *1* to *3999*) and Milhar Romans, a variation which uses a bar
+across the algarism to indicate multiplication by *1_000*.
+
+WWW: http://search.cpan.org/dist/Text-Roman/
diff --git a/textproc/p5-Text-Roman/pkg-plist b/textproc/p5-Text-Roman/pkg-plist
new file mode 100644
index 000000000000..2ec444a58c9e
--- /dev/null
+++ b/textproc/p5-Text-Roman/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Text/Roman.pm
+%%PERL5_MAN3%%/Text::Roman.3.gz