aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-01-24 15:52:55 +0800
committertg <tg@FreeBSD.org>1997-01-24 15:52:55 +0800
commit1ebb90a44466c8d0075ed692fad0acf3ea20fc71 (patch)
tree1ea3b542577ca9c884c1e7f89bbcb1b5db62365e
parent0bf931a596ed1d39570cbbae38dce471cf7ab0f4 (diff)
downloadfreebsd-ports-gnome-1ebb90a44466c8d0075ed692fad0acf3ea20fc71.tar.gz
freebsd-ports-gnome-1ebb90a44466c8d0075ed692fad0acf3ea20fc71.tar.zst
freebsd-ports-gnome-1ebb90a44466c8d0075ed692fad0acf3ea20fc71.zip
Use rpm2cpio for extracting.
-rw-r--r--games/xgammon/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/xgammon/Makefile b/games/xgammon/Makefile
index e25576dc4c4b..e1b990b5f7b8 100644
--- a/games/xgammon/Makefile
+++ b/games/xgammon/Makefile
@@ -3,7 +3,7 @@
# Date created: 02 January 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/01/03 08:15:44 tg Exp $
#
DISTNAME= xgammon-0.98
@@ -15,6 +15,8 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= tg@FreeBSD.ORG
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/misc/rpm
+
NO_WRKSUBDIR= yes
USE_IMAKE= yes
@@ -25,8 +27,7 @@ do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
.endif
- @dd if=${_DISTDIR}${DISTFILES} bs=1706 skip=1 | gzip -cd | \
- (cd ${WRKDIR}; cpio -i)
+ @rpm2cpio ${_DISTDIR}${DISTFILES} | (cd ${WRKDIR}; cpio -i)
@tar -xzf ${WRKDIR}/${DISTNAME}.tar.gz -C ${WRKDIR}
pre-patch: