aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-05-02 14:21:22 +0800
committermakc <makc@FreeBSD.org>2010-05-02 14:21:22 +0800
commit20e54ceb0aedbf2fc07c6cee12e9515d7248e010 (patch)
tree69d20c3480448192d564f5e712b7266d521b5fed
parent3f98e46725fef55e2873f03f9770e880a9e6d0e0 (diff)
downloadfreebsd-ports-gnome-20e54ceb0aedbf2fc07c6cee12e9515d7248e010.tar.gz
freebsd-ports-gnome-20e54ceb0aedbf2fc07c6cee12e9515d7248e010.tar.zst
freebsd-ports-gnome-20e54ceb0aedbf2fc07c6cee12e9515d7248e010.zip
Add new port editors/textroom:
TextRoom and all other similar editors share one goal: to get you writing right away by providing distraction free environment to your liking, as well as familiar set of keyboard shortcuts to control its behavior. If you don't feel comfortable already with your editor of choice, you may find it useful. WWW: http://code.google.com/p/textroom/ PR: based on ports/146103 Submitted by: Michael James Brune <admin at mjbrune.org>
-rw-r--r--editors/textroom/Makefile38
-rw-r--r--editors/textroom/distinfo3
-rw-r--r--editors/textroom/files/patch-textroom.pro54
-rw-r--r--editors/textroom/pkg-descr7
-rw-r--r--editors/textroom/pkg-plist16
5 files changed, 118 insertions, 0 deletions
diff --git a/editors/textroom/Makefile b/editors/textroom/Makefile
new file mode 100644
index 000000000000..bd1e88d15561
--- /dev/null
+++ b/editors/textroom/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: textroom
+# Date created: 27 April 2010
+# Whom: admin@mjbrune.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= textroom
+PORTVERSION= 0.6.3.2
+CATEGORIES= editors
+MASTER_SITES= SF
+
+MAINTAINER= admin@mjbrune.org
+COMMENT= A full screen text editor
+
+BUILD_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
+LIB_DEPENDS= hunspell-1.2:${PORTSDIR}/hungarian/hunspell
+RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
+
+USE_SDL= mixer
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build corelib gui
+QMAKE_ARGS= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
+HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lhunspell|-lhunspell-1.2|' ${WRKSRC}/textroom.pro
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS} textroom.pro
+
+post-install:
+ @-update-mime-database ${PREFIX}/share/mime
+
+.include <bsd.port.mk>
diff --git a/editors/textroom/distinfo b/editors/textroom/distinfo
new file mode 100644
index 000000000000..98b81190bb8e
--- /dev/null
+++ b/editors/textroom/distinfo
@@ -0,0 +1,3 @@
+MD5 (textroom-0.6.3.2.tar.gz) = 7c3bfb18bfca13807957de96a5a3ecdb
+SHA256 (textroom-0.6.3.2.tar.gz) = 3f117c5409cf0d2382addc5ace4b23b555c4c3a21e72c1084c7a2098319425e0
+SIZE (textroom-0.6.3.2.tar.gz) = 4949646
diff --git a/editors/textroom/files/patch-textroom.pro b/editors/textroom/files/patch-textroom.pro
new file mode 100644
index 000000000000..f06dfe2fffa5
--- /dev/null
+++ b/editors/textroom/files/patch-textroom.pro
@@ -0,0 +1,54 @@
+--- ./textroom.pro.orig 2010-04-21 18:41:54.000000000 +0400
++++ ./textroom.pro 2010-05-01 02:27:57.894111731 +0400
+@@ -7,9 +7,9 @@
+ INCLUDEPATH += . \
+ src \
+ src/include \
+- /usr/include \
+- /usr/include/hunspell \
+- /usr/include/SDL
++ $$LOCALBASE/include \
++ $$LOCALBASE/include/hunspell \
++ $$LOCALBASE/include/SDL
+ DESTDIR += .
+ OBJECTS_DIR += temp
+ MOC_DIR += temp
+@@ -40,7 +40,6 @@
+ dict \
+ target \
+ desktop \
+- uninstaller \
+ mime \
+ icon
+ LIBS = -lSDL \
+@@ -50,22 +49,19 @@
+ QT += core \
+ gui
+
+-data.path = /usr/share/sounds
++data.path = $$PREFIX/share/sounds
+ data.files = resource/sounds/*
+-target.path = /usr/bin
+-desktop.path = /usr/share/applications
++target.path = $$PREFIX/bin
++desktop.path = $$PREFIX/share/applications
+ desktop.files = resource/desktop/textroom.desktop
+-doc-icon.path = /usr/share/textroom
++doc-icon.path = $$PREFIX/share/textroom
+ doc-icon.files = resource/images/textroom-doc.png
+-mime.path = /usr/share/textroom
++mime.path = $$PREFIX/share/mime/packages
+ mime.files = resource/desktop/textroom-txr-mime.xml
+-uninstaller.path = /usr/bin
++uninstaller.path = $$PREFIX/bin
+ uninstaller.files = resource/desktop/textroom-uninstall
+-dict.path = /usr/share/myspell/dicts
++dict.path = $$PREFIX/share/myspell/dicts
+ dict.files = resource/dict/*
+-icon.path = /usr/share/pixmaps
++icon.path = $$PREFIX/share/pixmaps
+ icon.files = resource/images/textroom.png
+
+-unix:system(xdg-icon-resource install --context mimetypes --size 48 ./resource/images/textroom-doc.png application/x-txr)
+-unix:system(xdg-mime install ./resource/desktop/textroom-txr-mime.xml)
+-unix:system(xdg-mime default textroom.desktop application/x-txr)
diff --git a/editors/textroom/pkg-descr b/editors/textroom/pkg-descr
new file mode 100644
index 000000000000..6f5766f2ebf2
--- /dev/null
+++ b/editors/textroom/pkg-descr
@@ -0,0 +1,7 @@
+TextRoom and all other similar editors share one goal: to get you
+writing right away by providing distraction free environment to
+your liking, as well as familiar set of keyboard shortcuts to control
+its behavior. If you don't feel comfortable already with your editor
+of choice, you may find it useful.
+
+WWW: http://code.google.com/p/textroom/
diff --git a/editors/textroom/pkg-plist b/editors/textroom/pkg-plist
new file mode 100644
index 000000000000..2a18230e4ecc
--- /dev/null
+++ b/editors/textroom/pkg-plist
@@ -0,0 +1,16 @@
+bin/textroom
+share/applications/textroom.desktop
+share/mime/packages/textroom-txr-mime.xml
+share/myspell/dicts/tr.aff
+share/myspell/dicts/tr.dic
+share/pixmaps/textroom.png
+share/sounds/keyany.wav
+share/sounds/keyenter.wav
+@dirrmtry share/sounds
+@dirrmtry share/myspell/dicts
+@dirrmtry share/myspell
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true