aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2007-07-16 01:09:08 +0800
committergerald <gerald@FreeBSD.org>2007-07-16 01:09:08 +0800
commit21a4fd543823214f04c29ea9eca6e63c54545b42 (patch)
treec662adfa561c25e7a2b8cab9b392de299b681b20
parent37a563eb59cc437c1d7f77068d3afb8c23ce030d (diff)
downloadfreebsd-ports-gnome-21a4fd543823214f04c29ea9eca6e63c54545b42.tar.gz
freebsd-ports-gnome-21a4fd543823214f04c29ea9eca6e63c54545b42.tar.zst
freebsd-ports-gnome-21a4fd543823214f04c29ea9eca6e63c54545b42.zip
Update to Wine 0.9.41. Among others, this brings the following changes:
- A number of gdiplus functions. - More complete pdh.dll implementation. - Support for MSI remote calls. - Messaging support in crypt32.dll. - Lots of bug fixes. Handle the wineg++.1 man page via MLINK instead of removing it. Make ${PREFIX}/lib/libwine.so a relative link. Refer to LOCALBASE instead of PREFIX in setting CONFIGURE_ENV. Remove LIBS=-Wl,-rpath,${PREFIX}/lib/wine which was added in revision 1.86 for PR19562 but is not needed any longer. [1] Support DATADIR. Submitted by: Tijl Coosemans <tijl@ulyssis.org> [1]
-rw-r--r--emulators/wine-devel/Makefile13
-rw-r--r--emulators/wine-devel/distinfo6
-rw-r--r--emulators/wine-devel/pkg-plist98
-rw-r--r--emulators/wine/Makefile13
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/pkg-plist98
6 files changed, 120 insertions, 114 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index b4740151b5d2..6a44ffed2218 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.40
+PORTVERSION= 0.9.41
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -23,14 +23,14 @@ LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
xml2:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
- LIBS=-Wl,-rpath,${PREFIX}/lib/wine \
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --datadir=${DATADIR}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
EXTRA_BINARIES="wine-kthread"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
+MLINKS= winegcc.1 wineg++.1
ONLY_FOR_ARCHS= i386
USE_BISON= yes
USE_BZIP2= yes
@@ -51,9 +51,8 @@ pre-build:
cd ${WRKSRC} && make depend
post-install:
- ${RM} ${PREFIX}/man/man1/wineg++.1
${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
- ${LN} -sf ${PREFIX}/lib/libwine.so.1 ${PREFIX}/lib/libwine.so
+ ${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
.if !defined(NOPORTDOCS)
-@${MKDIR} ${DOCSDIR}
.for i in README ANNOUNCE AUTHORS LICENSE
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 74c13724fcc4..17a33a5292ae 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-0.9.40.tar.bz2) = 412b64916b32c31cacd7655ffa4489b6
-SHA256 (wine-0.9.40.tar.bz2) = 420eeae37d2fd276640e47bd6f345994b98d5b05eedf040a4a21824b198fe4e1
-SIZE (wine-0.9.40.tar.bz2) = 12091160
+MD5 (wine-0.9.41.tar.bz2) = 014e3760c07ac71906ba47c27f0471ab
+SHA256 (wine-0.9.41.tar.bz2) = e6765af740e2cdf63c0f1bf661a06b00f2954a10eedc4b390f9ec63b49fcd026
+SIZE (wine-0.9.41.tar.bz2) = 12117969
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 36a4563e6f1a..4c95b0752d37 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -454,6 +454,7 @@ include/wine/windows/xmldsodid.h
include/wine/windows/zmouse.h
include/wine/windows/ddk/compstui.h
include/wine/windows/ddk/hidsdi.h
+include/wine/windows/ddk/imm.h
include/wine/windows/ddk/ntddcdvd.h
include/wine/windows/ddk/ntddser.h
include/wine/windows/ddk/ntddtape.h
@@ -495,6 +496,7 @@ lib/wine/cryptnet.dll.so
lib/wine/ctl3d.dll16
lib/wine/ctl3d32.dll.so
lib/wine/ctl3dv2.dll16
+lib/wine/d3d10.dll.so
lib/wine/d3d8.dll.so
lib/wine/d3d9.dll.so
lib/wine/d3dim.dll.so
@@ -643,6 +645,7 @@ lib/wine/liboledlg.def
lib/wine/libolepro32.def
lib/wine/libolesvr32.def
lib/wine/libopengl32.def
+lib/wine/libpdh.def
lib/wine/libpowrprof.def
lib/wine/libpsapi.def
lib/wine/libquartz.def
@@ -890,50 +893,50 @@ lib/wine/ws2_32.dll.so
lib/wine/wsock32.dll.so
lib/wine/wtsapi32.dll.so
lib/wine/xcopy.exe.so
-share/aclocal/wine.m4
-share/applications/wine.desktop
-share/wine/wine.inf
-share/wine/generic.ppd
-share/wine/fonts/coue1255.fon
-share/wine/fonts/coue1256.fon
-share/wine/fonts/coue1257.fon
-share/wine/fonts/coure.fon
-share/wine/fonts/couree.fon
-share/wine/fonts/coureg.fon
-share/wine/fonts/courer.fon
-share/wine/fonts/couret.fon
-share/wine/fonts/cvgasys.fon
-share/wine/fonts/hvgasys.fon
-share/wine/fonts/jsmalle.fon
-share/wine/fonts/jvgasys.fon
-share/wine/fonts/marlett.ttf
-share/wine/fonts/smae1255.fon
-share/wine/fonts/smae1256.fon
-share/wine/fonts/smae1257.fon
-share/wine/fonts/smalle.fon
-share/wine/fonts/smallee.fon
-share/wine/fonts/smalleg.fon
-share/wine/fonts/smaller.fon
-share/wine/fonts/smallet.fon
-share/wine/fonts/ssee1255.fon
-share/wine/fonts/ssee1256.fon
-share/wine/fonts/ssee1257.fon
-share/wine/fonts/ssee874.fon
-share/wine/fonts/sserife.fon
-share/wine/fonts/sserifee.fon
-share/wine/fonts/sserifeg.fon
-share/wine/fonts/sserifer.fon
-share/wine/fonts/sserifet.fon
-share/wine/fonts/svgasys.fon
-share/wine/fonts/vgas1255.fon
-share/wine/fonts/vgas1256.fon
-share/wine/fonts/vgas1257.fon
-share/wine/fonts/vgas874.fon
-share/wine/fonts/vgasys.fon
-share/wine/fonts/vgasyse.fon
-share/wine/fonts/vgasysg.fon
-share/wine/fonts/vgasysr.fon
-share/wine/fonts/vgasyst.fon
+%%DATADIR%%/aclocal/wine.m4
+%%DATADIR%%/applications/wine.desktop
+%%DATADIR%%/wine/wine.inf
+%%DATADIR%%/wine/generic.ppd
+%%DATADIR%%/wine/fonts/coue1255.fon
+%%DATADIR%%/wine/fonts/coue1256.fon
+%%DATADIR%%/wine/fonts/coue1257.fon
+%%DATADIR%%/wine/fonts/coure.fon
+%%DATADIR%%/wine/fonts/couree.fon
+%%DATADIR%%/wine/fonts/coureg.fon
+%%DATADIR%%/wine/fonts/courer.fon
+%%DATADIR%%/wine/fonts/couret.fon
+%%DATADIR%%/wine/fonts/cvgasys.fon
+%%DATADIR%%/wine/fonts/hvgasys.fon
+%%DATADIR%%/wine/fonts/jsmalle.fon
+%%DATADIR%%/wine/fonts/jvgasys.fon
+%%DATADIR%%/wine/fonts/marlett.ttf
+%%DATADIR%%/wine/fonts/smae1255.fon
+%%DATADIR%%/wine/fonts/smae1256.fon
+%%DATADIR%%/wine/fonts/smae1257.fon
+%%DATADIR%%/wine/fonts/smalle.fon
+%%DATADIR%%/wine/fonts/smallee.fon
+%%DATADIR%%/wine/fonts/smalleg.fon
+%%DATADIR%%/wine/fonts/smaller.fon
+%%DATADIR%%/wine/fonts/smallet.fon
+%%DATADIR%%/wine/fonts/ssee1255.fon
+%%DATADIR%%/wine/fonts/ssee1256.fon
+%%DATADIR%%/wine/fonts/ssee1257.fon
+%%DATADIR%%/wine/fonts/ssee874.fon
+%%DATADIR%%/wine/fonts/sserife.fon
+%%DATADIR%%/wine/fonts/sserifee.fon
+%%DATADIR%%/wine/fonts/sserifeg.fon
+%%DATADIR%%/wine/fonts/sserifer.fon
+%%DATADIR%%/wine/fonts/sserifet.fon
+%%DATADIR%%/wine/fonts/svgasys.fon
+%%DATADIR%%/wine/fonts/vgas1255.fon
+%%DATADIR%%/wine/fonts/vgas1256.fon
+%%DATADIR%%/wine/fonts/vgas1257.fon
+%%DATADIR%%/wine/fonts/vgas874.fon
+%%DATADIR%%/wine/fonts/vgasys.fon
+%%DATADIR%%/wine/fonts/vgasyse.fon
+%%DATADIR%%/wine/fonts/vgasysg.fon
+%%DATADIR%%/wine/fonts/vgasysr.fon
+%%DATADIR%%/wine/fonts/vgasyst.fon
%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
@@ -951,6 +954,7 @@ share/wine/fonts/vgasyst.fon
@dirrm include/wine/windows
@dirrm include/wine
@dirrmtry man/man3w
-@dirrmtry share/applications
-@dirrm share/wine/fonts
-@dirrm share/wine
+@dirrmtry %%DATADIR%%/aclocal
+@dirrmtry %%DATADIR%%/applications
+@dirrm %%DATADIR%%/wine/fonts
+@dirrm %%DATADIR%%/wine
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index b4740151b5d2..6a44ffed2218 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.40
+PORTVERSION= 0.9.41
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -23,14 +23,14 @@ LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
xml2:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
- LIBS=-Wl,-rpath,${PREFIX}/lib/wine \
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --datadir=${DATADIR}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
EXTRA_BINARIES="wine-kthread"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
+MLINKS= winegcc.1 wineg++.1
ONLY_FOR_ARCHS= i386
USE_BISON= yes
USE_BZIP2= yes
@@ -51,9 +51,8 @@ pre-build:
cd ${WRKSRC} && make depend
post-install:
- ${RM} ${PREFIX}/man/man1/wineg++.1
${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
- ${LN} -sf ${PREFIX}/lib/libwine.so.1 ${PREFIX}/lib/libwine.so
+ ${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
.if !defined(NOPORTDOCS)
-@${MKDIR} ${DOCSDIR}
.for i in README ANNOUNCE AUTHORS LICENSE
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index 74c13724fcc4..17a33a5292ae 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-0.9.40.tar.bz2) = 412b64916b32c31cacd7655ffa4489b6
-SHA256 (wine-0.9.40.tar.bz2) = 420eeae37d2fd276640e47bd6f345994b98d5b05eedf040a4a21824b198fe4e1
-SIZE (wine-0.9.40.tar.bz2) = 12091160
+MD5 (wine-0.9.41.tar.bz2) = 014e3760c07ac71906ba47c27f0471ab
+SHA256 (wine-0.9.41.tar.bz2) = e6765af740e2cdf63c0f1bf661a06b00f2954a10eedc4b390f9ec63b49fcd026
+SIZE (wine-0.9.41.tar.bz2) = 12117969
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index 36a4563e6f1a..4c95b0752d37 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -454,6 +454,7 @@ include/wine/windows/xmldsodid.h
include/wine/windows/zmouse.h
include/wine/windows/ddk/compstui.h
include/wine/windows/ddk/hidsdi.h
+include/wine/windows/ddk/imm.h
include/wine/windows/ddk/ntddcdvd.h
include/wine/windows/ddk/ntddser.h
include/wine/windows/ddk/ntddtape.h
@@ -495,6 +496,7 @@ lib/wine/cryptnet.dll.so
lib/wine/ctl3d.dll16
lib/wine/ctl3d32.dll.so
lib/wine/ctl3dv2.dll16
+lib/wine/d3d10.dll.so
lib/wine/d3d8.dll.so
lib/wine/d3d9.dll.so
lib/wine/d3dim.dll.so
@@ -643,6 +645,7 @@ lib/wine/liboledlg.def
lib/wine/libolepro32.def
lib/wine/libolesvr32.def
lib/wine/libopengl32.def
+lib/wine/libpdh.def
lib/wine/libpowrprof.def
lib/wine/libpsapi.def
lib/wine/libquartz.def
@@ -890,50 +893,50 @@ lib/wine/ws2_32.dll.so
lib/wine/wsock32.dll.so
lib/wine/wtsapi32.dll.so
lib/wine/xcopy.exe.so
-share/aclocal/wine.m4
-share/applications/wine.desktop
-share/wine/wine.inf
-share/wine/generic.ppd
-share/wine/fonts/coue1255.fon
-share/wine/fonts/coue1256.fon
-share/wine/fonts/coue1257.fon
-share/wine/fonts/coure.fon
-share/wine/fonts/couree.fon
-share/wine/fonts/coureg.fon
-share/wine/fonts/courer.fon
-share/wine/fonts/couret.fon
-share/wine/fonts/cvgasys.fon
-share/wine/fonts/hvgasys.fon
-share/wine/fonts/jsmalle.fon
-share/wine/fonts/jvgasys.fon
-share/wine/fonts/marlett.ttf
-share/wine/fonts/smae1255.fon
-share/wine/fonts/smae1256.fon
-share/wine/fonts/smae1257.fon
-share/wine/fonts/smalle.fon
-share/wine/fonts/smallee.fon
-share/wine/fonts/smalleg.fon
-share/wine/fonts/smaller.fon
-share/wine/fonts/smallet.fon
-share/wine/fonts/ssee1255.fon
-share/wine/fonts/ssee1256.fon
-share/wine/fonts/ssee1257.fon
-share/wine/fonts/ssee874.fon
-share/wine/fonts/sserife.fon
-share/wine/fonts/sserifee.fon
-share/wine/fonts/sserifeg.fon
-share/wine/fonts/sserifer.fon
-share/wine/fonts/sserifet.fon
-share/wine/fonts/svgasys.fon
-share/wine/fonts/vgas1255.fon
-share/wine/fonts/vgas1256.fon
-share/wine/fonts/vgas1257.fon
-share/wine/fonts/vgas874.fon
-share/wine/fonts/vgasys.fon
-share/wine/fonts/vgasyse.fon
-share/wine/fonts/vgasysg.fon
-share/wine/fonts/vgasysr.fon
-share/wine/fonts/vgasyst.fon
+%%DATADIR%%/aclocal/wine.m4
+%%DATADIR%%/applications/wine.desktop
+%%DATADIR%%/wine/wine.inf
+%%DATADIR%%/wine/generic.ppd
+%%DATADIR%%/wine/fonts/coue1255.fon
+%%DATADIR%%/wine/fonts/coue1256.fon
+%%DATADIR%%/wine/fonts/coue1257.fon
+%%DATADIR%%/wine/fonts/coure.fon
+%%DATADIR%%/wine/fonts/couree.fon
+%%DATADIR%%/wine/fonts/coureg.fon
+%%DATADIR%%/wine/fonts/courer.fon
+%%DATADIR%%/wine/fonts/couret.fon
+%%DATADIR%%/wine/fonts/cvgasys.fon
+%%DATADIR%%/wine/fonts/hvgasys.fon
+%%DATADIR%%/wine/fonts/jsmalle.fon
+%%DATADIR%%/wine/fonts/jvgasys.fon
+%%DATADIR%%/wine/fonts/marlett.ttf
+%%DATADIR%%/wine/fonts/smae1255.fon
+%%DATADIR%%/wine/fonts/smae1256.fon
+%%DATADIR%%/wine/fonts/smae1257.fon
+%%DATADIR%%/wine/fonts/smalle.fon
+%%DATADIR%%/wine/fonts/smallee.fon
+%%DATADIR%%/wine/fonts/smalleg.fon
+%%DATADIR%%/wine/fonts/smaller.fon
+%%DATADIR%%/wine/fonts/smallet.fon
+%%DATADIR%%/wine/fonts/ssee1255.fon
+%%DATADIR%%/wine/fonts/ssee1256.fon
+%%DATADIR%%/wine/fonts/ssee1257.fon
+%%DATADIR%%/wine/fonts/ssee874.fon
+%%DATADIR%%/wine/fonts/sserife.fon
+%%DATADIR%%/wine/fonts/sserifee.fon
+%%DATADIR%%/wine/fonts/sserifeg.fon
+%%DATADIR%%/wine/fonts/sserifer.fon
+%%DATADIR%%/wine/fonts/sserifet.fon
+%%DATADIR%%/wine/fonts/svgasys.fon
+%%DATADIR%%/wine/fonts/vgas1255.fon
+%%DATADIR%%/wine/fonts/vgas1256.fon
+%%DATADIR%%/wine/fonts/vgas1257.fon
+%%DATADIR%%/wine/fonts/vgas874.fon
+%%DATADIR%%/wine/fonts/vgasys.fon
+%%DATADIR%%/wine/fonts/vgasyse.fon
+%%DATADIR%%/wine/fonts/vgasysg.fon
+%%DATADIR%%/wine/fonts/vgasysr.fon
+%%DATADIR%%/wine/fonts/vgasyst.fon
%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
@@ -951,6 +954,7 @@ share/wine/fonts/vgasyst.fon
@dirrm include/wine/windows
@dirrm include/wine
@dirrmtry man/man3w
-@dirrmtry share/applications
-@dirrm share/wine/fonts
-@dirrm share/wine
+@dirrmtry %%DATADIR%%/aclocal
+@dirrmtry %%DATADIR%%/applications
+@dirrm %%DATADIR%%/wine/fonts
+@dirrm %%DATADIR%%/wine