aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2018-09-27 15:44:48 +0800
committerromain <romain@FreeBSD.org>2018-09-27 15:44:48 +0800
commit22b074f365b0f574c03412dfafc66de681a3e653 (patch)
treeaef352963e79646ab81b24970daa5d3612aa4e23
parent51805c521c346fef3ad4dd12e791bb2eda6115d9 (diff)
downloadfreebsd-ports-gnome-22b074f365b0f574c03412dfafc66de681a3e653.tar.gz
freebsd-ports-gnome-22b074f365b0f574c03412dfafc66de681a3e653.tar.zst
freebsd-ports-gnome-22b074f365b0f574c03412dfafc66de681a3e653.zip
New port: sysutils/puppet6
Release notes: https://puppet.com/docs/puppet/6.0/release_notes.html With hat: puppet
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/puppet4/Makefile2
-rw-r--r--sysutils/puppet5/Makefile2
-rw-r--r--sysutils/puppet6/Makefile103
-rw-r--r--sysutils/puppet6/distinfo3
-rw-r--r--sysutils/puppet6/files/patch-lib_puppet_provider_service_daemontools.rb20
-rw-r--r--sysutils/puppet6/files/pkg-message.in7
-rw-r--r--sysutils/puppet6/files/puppet.in49
-rw-r--r--sysutils/puppet6/pkg-descr7
-rw-r--r--sysutils/puppet6/pkg-plist39
10 files changed, 231 insertions, 2 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 688d3f1530b8..becfd46a9df8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -955,6 +955,7 @@
SUBDIR += puppet-mode.el
SUBDIR += puppet4
SUBDIR += puppet5
+ SUBDIR += puppet6
SUBDIR += puppetserver
SUBDIR += puppetserver5
SUBDIR += pv
diff --git a/sysutils/puppet4/Makefile b/sysutils/puppet4/Makefile
index c7d28a0af730..e6f2c6cc2fe7 100644
--- a/sysutils/puppet4/Makefile
+++ b/sysutils/puppet4/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= rubygem-hiera>=2.0:sysutils/rubygem-hiera \
USES= cpe
CPE_VENDOR= puppetlabs
-CONFLICTS_INSTALL= puppet5-*
+CONFLICTS_INSTALL= puppet5-* puppet6-*
NO_ARCH= yes
NO_BUILD= yes
USE_RUBY= yes
diff --git a/sysutils/puppet5/Makefile b/sysutils/puppet5/Makefile
index 49b0052a6e22..e31d24b5e40d 100644
--- a/sysutils/puppet5/Makefile
+++ b/sysutils/puppet5/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= rubygem-gettext-setup>=0:devel/rubygem-gettext-setup \
USES= cpe
CPE_VENDOR= puppetlabs
-CONFLICTS_INSTALL= puppet4-*
+CONFLICTS_INSTALL= puppet4-* puppet6-*
NO_ARCH= yes
NO_BUILD= yes
USE_RUBY= yes
diff --git a/sysutils/puppet6/Makefile b/sysutils/puppet6/Makefile
new file mode 100644
index 000000000000..ae77751efcec
--- /dev/null
+++ b/sysutils/puppet6/Makefile
@@ -0,0 +1,103 @@
+# $FreeBSD$
+
+PORTNAME= puppet
+PORTVERSION= 6.0.0
+CATEGORIES= sysutils
+MASTER_SITES= https://downloads.puppetlabs.com/puppet/
+PKGNAMESUFFIX= 6
+
+MAINTAINER= puppet@FreeBSD.org
+COMMENT= Configuration management framework written in Ruby
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BROKEN_aarch64= fails to install: Could not load facter; cannot install
+
+BUILD_DEPENDS= facter>=3.0:sysutils/facter \
+ rubygem-hiera>=2.0:sysutils/rubygem-hiera \
+ rubygem-json_pure>=0:devel/rubygem-json_pure \
+ rubygem-semantic_puppet>=1:devel/rubygem-semantic_puppet
+RUN_DEPENDS= facter>=3.0:sysutils/facter \
+ rubygem-gettext-setup>=0:devel/rubygem-gettext-setup \
+ rubygem-hiera>=2.0:sysutils/rubygem-hiera \
+ rubygem-hocon>=0:devel/rubygem-hocon \
+ rubygem-json_pure>=0:devel/rubygem-json_pure \
+ rubygem-ruby-augeas>=0:textproc/rubygem-ruby-augeas \
+ rubygem-semantic_puppet>=1:devel/rubygem-semantic_puppet
+
+USES= cpe
+CPE_VENDOR= puppetlabs
+CONFLICTS_INSTALL= puppet4-* puppet5-*
+NO_ARCH= yes
+NO_BUILD= yes
+USE_RUBY= yes
+USE_RC_SUBR= puppet
+PORTDOCS= LICENSE README.md
+PORTEXAMPLES= *
+USERS= puppet
+GROUPS= puppet
+SUB_FILES+= pkg-message
+SUB_LIST= RUBY=${RUBY}
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/etc/puppetlabs/puppet|${ETCDIR}|" \
+ ${WRKSRC}/install.rb \
+ ${WRKSRC}/lib/puppet/reference/configuration.rb \
+ ${WRKSRC}/lib/puppet/util/run_mode.rb
+ @${REINPLACE_CMD} -e "s|/etc/puppetlabs/code|${ETCDIR}|" \
+ ${WRKSRC}/install.rb \
+ ${WRKSRC}/lib/puppet/reference/configuration.rb \
+ ${WRKSRC}/lib/puppet/util/run_mode.rb
+ @${REINPLACE_CMD} -e "s|/opt/puppetlabs/puppet/cache|/var/puppet|" \
+ ${WRKSRC}/install.rb \
+ ${WRKSRC}/lib/puppet/reference/configuration.rb \
+ ${WRKSRC}/lib/puppet/util/run_mode.rb
+ @${REINPLACE_CMD} -e "s|/var/run/puppetlabs|/var/run/puppet|" \
+ ${WRKSRC}/install.rb \
+ ${WRKSRC}/lib/puppet/util/run_mode.rb
+ @${REINPLACE_CMD} -e "s|/var/log/puppetlabs/puppet|/var/log/puppet|" \
+ ${WRKSRC}/install.rb \
+ ${WRKSRC}/lib/puppet/util/run_mode.rb
+ @${REINPLACE_CMD} -e "s|/opt/puppetlabs/puppet/modules|${ETCDIR}/modules|" \
+ ${WRKSRC}/lib/puppet/defaults.rb
+ @${REINPLACE_CMD} -e "s|/opt/puppetlabs/puppet/bin/gem|${LOCALBASE}/bin/gem|" \
+ ${WRKSRC}/lib/puppet/provider/package/puppet_gem.rb
+ @${REINPLACE_CMD} -e "s|\$$confdir/ssl|/var/puppet/ssl|" \
+ ${WRKSRC}/lib/puppet/defaults.rb
+ @${REINPLACE_CMD} -e "s|\.\./\.\./\.\./locales|../locales|" \
+ ${WRKSRC}/lib/puppet/gettext/config.rb
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} LC_ALL=C.UTF-8 ${RUBY} ${WRKSRC}/install.rb --no-configs --destdir=${STAGEDIR} \
+ --localedir=${RUBY_SITELIBDIR}/puppet/locales
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${ETCDIR}/manifests
+ ${MKDIR} ${STAGEDIR}${ETCDIR}/modules
+ ${MKDIR} ${STAGEDIR}/var/puppet
+ ${INSTALL_DATA} ${WRKSRC}/conf/auth.conf ${STAGEDIR}${ETCDIR}/auth.conf-dist
+ ${SETENV} LC_ALL=C.UTF-8 ${RUBY} -I ${STAGEDIR}/${RUBY_SITELIBDIR} ${STAGEDIR}${PREFIX}/bin/puppet agent --genconfig \
+ --confdir=${ETCDIR} \
+ --rundir=/var/run/puppet \
+ --vardir=/var/puppet \
+ --logdir=/var/log/puppet \
+ --codedir=${ETCDIR} \
+ > ${STAGEDIR}${ETCDIR}/puppet.conf-dist
+ @${ECHO} ${STAGEDIR}${RUBY_SITELIBDIR}/puppet.rb | \
+ ${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${STAGEDIR}${RUBY_SITELIBDIR}/${PORTNAME} -type f | \
+ ${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ext/rack/example-passenger-vhost.conf ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/puppet6/distinfo b/sysutils/puppet6/distinfo
new file mode 100644
index 000000000000..7003643b784d
--- /dev/null
+++ b/sysutils/puppet6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537339060
+SHA256 (puppet-6.0.0.tar.gz) = d60b018007ee1f1ac882aa2ba9a9052e6b6e5993b4d300fabf76307a42e362d0
+SIZE (puppet-6.0.0.tar.gz) = 2790790
diff --git a/sysutils/puppet6/files/patch-lib_puppet_provider_service_daemontools.rb b/sysutils/puppet6/files/patch-lib_puppet_provider_service_daemontools.rb
new file mode 100644
index 000000000000..3857c824a1ba
--- /dev/null
+++ b/sysutils/puppet6/files/patch-lib_puppet_provider_service_daemontools.rb
@@ -0,0 +1,20 @@
+--- lib/puppet/provider/service/daemontools.rb.orig 2016-04-25 18:52:09 UTC
++++ lib/puppet/provider/service/daemontools.rb
+@@ -39,7 +39,7 @@ Puppet::Type.type(:service).provide :dae
+
+ EOT
+
+- commands :svc => "/usr/bin/svc", :svstat => "/usr/bin/svstat"
++ commands :svc => "%%PREFIX%%/bin/svc", :svstat => "%%PREFIX%%/bin/svstat"
+
+ class << self
+ attr_writer :defpath
+@@ -88,7 +88,7 @@ Puppet::Type.type(:service).provide :dae
+ # find the service dir on this node
+ def servicedir
+ unless @servicedir
+- ["/service", "/etc/service","/var/lib/svscan"].each do |path|
++ ["/var/service", "/etc/service","/var/lib/svscan"].each do |path|
+ if Puppet::FileSystem.exist?(path)
+ @servicedir = path
+ break
diff --git a/sysutils/puppet6/files/pkg-message.in b/sysutils/puppet6/files/pkg-message.in
new file mode 100644
index 000000000000..9c18b68be5b4
--- /dev/null
+++ b/sysutils/puppet6/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+To enable the puppet agent, add the following to /etc/rc.conf:
+
+ puppet_enable="YES"
+
+The default PID directory is /var/run/puppet
+
diff --git a/sysutils/puppet6/files/puppet.in b/sysutils/puppet6/files/puppet.in
new file mode 100644
index 000000000000..74ea2c3793f2
--- /dev/null
+++ b/sysutils/puppet6/files/puppet.in
@@ -0,0 +1,49 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: puppet
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable the puppet agent:
+#
+# puppet_enable="YES"
+
+. /etc/rc.subr
+
+name="puppet"
+rcvar=puppet_enable
+
+load_rc_config "$name"
+
+: ${puppet_enable="NO"}
+: ${puppet_rundir="/var/run/puppet"}
+
+command="%%PREFIX%%/bin/puppet"
+command_args="agent ${puppet_flags} --rundir=${puppet_rundir}"
+command_interpreter=%%RUBY%%
+unset puppet_flags
+
+pidfile="${puppet_rundir}/agent.pid"
+start_precmd="install -d -o puppet -g puppet ${pidfile%/*}"
+
+PATH="${PATH}:/usr/local/bin"
+
+# An UTF-8 locale is required
+: LC_ALL=${LC_ALL:=C.UTF-8}
+case $LC_ALL in
+ *.UTF-8)
+ ;;
+ *.*)
+ LC_ALL="${LC_ALL%.*}.UTF-8"
+ ;;
+ *)
+ LC_ALL=C.UTF-8
+ ;;
+esac
+export LC_ALL
+
+run_rc_command "$1"
diff --git a/sysutils/puppet6/pkg-descr b/sysutils/puppet6/pkg-descr
new file mode 100644
index 000000000000..89a2fce63e8d
--- /dev/null
+++ b/sysutils/puppet6/pkg-descr
@@ -0,0 +1,7 @@
+Puppet lets you centrally manage every important aspect of your system using
+a cross-platform specification language that manages all the separate
+elements normally aggregated in different files, like users, cron jobs, and
+hosts, along with obviously discrete elements like packages, services, and
+files.
+
+WWW: https://puppetlabs.com/puppet/puppet-open-source
diff --git a/sysutils/puppet6/pkg-plist b/sysutils/puppet6/pkg-plist
new file mode 100644
index 000000000000..a31834a7d0bf
--- /dev/null
+++ b/sysutils/puppet6/pkg-plist
@@ -0,0 +1,39 @@
+bin/puppet
+%%ETCDIR%%/auth.conf-dist
+%%ETCDIR%%/puppet.conf-dist
+%%RUBY_SITELIBDIR%%/hiera/puppet_function.rb
+%%RUBY_SITELIBDIR%%/hiera/scope.rb
+%%RUBY_SITELIBDIR%%/hiera_puppet.rb
+%%RUBY_SITELIBDIR%%/puppet_pal.rb
+%%RUBY_SITELIBDIR%%/puppet_x.rb
+man/man5/puppet.conf.5.gz
+man/man8/puppet-agent.8.gz
+man/man8/puppet-apply.8.gz
+man/man8/puppet-catalog.8.gz
+man/man8/puppet-config.8.gz
+man/man8/puppet-describe.8.gz
+man/man8/puppet-device.8.gz
+man/man8/puppet-doc.8.gz
+man/man8/puppet-epp.8.gz
+man/man8/puppet-facts.8.gz
+man/man8/puppet-filebucket.8.gz
+man/man8/puppet-generate.8.gz
+man/man8/puppet-help.8.gz
+man/man8/puppet-key.8.gz
+man/man8/puppet-lookup.8.gz
+man/man8/puppet-man.8.gz
+man/man8/puppet-module.8.gz
+man/man8/puppet-node.8.gz
+man/man8/puppet-parser.8.gz
+man/man8/puppet-plugin.8.gz
+man/man8/puppet-report.8.gz
+man/man8/puppet-resource.8.gz
+man/man8/puppet-script.8.gz
+man/man8/puppet-ssl.8.gz
+man/man8/puppet-status.8.gz
+man/man8/puppet.8.gz
+@dir(puppet,puppet,) %%ETCDIR%%/manifests
+@dir(puppet,puppet,) %%ETCDIR%%/modules
+@dir(puppet,puppet,) /var/puppet
+@dir(puppet,puppet,) /var/log/puppet
+@dir /var/run/puppet