aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-25 18:06:36 +0800
committeredwin <edwin@FreeBSD.org>2005-11-25 18:06:36 +0800
commit24ff4498a3086848c37123f23d47e35e49319051 (patch)
tree390ef170cc3862f2a5abf585149a130c9905d0aa
parent0785eac9c63c6e718eb095aacb157a5438c07e28 (diff)
downloadfreebsd-ports-gnome-24ff4498a3086848c37123f23d47e35e49319051.tar.gz
freebsd-ports-gnome-24ff4498a3086848c37123f23d47e35e49319051.tar.zst
freebsd-ports-gnome-24ff4498a3086848c37123f23d47e35e49319051.zip
Unbreak powerdns
Change the Makefile so compiling against the LDAP library works again PR: ports/89477 Submitted by: Ralf van der Enden <tremere@cainites.net>
-rw-r--r--dns/powerdns-devel/Makefile3
-rw-r--r--dns/powerdns/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index 14aa741862d4..d7bcf28e2882 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -21,7 +21,7 @@ USE_SUBMAKE= YES
USE_REINPLACE= YES
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
-CXXFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
@@ -86,6 +86,7 @@ PLIST_SUB+= WITHMYSQL="@comment "
USE_OPENLDAP?= YES
CONFIGURE_MODULES+= "ldap"
PLIST_SUB+= WITHLDAP=""
+CXXFLAGS+= -L${LOCALBASE}/lib
.else
PLIST_SUB+= WITHLDAP="@comment "
.endif
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 14aa741862d4..d7bcf28e2882 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -21,7 +21,7 @@ USE_SUBMAKE= YES
USE_REINPLACE= YES
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
-CXXFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
@@ -86,6 +86,7 @@ PLIST_SUB+= WITHMYSQL="@comment "
USE_OPENLDAP?= YES
CONFIGURE_MODULES+= "ldap"
PLIST_SUB+= WITHLDAP=""
+CXXFLAGS+= -L${LOCALBASE}/lib
.else
PLIST_SUB+= WITHLDAP="@comment "
.endif