aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-07-11 16:37:33 +0800
committermm <mm@FreeBSD.org>2011-07-11 16:37:33 +0800
commit28e0ade9b4bea0f0015c0467695a83ae3401e0a9 (patch)
tree8e33d72d81873379d551df1304f3680433afcca3
parent87a5fc8b82f7f7aa52bc1ea10807b89b5f4f2661 (diff)
downloadfreebsd-ports-gnome-28e0ade9b4bea0f0015c0467695a83ae3401e0a9.tar.gz
freebsd-ports-gnome-28e0ade9b4bea0f0015c0467695a83ae3401e0a9.tar.zst
freebsd-ports-gnome-28e0ade9b4bea0f0015c0467695a83ae3401e0a9.zip
PEAR channel for PHPUnit
WWW: http://pear.phpunit.de
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-channel-phpunit/Makefile36
-rw-r--r--devel/pear-channel-phpunit/files/pear.phpunit.de.reg1
-rw-r--r--devel/pear-channel-phpunit/pkg-descr3
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5531b376e4a5..e871b2a157a2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2697,6 +2697,7 @@
SUBDIR += pear-XML_Util
SUBDIR += pear-XML_XPath
SUBDIR += pear-channel-horde
+ SUBDIR += pear-channel-phpunit
SUBDIR += pear-codegen
SUBDIR += pecl-automap
SUBDIR += pecl-bbcode
diff --git a/devel/pear-channel-phpunit/Makefile b/devel/pear-channel-phpunit/Makefile
new file mode 100644
index 000000000000..4a253628f84b
--- /dev/null
+++ b/devel/pear-channel-phpunit/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-channel-phpunit
+# Date created: 11 July 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear-channel-phpunit
+PORTVERSION= 20110327
+CATEGORIES= devel www pear
+MASTER_SITES= #no master sites
+DISTFILES= #no distfiles
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= PEAR Channel pear.phpunit.de
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
+
+NO_BUILD= yes
+
+LPEARDIR?= share/pear
+
+PLIST_FILES= ${LPEARDIR}/.channels/.alias/phpunit.txt \
+ ${LPEARDIR}/.channels/pear.phpunit.de.reg \
+ "@exec ${MKDIR} %D/${LPEARDIR}/.registry/.channel.pear.phpunit.de"
+PLIST_DIRS= ${LPEARDIR}/.registry/.channel.pear.phpunit.de
+
+do-install:
+ @${MKDIR} ${PREFIX}/${LPEARDIR}/.registry/.channel.pear.phpunit.de
+ @${INSTALL_DATA} ${FILESDIR}/pear.phpunit.de.reg \
+ ${PREFIX}/${LPEARDIR}/.channels/pear.phpunit.de.reg
+ @${ECHO_CMD} -n pear.phpunit.de > \
+ ${PREFIX}/${LPEARDIR}/.channels/.alias/phpunit.txt
+
+.include <bsd.port.mk>
diff --git a/devel/pear-channel-phpunit/files/pear.phpunit.de.reg b/devel/pear-channel-phpunit/files/pear.phpunit.de.reg
new file mode 100644
index 000000000000..7ad3291ad23d
--- /dev/null
+++ b/devel/pear-channel-phpunit/files/pear.phpunit.de.reg
@@ -0,0 +1 @@
+a:6:{s:7:"attribs";a:4:{s:7:"version";s:3:"1.0";s:5:"xmlns";s:31:"http://pear.php.net/channel-1.0";s:9:"xmlns:xsi";s:41:"http://www.w3.org/2001/XMLSchema-instance";s:18:"xsi:schemaLocation";s:71:"http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd";}s:4:"name";s:15:"pear.phpunit.de";s:7:"summary";s:20:"PHPUnit PEAR Channel";s:14:"suggestedalias";s:7:"phpunit";s:7:"servers";a:1:{s:7:"primary";a:1:{s:4:"rest";a:1:{s:7:"baseurl";a:4:{i:0;a:2:{s:7:"attribs";a:1:{s:4:"type";s:7:"REST1.0";}s:8:"_content";s:28:"http://pear.phpunit.de/rest/";}i:1;a:2:{s:7:"attribs";a:1:{s:4:"type";s:7:"REST1.1";}s:8:"_content";s:28:"http://pear.phpunit.de/rest/";}i:2;a:2:{s:7:"attribs";a:1:{s:4:"type";s:7:"REST1.2";}s:8:"_content";s:28:"http://pear.phpunit.de/rest/";}i:3;a:2:{s:7:"attribs";a:1:{s:4:"type";s:7:"REST1.3";}s:8:"_content";s:28:"http://pear.phpunit.de/rest/";}}}}}s:13:"_lastmodified";a:2:{s:4:"ETag";s:12:""4141299221"";s:13:"Last-Modified";s:29:"Sun, 27 Mar 2011 17:52:32 GMT";}} \ No newline at end of file
diff --git a/devel/pear-channel-phpunit/pkg-descr b/devel/pear-channel-phpunit/pkg-descr
new file mode 100644
index 000000000000..9031f78a8572
--- /dev/null
+++ b/devel/pear-channel-phpunit/pkg-descr
@@ -0,0 +1,3 @@
+PEAR channel for PHPUnit
+
+WWW: http://pear.phpunit.de