aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-24 09:36:11 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-24 09:36:11 +0800
commit29f703986ff7bc8b9a95963ba70d832963c46080 (patch)
treebc4a17cda211e3efe19be478fcccc42ca9b4188b
parentf1aab70965b4c91e63bfc627d2e64c9449cee939 (diff)
downloadfreebsd-ports-gnome-29f703986ff7bc8b9a95963ba70d832963c46080.tar.gz
freebsd-ports-gnome-29f703986ff7bc8b9a95963ba70d832963c46080.tar.zst
freebsd-ports-gnome-29f703986ff7bc8b9a95963ba70d832963c46080.zip
Mark these broken on non-x86.
I was not able to find a quick fix for these, although most of the other -lv2 ports were fairly easy. Approved by: portmgr (tier-2 blanket)
-rw-r--r--audio/artyfx-lv2/Makefile5
-rw-r--r--audio/guitarix-lv2/Makefile5
-rw-r--r--audio/zam-plugins-lv2/Makefile5
3 files changed, 15 insertions, 0 deletions
diff --git a/audio/artyfx-lv2/Makefile b/audio/artyfx-lv2/Makefile
index 6d6fce8c766e..9f0962db4dc7 100644
--- a/audio/artyfx-lv2/Makefile
+++ b/audio/artyfx-lv2/Makefile
@@ -13,6 +13,11 @@ COMMENT= ArtyFX plugin bundle
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_aarch64= fails to compile: unknown FP unit 'sse'
+BROKEN_armv6= fails to compile: unknown FP unit 'sse'
+BROKEN_armv7= fails to compile: unknown FP unit 'sse'
+BROKEN_powerpc64= fails to compile: unknown FP unit 'sse'
+
BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libsndfile.so:audio/libsndfile
diff --git a/audio/guitarix-lv2/Makefile b/audio/guitarix-lv2/Makefile
index 83b3ad164ce2..cf37d1eae0f2 100644
--- a/audio/guitarix-lv2/Makefile
+++ b/audio/guitarix-lv2/Makefile
@@ -14,6 +14,11 @@ COMMENT= Virtual versatile amplification for Jack and set of LV2 plugins
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_aarch64= fails to compile: unknown FP unit 'sse'
+BROKEN_armv6= fails to compile: unknown FP unit 'sse'
+BROKEN_armv7= fails to compile: unknown FP unit 'sse'
+BROKEN_powerpc64= fails to compile: unknown FP unit 'sse'
+
BUILD_DEPENDS= lv2>0:audio/lv2 \
${LOCALBASE}/include/fftw3.h:math/fftw3 \
roboto-fonts-ttf>0:x11-fonts/roboto-fonts-ttf \
diff --git a/audio/zam-plugins-lv2/Makefile b/audio/zam-plugins-lv2/Makefile
index c9607a45b875..e944a0b81a34 100644
--- a/audio/zam-plugins-lv2/Makefile
+++ b/audio/zam-plugins-lv2/Makefile
@@ -11,6 +11,11 @@ COMMENT= Collection of LADSPA/LV2/VST/JACK audio plugins
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_aarch64= fails to compile: unknown FP unit 'sse'
+BROKEN_armv6= fails to compile: unknown FP unit 'sse'
+BROKEN_armv7= fails to compile: unknown FP unit 'sse'
+BROKEN_powerpc64= fails to compile: unknown FP unit 'sse'
+
BUILD_DEPENDS= lv2>0:audio/lv2 \
${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libfftw3f.so:math/fftw3-float \