aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-04-03 12:42:36 +0800
committerwill <will@FreeBSD.org>2000-04-03 12:42:36 +0800
commit3020ef99ef155244a9acfdeebe84617260a974c9 (patch)
tree17a72ef0887876c91a2944fd83dfa47165bfcad6
parent42b14afd702b9b6b52de9220963bad5bbb6ce9b9 (diff)
downloadfreebsd-ports-gnome-3020ef99ef155244a9acfdeebe84617260a974c9.tar.gz
freebsd-ports-gnome-3020ef99ef155244a9acfdeebe84617260a974c9.tar.zst
freebsd-ports-gnome-3020ef99ef155244a9acfdeebe84617260a974c9.zip
Fix heretic port so that it works right. Also use x11 target instead of
fastx11, because for some reason it reportedly doesn't work in 16bpp mode, which most people use (I use 24bpp). Sorry for being so late about this. Submitted by: green
-rw-r--r--games/heretic/Makefile10
-rw-r--r--games/heretic/distinfo2
-rw-r--r--games/heretic/files/patch-ae20
3 files changed, 18 insertions, 14 deletions
diff --git a/games/heretic/Makefile b/games/heretic/Makefile
index 9481e9521c57..e0e5f2c63a03 100644
--- a/games/heretic/Makefile
+++ b/games/heretic/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= games
MASTER_SITES= http://www.raven-games.com/linuxheretic/heretic/src/ \
http://www.raven-games.com/linuxheretic/wad/
.if !defined(NO_WAD)
-DISTFILES+= heretic_share.wad.gz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} heretic_share.wad.gz
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.endif
@@ -21,12 +21,16 @@ MAINTAINER= will@FreeBSD.org
FETCH_BEFORE_ARGS+= -b
USE_X_PREFIX= yes
USE_GMAKE= yes
-ALL_TARGET= fastx11
MAKE_ENV= WANT_OGL="no" WANT_OGL_FULLSCREEN="no" WANT_NICE_OGL="no"
-BINARY= xaheretic
.if !defined(NO_WAD)
PLIST= ${PKGDIR}/PLIST.nowad
.endif
+ALL_TARGET= x11
+BINARY= xheretic
+.if defined(WANT_FASTX11)
+BINARY= xaheretic
+ALL_TARGET= fastx11
+.endif
do-install:
@${MKDIR} ${PREFIX}/share/heretic
diff --git a/games/heretic/distinfo b/games/heretic/distinfo
index b90d2b9b88d2..db830d3bdc3e 100644
--- a/games/heretic/distinfo
+++ b/games/heretic/distinfo
@@ -1,2 +1,2 @@
MD5 (glheretic-1.0.tar.gz) = 82874571b280c6907a2c781377393f6e
-MD5 (heretic_share.wad.gz) = 8aa0b891681fc04726bbeae031bddea5
+MD5 (heretic_share.wad.gz) = efc102ab90b0cb4bfe9177303e549d6f
diff --git a/games/heretic/files/patch-ae b/games/heretic/files/patch-ae
index 8754ef9bf068..009be366cda1 100644
--- a/games/heretic/files/patch-ae
+++ b/games/heretic/files/patch-ae
@@ -1,11 +1,11 @@
---- opengl/gl_struct.h Wed Jan 26 14:38:19 2000
-+++ opengl/gl_struct.h.new Sun Feb 13 03:54:46 2000
+--- opengl/gl_struct.h.orig Wed Jan 26 14:38:19 2000
++++ opengl/gl_struct.h Sun Apr 2 16:43:51 2000
@@ -2,7 +2,7 @@
- #define __GL_STRUCT_H__
-
- #include <stdio.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <GL/gl.h>
- #include <GL/glu.h>
+ #define __GL_STRUCT_H__
+
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>