aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-03-15 06:52:34 +0800
committerkwm <kwm@FreeBSD.org>2005-03-15 06:52:34 +0800
commit30e500fd4c2f5ab691da92b148a5821393d5e005 (patch)
tree4ae4b3bf3647eabd3cd2a69f1ab817b6e021a5ef
parentbf71aa4bf0e842e97a0da939c37e0ffa1fe3095b (diff)
downloadfreebsd-ports-gnome-30e500fd4c2f5ab691da92b148a5821393d5e005.tar.gz
freebsd-ports-gnome-30e500fd4c2f5ab691da92b148a5821393d5e005.tar.zst
freebsd-ports-gnome-30e500fd4c2f5ab691da92b148a5821393d5e005.zip
Disable CPUFLAGS by default, add switch WITH_CPUFLAGS to disable this. [1]
Make configure faster for plugins. [1] Sprinkle some plugins around that apeard in this release. Disable example building, we don't use them so why build them. [2] Remove some useless ECHO_CMD's. Submitted by: [1] ahze Requested by: [2] adamw Approved by: maintainer (implicid)
-rw-r--r--multimedia/gstreamer-plugins/Makefile42
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common19
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist2
-rw-r--r--multimedia/gstreamer-plugins80/Makefile42
-rw-r--r--multimedia/gstreamer-plugins80/Makefile.common19
-rw-r--r--multimedia/gstreamer-plugins80/pkg-plist2
6 files changed, 74 insertions, 52 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 18c6a001a764..98cc56bbf3fe 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -43,6 +43,11 @@ CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -L${LOCALBASE}/lib ${EXTRA_LIBS} ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
+.include "${MASTERDIR}/Makefile.common"
+
+#.if !defined(WITH_CPUFLAGS)
+WITHOUT_CPU_CFLAGS= yes
+#.endif
.if ${GST_PLUGIN} == "base"
GCONF_SCHEMAS= gstreamer-0.8.schemas
@@ -60,6 +65,10 @@ MAN1= gst-launch-ext-0.8.1 gst-visualise-0.8.1
EXTRA_BUILD_DIR+= sys/vcd
# modplug
EXTRA_BUILD_DIR+= gst/modplug
+.else
+.for f in ${GST_PLUGIN_DIR}
+GST_PLUGIN_MAKEFILES+= ${f}/Makefile
+.endfor
.endif
# cdrom default device
@@ -84,6 +93,17 @@ DEFAULT_DVD_DEVICE=/dev/acd0
. endif
.endif
+pre-everything::
+.if !defined(WITH_CPUFLAGS)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you want to compile with CPUFLAGS"
+ @${ECHO_MSG} "hit Ctrl+C now and use make \"WITH_CPUFLAGS=yes\""
+ @${ECHO_MSG} "NOTE: This option may cause build, install, and/or"
+ @${ECHO_MSG} "runtime failures. If this option does not work for you"
+ @${ECHO_MSG} "please do not use it."
+ @${ECHO_MSG} ""
+.endif
+
post-extract:
# for cdrom/vcd support
# taken from mplayer distfile
@@ -114,32 +134,17 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|PFLAGS@|PFLAGS@ -I${LOCALBASE}/include/mjpegtools -I${LOCALBASE}/include/mjpegtools/mplex|' \
${WRKSRC}/ext/mplex/Makefile.in
-.if ${CXXFLAGS:M*=athlon-4} || ${CXXFLAGS:M*=athlon-mp} || ${CXXFLAGS:M*=athlon-xp}
-# Fix gst-register when using -O -march=athlon-xp
- @${REINPLACE_CMD} -e 's|@CXXF|-fgcse @CXXF|g' \
- ${WRKSRC}/gst/modplug/Makefile.in \
- ${WRKSRC}/gst/modplug/libmodplug/Makefile.in
+.if ${GST_PLUGIN}!="base"
+ @${REINPLACE_CMD} -E -e 's|ac_config_files=\"*\"|ac_config_files="$$ac_config_files Makefile ${GST_PLUGIN_MAKEFILES}" #|' \
+ ${WRKSRC}/configure
.endif
-pre-build:
-# This port cannot be CFLAGS safe, when using p4 optimizations
-# because it breaks the mod plugin
- @${REINPLACE_CMD} -E \
- -e 's|(-march=pentiu)m4|\1m3|g' \
- -e 's|(-mcpu=pentiu)m4|\1m3|g' \
- -e 's|(-mtune=pentiu)m)4|\1m3|g' \
- ${WRKSRC}/gst/modplug/Makefile \
- ${WRKSRC}/gst/modplug/libmodplug/Makefile
-
post-build:
.ifdef(EXTRA_BUILD_DIR)
. for dir in ${EXTRA_BUILD_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
. endfor
.endif
-# @${ECHO_CMD} "@unexec ${PREFIX}/bin/gst-register-${GST_VERSION} \
-# --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml \
-# >> ${TMPPLIST}"
post-install:
.ifdef(EXTRA_BUILD_DIR)
@@ -151,5 +156,4 @@ post-install:
-@${X11BASE}/bin/gst-register-${GST_VERSION} \
--gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
-.include "${MASTERDIR}/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 45b6a752435b..d5ffb4f06463 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -2,21 +2,24 @@ GST_ALL_PLUGINS= \
a52dec \
aalib \
aalibtest \
- alsa \
+ amrnb \
arts \
artstest \
artsc \
audiofile \
+ audioresample \
cairo \
cdaudio \
cdparanoia \
dirac \
+ directfb \
divx \
dts \
dvdnav \
dvdread \
dxr3 \
esd \
+ esdtest \
faac \
faad \
flac \
@@ -49,6 +52,7 @@ GST_ALL_PLUGINS= \
musicbrainz \
nas \
ogg \
+ oggtest \
opengl \
pango \
polyp \
@@ -56,8 +60,10 @@ GST_ALL_PLUGINS= \
qcam \
raw1394 \
sdl \
+ sdltest \
shout \
shout2 \
+ shout2test \
sidplay \
smoothwave \
sndfile \
@@ -69,6 +75,7 @@ GST_ALL_PLUGINS= \
vcd \
vorbis \
xine \
+ vorbistest \
xvid
# Disable all plugins by default\
@@ -77,6 +84,7 @@ CONFIGURE_ARGS+= --disable-${d}
.endfor
CONFIGURE_ARGS+=--disable-tests \
+ --disable-examples \
--disable-alsa \
--disable-http \
--enable-cdrom \
@@ -86,8 +94,9 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-osx_audio \
--disable-osx_video \
--enable-static \
- --enable-gst_v4l \
- --enable-gst_v4l2 \
+ --disable-sunaudio \
+ --disable-gst_v4l \
+ --disable-gst_v4l2 \
--enable-x \
--enable-xshm \
--enable-xvideo
@@ -430,10 +439,6 @@ do-build:
${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
.endfor
-post-build:
- @${ECHO_CMD} ${PREFIX}/bin/gst-register-${GST_VERSION} \
- --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml
-
do-install:
.for dir in ${GST_PLUGIN_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index e1d97a9a66c2..25e6d1b6a4d2 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -186,3 +186,5 @@ share/locale/vi/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/audio
@unexec rmdir %D/include/gstreamer-%%VERSION%%/gst 2>/dev/null || true
@unexec rmdir %D/include/gstreamer-%%VERSION%% 2>/dev/null || true
+@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true
+@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index 18c6a001a764..98cc56bbf3fe 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -43,6 +43,11 @@ CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -L${LOCALBASE}/lib ${EXTRA_LIBS} ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
+.include "${MASTERDIR}/Makefile.common"
+
+#.if !defined(WITH_CPUFLAGS)
+WITHOUT_CPU_CFLAGS= yes
+#.endif
.if ${GST_PLUGIN} == "base"
GCONF_SCHEMAS= gstreamer-0.8.schemas
@@ -60,6 +65,10 @@ MAN1= gst-launch-ext-0.8.1 gst-visualise-0.8.1
EXTRA_BUILD_DIR+= sys/vcd
# modplug
EXTRA_BUILD_DIR+= gst/modplug
+.else
+.for f in ${GST_PLUGIN_DIR}
+GST_PLUGIN_MAKEFILES+= ${f}/Makefile
+.endfor
.endif
# cdrom default device
@@ -84,6 +93,17 @@ DEFAULT_DVD_DEVICE=/dev/acd0
. endif
.endif
+pre-everything::
+.if !defined(WITH_CPUFLAGS)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you want to compile with CPUFLAGS"
+ @${ECHO_MSG} "hit Ctrl+C now and use make \"WITH_CPUFLAGS=yes\""
+ @${ECHO_MSG} "NOTE: This option may cause build, install, and/or"
+ @${ECHO_MSG} "runtime failures. If this option does not work for you"
+ @${ECHO_MSG} "please do not use it."
+ @${ECHO_MSG} ""
+.endif
+
post-extract:
# for cdrom/vcd support
# taken from mplayer distfile
@@ -114,32 +134,17 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|PFLAGS@|PFLAGS@ -I${LOCALBASE}/include/mjpegtools -I${LOCALBASE}/include/mjpegtools/mplex|' \
${WRKSRC}/ext/mplex/Makefile.in
-.if ${CXXFLAGS:M*=athlon-4} || ${CXXFLAGS:M*=athlon-mp} || ${CXXFLAGS:M*=athlon-xp}
-# Fix gst-register when using -O -march=athlon-xp
- @${REINPLACE_CMD} -e 's|@CXXF|-fgcse @CXXF|g' \
- ${WRKSRC}/gst/modplug/Makefile.in \
- ${WRKSRC}/gst/modplug/libmodplug/Makefile.in
+.if ${GST_PLUGIN}!="base"
+ @${REINPLACE_CMD} -E -e 's|ac_config_files=\"*\"|ac_config_files="$$ac_config_files Makefile ${GST_PLUGIN_MAKEFILES}" #|' \
+ ${WRKSRC}/configure
.endif
-pre-build:
-# This port cannot be CFLAGS safe, when using p4 optimizations
-# because it breaks the mod plugin
- @${REINPLACE_CMD} -E \
- -e 's|(-march=pentiu)m4|\1m3|g' \
- -e 's|(-mcpu=pentiu)m4|\1m3|g' \
- -e 's|(-mtune=pentiu)m)4|\1m3|g' \
- ${WRKSRC}/gst/modplug/Makefile \
- ${WRKSRC}/gst/modplug/libmodplug/Makefile
-
post-build:
.ifdef(EXTRA_BUILD_DIR)
. for dir in ${EXTRA_BUILD_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
. endfor
.endif
-# @${ECHO_CMD} "@unexec ${PREFIX}/bin/gst-register-${GST_VERSION} \
-# --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml \
-# >> ${TMPPLIST}"
post-install:
.ifdef(EXTRA_BUILD_DIR)
@@ -151,5 +156,4 @@ post-install:
-@${X11BASE}/bin/gst-register-${GST_VERSION} \
--gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
-.include "${MASTERDIR}/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer-plugins80/Makefile.common b/multimedia/gstreamer-plugins80/Makefile.common
index 45b6a752435b..d5ffb4f06463 100644
--- a/multimedia/gstreamer-plugins80/Makefile.common
+++ b/multimedia/gstreamer-plugins80/Makefile.common
@@ -2,21 +2,24 @@ GST_ALL_PLUGINS= \
a52dec \
aalib \
aalibtest \
- alsa \
+ amrnb \
arts \
artstest \
artsc \
audiofile \
+ audioresample \
cairo \
cdaudio \
cdparanoia \
dirac \
+ directfb \
divx \
dts \
dvdnav \
dvdread \
dxr3 \
esd \
+ esdtest \
faac \
faad \
flac \
@@ -49,6 +52,7 @@ GST_ALL_PLUGINS= \
musicbrainz \
nas \
ogg \
+ oggtest \
opengl \
pango \
polyp \
@@ -56,8 +60,10 @@ GST_ALL_PLUGINS= \
qcam \
raw1394 \
sdl \
+ sdltest \
shout \
shout2 \
+ shout2test \
sidplay \
smoothwave \
sndfile \
@@ -69,6 +75,7 @@ GST_ALL_PLUGINS= \
vcd \
vorbis \
xine \
+ vorbistest \
xvid
# Disable all plugins by default\
@@ -77,6 +84,7 @@ CONFIGURE_ARGS+= --disable-${d}
.endfor
CONFIGURE_ARGS+=--disable-tests \
+ --disable-examples \
--disable-alsa \
--disable-http \
--enable-cdrom \
@@ -86,8 +94,9 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-osx_audio \
--disable-osx_video \
--enable-static \
- --enable-gst_v4l \
- --enable-gst_v4l2 \
+ --disable-sunaudio \
+ --disable-gst_v4l \
+ --disable-gst_v4l2 \
--enable-x \
--enable-xshm \
--enable-xvideo
@@ -430,10 +439,6 @@ do-build:
${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
.endfor
-post-build:
- @${ECHO_CMD} ${PREFIX}/bin/gst-register-${GST_VERSION} \
- --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml
-
do-install:
.for dir in ${GST_PLUGIN_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
diff --git a/multimedia/gstreamer-plugins80/pkg-plist b/multimedia/gstreamer-plugins80/pkg-plist
index e1d97a9a66c2..25e6d1b6a4d2 100644
--- a/multimedia/gstreamer-plugins80/pkg-plist
+++ b/multimedia/gstreamer-plugins80/pkg-plist
@@ -186,3 +186,5 @@ share/locale/vi/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/audio
@unexec rmdir %D/include/gstreamer-%%VERSION%%/gst 2>/dev/null || true
@unexec rmdir %D/include/gstreamer-%%VERSION%% 2>/dev/null || true
+@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true
+@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true