aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-09-12 05:11:02 +0800
committermarcus <marcus@FreeBSD.org>2002-09-12 05:11:02 +0800
commit33353d188195fb891b63471a2590ad69a127156b (patch)
tree43a940270ddb8ecd8823b75655de941b8ab01b93
parentfd50f7c81e54984c91287d9ed6bd37fbbf4753c3 (diff)
downloadfreebsd-ports-gnome-33353d188195fb891b63471a2590ad69a127156b.tar.gz
freebsd-ports-gnome-33353d188195fb891b63471a2590ad69a127156b.tar.zst
freebsd-ports-gnome-33353d188195fb891b63471a2590ad69a127156b.zip
Fix build with Mozilla-1.0.1.
-rw-r--r--www/galeon/Makefile4
-rw-r--r--www/galeon/files/patch-src_mozilla_GaleonWrapper.cpp11
-rw-r--r--www/galeon2/Makefile4
-rw-r--r--www/galeon2/files/patch-src_mozilla_GaleonWrapper.cpp11
4 files changed, 28 insertions, 2 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 232791cb5ce0..1e2af244caa9 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= galeon
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -33,7 +34,8 @@ USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}" \
- --enable-nautilus-view
+ --enable-nautilus-view \
+ --with-mozilla-snapshot="1.0.1"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_REENTRANT ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/www/galeon/files/patch-src_mozilla_GaleonWrapper.cpp b/www/galeon/files/patch-src_mozilla_GaleonWrapper.cpp
new file mode 100644
index 000000000000..d0aa0aaaaea7
--- /dev/null
+++ b/www/galeon/files/patch-src_mozilla_GaleonWrapper.cpp
@@ -0,0 +1,11 @@
+--- src/mozilla/GaleonWrapper.cpp.orig Wed Sep 11 16:59:41 2002
++++ src/mozilla/GaleonWrapper.cpp Wed Sep 11 17:00:49 2002
+@@ -182,7 +182,7 @@
+ }
+ else
+ {
+-#if MOZILLA_SNAPSHOT > 1
++#if MOZILLA_SNAPSHOT >= 1
+ result = print->PrintPreview(options, nsnull, nsnull);
+ #else
+ result = print->PrintPreview(options);
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 232791cb5ce0..1e2af244caa9 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= galeon
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -33,7 +34,8 @@ USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}" \
- --enable-nautilus-view
+ --enable-nautilus-view \
+ --with-mozilla-snapshot="1.0.1"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_REENTRANT ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/www/galeon2/files/patch-src_mozilla_GaleonWrapper.cpp b/www/galeon2/files/patch-src_mozilla_GaleonWrapper.cpp
new file mode 100644
index 000000000000..d0aa0aaaaea7
--- /dev/null
+++ b/www/galeon2/files/patch-src_mozilla_GaleonWrapper.cpp
@@ -0,0 +1,11 @@
+--- src/mozilla/GaleonWrapper.cpp.orig Wed Sep 11 16:59:41 2002
++++ src/mozilla/GaleonWrapper.cpp Wed Sep 11 17:00:49 2002
+@@ -182,7 +182,7 @@
+ }
+ else
+ {
+-#if MOZILLA_SNAPSHOT > 1
++#if MOZILLA_SNAPSHOT >= 1
+ result = print->PrintPreview(options, nsnull, nsnull);
+ #else
+ result = print->PrintPreview(options);