aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-07-12 19:56:29 +0800
committervs <vs@FreeBSD.org>2004-07-12 19:56:29 +0800
commit363ef702f13c985d07a174d2a5f04b672971a69c (patch)
tree01a0f0b61073efd567fe44e8bab77c44a4477554
parent9eaced08554ac06f47159a5404bebc100401127b (diff)
downloadfreebsd-ports-gnome-363ef702f13c985d07a174d2a5f04b672971a69c.tar.gz
freebsd-ports-gnome-363ef702f13c985d07a174d2a5f04b672971a69c.tar.zst
freebsd-ports-gnome-363ef702f13c985d07a174d2a5f04b672971a69c.zip
Fix .skippyrc-parsing (bump PORTREVISION)
PR: ports/68705 Submitted by: Leland Wang Approved by: maintainer
-rw-r--r--x11-wm/skippy/Makefile1
-rw-r--r--x11-wm/skippy/files/patch-config.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-wm/skippy/Makefile b/x11-wm/skippy/Makefile
index 20c41358f502..735a1d918a3b 100644
--- a/x11-wm/skippy/Makefile
+++ b/x11-wm/skippy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skippy
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://thegraveyard.org/files/
diff --git a/x11-wm/skippy/files/patch-config.c b/x11-wm/skippy/files/patch-config.c
new file mode 100644
index 000000000000..4dfcce54a0fa
--- /dev/null
+++ b/x11-wm/skippy/files/patch-config.c
@@ -0,0 +1,22 @@
+--- config.c.orig Mon Jul 5 22:36:39 2004
++++ config.c Mon Jul 5 23:32:25 2004
+@@ -72,9 +72,9 @@
+ int ix = 0, l_ix = 0;
+ dlist *new_config = 0;
+
+- regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*?)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
+ regcomp(&re_empty, "^[[:space:]]*#|^[[:space:]]*$", REG_EXTENDED);
+- regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*?)[[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*)[[:space:]]*$", REG_EXTENDED);
+
+ while(1)
+ {
+@@ -148,6 +148,7 @@
+ fclose(fin);
+ return 0;
+ }
++ data[flen] = '\0';
+
+ fclose(fin);
+