aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-14 11:04:39 +0800
committerkris <kris@FreeBSD.org>2004-03-14 11:04:39 +0800
commit37b7848f6574f265cf0a4d7e96710aa2a7a3dbdb (patch)
tree99b2982d88c6222ff7c1e32081599d66a4b65f36
parentc97a0c1154e00cdbf4b46e1e99033babbb160c76 (diff)
downloadfreebsd-ports-gnome-37b7848f6574f265cf0a4d7e96710aa2a7a3dbdb.tar.gz
freebsd-ports-gnome-37b7848f6574f265cf0a4d7e96710aa2a7a3dbdb.tar.zst
freebsd-ports-gnome-37b7848f6574f265cf0a4d7e96710aa2a7a3dbdb.zip
Switch to USE_GCC=3.3 and work around bsd.port.mk bug that does not add
CC and CXX to MAKE_ENV.
-rw-r--r--net/xmlrpc++/Makefile11
-rw-r--r--security/libecc/Makefile11
2 files changed, 18 insertions, 4 deletions
diff --git a/net/xmlrpc++/Makefile b/net/xmlrpc++/Makefile
index 3c95fec30cf4..daa25cd2e693 100644
--- a/net/xmlrpc++/Makefile
+++ b/net/xmlrpc++/Makefile
@@ -18,9 +18,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ implementation of the XML-RPC protocol
USE_REINPLACE= yes
-USE_GCC= 3.1
+USE_GCC= 3.3
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501103
+# Work around bsd.port.mk bug: Does not currently set up MAKE_ENV for gcc 3.2 and 3.3
+MAKE_ENV+= CC="${CC}" CXX="${CXX}"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|^CXX|#CXX|" -e "s|^CXXFLAGS|#CXXFLAGS|" \
-e "s|tests$$||" ${WRKSRC}/Makefile
@@ -30,4 +37,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/src/XmlRpc*.h ${PREFIX}/include/xmlrpc++
${INSTALL_PROGRAM} ${WRKSRC}/libXmlRpc.a ${PREFIX}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/libecc/Makefile b/security/libecc/Makefile
index df55f211cd7b..bd61797131e6 100644
--- a/security/libecc/Makefile
+++ b/security/libecc/Makefile
@@ -15,8 +15,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ Elliptic Curve Library
-USE_GCC= 3.1
+USE_GCC= 3.3
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501103
+# Work around bsd.port.mk bug: Does not currently set up MAKE_ENV for gcc 3.2 and 3.3
+MAKE_ENV+= CC="${CC}" CXX="${CXX}"
+.endif
+
+.include <bsd.port.post.mk>