aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-08-13 14:41:17 +0800
committercrees <crees@FreeBSD.org>2011-08-13 14:41:17 +0800
commit3a8e69df6d208fde4a34371e1671422b4ea3df68 (patch)
treed15a0924c0369351985195547dab8a4b3a2189b6
parentce6f405295a514aa3168b2e9563e0bb00c641bab (diff)
downloadfreebsd-ports-gnome-3a8e69df6d208fde4a34371e1671422b4ea3df68.tar.gz
freebsd-ports-gnome-3a8e69df6d208fde4a34371e1671422b4ea3df68.tar.zst
freebsd-ports-gnome-3a8e69df6d208fde4a34371e1671422b4ea3df68.zip
Fix on amd64 -- cputype is called x86_64 here.
PR: ports/159627 Submitted by: rdivacky Approved by: Armin Pirkovitsch <armin@frozen-zone.org> (maintainer)
-rw-r--r--lang/cparser/Makefile1
-rw-r--r--lang/cparser/files/patch-firm_machine-c25
2 files changed, 26 insertions, 0 deletions
diff --git a/lang/cparser/Makefile b/lang/cparser/Makefile
index 1f93f984f011..e40aab0280a9 100644
--- a/lang/cparser/Makefile
+++ b/lang/cparser/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cparser
PORTVERSION= 0.9.12
+PORTREVISION= 1
CATEGORIES= lang devel
MASTER_SITES= SF
diff --git a/lang/cparser/files/patch-firm_machine-c b/lang/cparser/files/patch-firm_machine-c
new file mode 100644
index 000000000000..d1de83080bda
--- /dev/null
+++ b/lang/cparser/files/patch-firm_machine-c
@@ -0,0 +1,25 @@
+$FreeBSD$
+
+By rdivacky@, enables cparser to work out of the box on amd64
+
+--- work/cparser-0.9.12/driver/firm_machine.c 2011-04-14 16:51:46.000000000 +0200
++++ /tmp/firm_machine.c 2011-08-12 22:04:40.000000000 +0200
+@@ -77,12 +77,18 @@
+ machine_triple_t *firm_get_host_machine(void)
+ {
+ machine_triple_t *machine = XMALLOC(machine_triple_t);
++#ifdef __amd64__
++ machine->cpu_type = xstrdup("x86_64");
++#else
+ machine->cpu_type = xstrdup("i386");
++#endif
+ machine->manufacturer = xstrdup("unknown");
+ #if defined(_WIN32) || defined(__CYGWIN__)
+ machine->operating_system = xstrdup("win32");
+ #elif defined(__APPLE__)
+ machine->operating_system = xstrdup("darwin");
++#elif defined(__FreeBSD__)
++ machine->operating_system = xstrdup("bsd");
+ #else
+ machine->operating_system = xstrdup("linux");
+ #endif