aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-28 16:35:59 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-28 16:35:59 +0800
commit3eea2b7f370347390fe3c2af1286f751a79cca4b (patch)
tree8d432c6567c8eb313abcd98d69fc48c142fc7431
parent504e40836c6bd83e63e897475e4b7e4814f6377d (diff)
downloadfreebsd-ports-gnome-3eea2b7f370347390fe3c2af1286f751a79cca4b.tar.gz
freebsd-ports-gnome-3eea2b7f370347390fe3c2af1286f751a79cca4b.tar.zst
freebsd-ports-gnome-3eea2b7f370347390fe3c2af1286f751a79cca4b.zip
Support staging
-rw-r--r--net/dhcperf/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/net/dhcperf/Makefile b/net/dhcperf/Makefile
index c9bea26823d7..dd690039bd32 100644
--- a/net/dhcperf/Makefile
+++ b/net/dhcperf/Makefile
@@ -19,19 +19,21 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-1/
PLIST_FILES= bin/dhcperf \
share/doc/dhcperf/dcsevaltutorial.pdf \
- share/doc/dhcperf/dhcperf.pdf
+ share/doc/dhcperf/dhcperf.pdf man/man1/dhcperf.1.gz
PLIST_DIRS= share/doc/dhcperf
-MAN1= dhcperf.1
-NO_STAGE= yes
post-extract:
${TAR} -C ${WRKSRC} -zxvf ${WRKSRC}/${PORTNAME}-${PORTVERSION}_1.tgz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/usr/local/nom/bin/dhcperf ${PREFIX}/bin/dhcperf
- ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/man/man1/dhcperf.1 ${PREFIX}/man/man1
- ${MKDIR} ${PREFIX}/share/doc/dhcperf
- ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dcsevaltutorial.pdf ${PREFIX}/share/doc/dhcperf/dcsevaltutorial.pdf
- ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dhcperf.pdf ${PREFIX}/share/doc/dhcperf/dhcperf.pdf
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr/local/nom/bin/dhcperf \
+ ${STAGEDIR}${PREFIX}/bin/dhcperf
+ ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/man/man1/dhcperf.1 \
+ ${STAGEDIR}${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/dhcperf
+ ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dcsevaltutorial.pdf \
+ ${STAGEDIR}${PREFIX}/share/doc/dhcperf/dcsevaltutorial.pdf
+ ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dhcperf.pdf \
+ ${STAGEDIR}${PREFIX}/share/doc/dhcperf/dhcperf.pdf
.include <bsd.port.mk>