aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-07-17 00:41:12 +0800
committersat <sat@FreeBSD.org>2007-07-17 00:41:12 +0800
commit3f77c441c237853a6d5130d1ac64bdf0807193e6 (patch)
treeb2c8c54580b9902faddc09b95d7a379c0bf54556
parent792c5475f67babf8b6919e12f3dd15b621a4967f (diff)
downloadfreebsd-ports-gnome-3f77c441c237853a6d5130d1ac64bdf0807193e6.tar.gz
freebsd-ports-gnome-3f77c441c237853a6d5130d1ac64bdf0807193e6.tar.zst
freebsd-ports-gnome-3f77c441c237853a6d5130d1ac64bdf0807193e6.zip
- Unbreak with gcc4 by using strtoq(3) instead of strtoll(3)
Reported by: pointyhat via pav
-rw-r--r--multimedia/subtitleeditor/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
index cb44bab60815..257a9c6cfdb5 100644
--- a/multimedia/subtitleeditor/Makefile
+++ b/multimedia/subtitleeditor/Makefile
@@ -34,6 +34,6 @@ MAN1= ${PORTNAME}.1
post-patch:
@${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|strtoll|std::strtoll|g' ${WRKSRC}/src/SubtitleASS.cc
+ @${REINPLACE_CMD} -e 's|strtoll|strtoq|g' ${WRKSRC}/src/SubtitleASS.cc
.include <bsd.port.mk>