aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2001-03-16 21:26:27 +0800
committerjoerg <joerg@FreeBSD.org>2001-03-16 21:26:27 +0800
commit402743a82c163fcde3fee12daa2ec5f8af95983a (patch)
tree257de3091d2e19bc586f36861ecb6953c4d90e0f
parent19110356d2dc95d35cc485456875a4993d1192ce (diff)
downloadfreebsd-ports-gnome-402743a82c163fcde3fee12daa2ec5f8af95983a.tar.gz
freebsd-ports-gnome-402743a82c163fcde3fee12daa2ec5f8af95983a.tar.zst
freebsd-ports-gnome-402743a82c163fcde3fee12daa2ec5f8af95983a.zip
Finally get the avr-gcc port really compile on the alpha architecture,
by forcing the CFLAGS to -O -pipe. Somehow, the alpha build always tries to enforce a particular -mcpu=ev4 flag which of course cannot be understood by the (AVR) xgcc later on. This looks to me like a bug in the cross-compilation environment of gcc, but i'm tired of actually finding the bug. The compiled result of avr-gcc MD5 compares equal to something build from an IA32 host platform.
-rw-r--r--devel/avr-gcc-3/Makefile1
-rw-r--r--devel/avr-gcc/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 29656d92a37c..2fed433ac19c 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -34,6 +34,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr
+CONFIGURE_ENV= CFLAGS="-O -pipe"
MAKE_FLAGS= LANGUAGES="c"
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 29656d92a37c..2fed433ac19c 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -34,6 +34,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr
+CONFIGURE_ENV= CFLAGS="-O -pipe"
MAKE_FLAGS= LANGUAGES="c"