aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-03-29 17:17:44 +0800
committerwill <will@FreeBSD.org>2000-03-29 17:17:44 +0800
commit43ee9985c959eb599e3180ed71a9ac4bda466b1a (patch)
tree1032b2fc51384ec44fe0de0f98f9d3930e2e91f5
parent32141b4035c3d20147e4f27900478480637905e1 (diff)
downloadfreebsd-ports-gnome-43ee9985c959eb599e3180ed71a9ac4bda466b1a.tar.gz
freebsd-ports-gnome-43ee9985c959eb599e3180ed71a9ac4bda466b1a.tar.zst
freebsd-ports-gnome-43ee9985c959eb599e3180ed71a9ac4bda466b1a.zip
Whoops, botched commit. This was actually something I was working on a
few weeks ago. Unfortunately, I can't update the port completely since there are some complications (such as requiring kdelibs2, which I haven't upgraded yet), so I'm reverting this to andy's old Makefile. This should teach me to commit in unclean checkouts. ;-) Quickly noticed by: will, kkenn
-rw-r--r--devel/qtez/Makefile27
1 files changed, 19 insertions, 8 deletions
diff --git a/devel/qtez/Makefile b/devel/qtez/Makefile
index 0fdfc55ef654..994e6740e7da 100644
--- a/devel/qtez/Makefile
+++ b/devel/qtez/Makefile
@@ -6,19 +6,30 @@
# $FreeBSD$
#
-DISTNAME= qtez-0.85.2
+DISTNAME= QtEZ.current-src
+PKGNAME= qtez-0.77a
CATEGORIES= devel
-MASTER_SITES= http://www.ibl.sk/qtez/download/
+MASTER_SITES= http://qtez.zax.net/qtez-extras/
MAINTAINER= will@FreeBSD.org
USE_X_PREFIX= yes
-USE_BZIP2= yes
-USE_QT2= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} --with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib
+USE_QT= yes
USE_GMAKE= yes
-MAKE_ENV+= PCFLAGS="${CXXFLAGS}"
+WRKSRC= ${WRKDIR}/qtez_src
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKDIR}/qtez_src/bin/qtez ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/examples/qtez
+ @cd ${WRKDIR}/qtez_src/demo; tar cf - . | (cd ${PREFIX}/share/examples/qtez; tar xf - )
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/qtez
+.for file in INSTALL KDE.README README TODO
+ @${INSTALL_DATA} ${WRKDIR}/qtez_src/${file} ${PREFIX}/share/doc/qtez
+.endfor
+ @cd ${WRKDIR}/qtez_src/docs; tar cf - . | (cd ${PREFIX}/share/doc/qtez; tar xf - )
+.endif
.include <bsd.port.mk>