aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-04-26 02:19:15 +0800
committerjbeich <jbeich@FreeBSD.org>2015-04-26 02:19:15 +0800
commit4a3001a6bfefe2ef0a7717224e4e52bcf1e32abe (patch)
tree1fe682166d3e5dcdef49f96b4e19154092efe5f9
parent2e20a1a1e7f3d269cfa42f217cbc68bcc41b62e8 (diff)
downloadfreebsd-ports-gnome-4a3001a6bfefe2ef0a7717224e4e52bcf1e32abe.tar.gz
freebsd-ports-gnome-4a3001a6bfefe2ef0a7717224e4e52bcf1e32abe.tar.zst
freebsd-ports-gnome-4a3001a6bfefe2ef0a7717224e4e52bcf1e32abe.zip
Unbreak build on FreeBSD 8.x/9.x and DragonFly
./PYSignal.h:35:22: error: expected namespace name using namespace std::placeholders; ~~~~~^ ./PYSignal.h:49:18: error: no type named 'function' in namespace 'std' typedef std::function<R()> func_type; ~~~~~^ ./PYEditor.h:37:14: error: no type named 'shared_ptr' in namespace 'std' typedef std::shared_ptr<Editor> EditorPtr; ~~~~~^ PYLibPinyin.cc:223:54: error: 'getline' was not declared in this scope while ((read = getline (&linebuf, &size, dictfile)) != -1) { ^ PR: 199408 Reported by: pkg-fallout, DPorts Submitted by: Henry Hu <henry.hu.sh@gmail.com> (maintainer)
-rw-r--r--chinese/ibus-libpinyin/Makefile2
-rw-r--r--chinese/ibus-libpinyin/files/patch-src_PYLibPinyin.cc11
2 files changed, 12 insertions, 1 deletions
diff --git a/chinese/ibus-libpinyin/Makefile b/chinese/ibus-libpinyin/Makefile
index bf3af95268a1..f46bbfc1743c 100644
--- a/chinese/ibus-libpinyin/Makefile
+++ b/chinese/ibus-libpinyin/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
libibus-1.0.so:${PORTSDIR}/textproc/ibus \
libpinyin.so:${PORTSDIR}/chinese/libpinyin
-USES= compiler:c++0x gmake python pkgconfig gettext
+USES= compiler:c++11-lib gmake python pkgconfig gettext
USE_GNOME= glib20
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/chinese/ibus-libpinyin/files/patch-src_PYLibPinyin.cc b/chinese/ibus-libpinyin/files/patch-src_PYLibPinyin.cc
new file mode 100644
index 000000000000..9fbac7843ef2
--- /dev/null
+++ b/chinese/ibus-libpinyin/files/patch-src_PYLibPinyin.cc
@@ -0,0 +1,11 @@
+--- src/PYLibPinyin.cc.orig 2015-01-23 04:57:48 UTC
++++ src/PYLibPinyin.cc
+@@ -21,6 +21,8 @@
+
+ #include "PYLibPinyin.h"
+
++#define _WITH_GETLINE
++#include <stdio.h>
+ #include <string.h>
+ #include <pinyin.h>
+ #include "PYPConfig.h"