aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2009-05-13 14:06:41 +0800
committerskv <skv@FreeBSD.org>2009-05-13 14:06:41 +0800
commit4de7bb93b65a53c9ce27aa8b4dd309c5d6c45a1b (patch)
treeffb695ccdccbed789be9cd57120ddd04fa289091
parent3412833abd3292d0dff75092573a2bfeb22fd416 (diff)
downloadfreebsd-ports-gnome-4de7bb93b65a53c9ce27aa8b4dd309c5d6c45a1b.tar.gz
freebsd-ports-gnome-4de7bb93b65a53c9ce27aa8b4dd309c5d6c45a1b.tar.zst
freebsd-ports-gnome-4de7bb93b65a53c9ce27aa8b4dd309c5d6c45a1b.zip
Add p5-MooseX-MethodAttributes 0.09, code attribute introspection.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooseX-MethodAttributes/Makefile33
-rw-r--r--devel/p5-MooseX-MethodAttributes/distinfo3
-rw-r--r--devel/p5-MooseX-MethodAttributes/pkg-descr4
-rw-r--r--devel/p5-MooseX-MethodAttributes/pkg-plist17
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8f3e240f4a5d..878476885c28 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1610,6 +1610,7 @@
SUBDIR += p5-MooseX-Log-Log4perl
SUBDIR += p5-MooseX-Meta-TypeConstraint-ForceCoercion
SUBDIR += p5-MooseX-Method-Signatures
+ SUBDIR += p5-MooseX-MethodAttributes
SUBDIR += p5-MooseX-POE
SUBDIR += p5-MooseX-Policy-SemiAffordanceAccessor
SUBDIR += p5-MooseX-SimpleConfig
diff --git a/devel/p5-MooseX-MethodAttributes/Makefile b/devel/p5-MooseX-MethodAttributes/Makefile
new file mode 100644
index 000000000000..9a4c390cfbb7
--- /dev/null
+++ b/devel/p5-MooseX-MethodAttributes/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: MooseX-MethodAttributes
+# Date created: 13 May 2009
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-MethodAttributes
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Code attribute introspection
+
+BUILD_DEPENDS= p5-Moose>=0.70:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Types>=0.06:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MooseX::MethodAttributes.3 \
+ MooseX::MethodAttributes::Inheritable.3 \
+ MooseX::MethodAttributes::Role::AttrContainer.3 \
+ MooseX::MethodAttributes::Role::AttrContainer::Inheritable.3 \
+ MooseX::MethodAttributes::Role::Meta::Class.3 \
+ MooseX::MethodAttributes::Role::Meta::Method.3 \
+ MooseX::MethodAttributes::Role::Meta::Method::MaybeWrapped.3 \
+ MooseX::MethodAttributes::Role::Meta::Method::Wrapped.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-MethodAttributes/distinfo b/devel/p5-MooseX-MethodAttributes/distinfo
new file mode 100644
index 000000000000..265ff2619528
--- /dev/null
+++ b/devel/p5-MooseX-MethodAttributes/distinfo
@@ -0,0 +1,3 @@
+MD5 (MooseX-MethodAttributes-0.09.tar.gz) = 97b7ab57a005efa6f744d8b0041ea7af
+SHA256 (MooseX-MethodAttributes-0.09.tar.gz) = 7fcda0a2de705b69f3154d68b13cbdaf3b6000b1de09edfbf88fd297eb94a7d4
+SIZE (MooseX-MethodAttributes-0.09.tar.gz) = 13440
diff --git a/devel/p5-MooseX-MethodAttributes/pkg-descr b/devel/p5-MooseX-MethodAttributes/pkg-descr
new file mode 100644
index 000000000000..84d649cede74
--- /dev/null
+++ b/devel/p5-MooseX-MethodAttributes/pkg-descr
@@ -0,0 +1,4 @@
+MooseX::MethodAttributes allows code attributes of methods to be
+introspected using Moose meta method objects.
+
+WWW: http://search.cpan.org/dist/MooseX-MethodAttributes/
diff --git a/devel/p5-MooseX-MethodAttributes/pkg-plist b/devel/p5-MooseX-MethodAttributes/pkg-plist
new file mode 100644
index 000000000000..790f96d8ac67
--- /dev/null
+++ b/devel/p5-MooseX-MethodAttributes/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/MethodAttributes/.packlist
+%%SITE_PERL%%/MooseX/MethodAttributes.pm
+%%SITE_PERL%%/MooseX/MethodAttributes/Inheritable.pm
+%%SITE_PERL%%/MooseX/MethodAttributes/Role/AttrContainer.pm
+%%SITE_PERL%%/MooseX/MethodAttributes/Role/AttrContainer/Inheritable.pm
+%%SITE_PERL%%/MooseX/MethodAttributes/Role/Meta/Class.pm
+%%SITE_PERL%%/MooseX/MethodAttributes/Role/Meta/Method.pm
+%%SITE_PERL%%/MooseX/MethodAttributes/Role/Meta/Method/MaybeWrapped.pm
+%%SITE_PERL%%/MooseX/MethodAttributes/Role/Meta/Method/Wrapped.pm
+@dirrm %%SITE_PERL%%/MooseX/MethodAttributes/Role/Meta/Method
+@dirrm %%SITE_PERL%%/MooseX/MethodAttributes/Role/Meta
+@dirrm %%SITE_PERL%%/MooseX/MethodAttributes/Role/AttrContainer
+@dirrm %%SITE_PERL%%/MooseX/MethodAttributes/Role
+@dirrm %%SITE_PERL%%/MooseX/MethodAttributes
+@dirrmtry %%SITE_PERL%%/MooseX
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/MethodAttributes
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX