aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2011-01-29 07:30:35 +0800
committerdhn <dhn@FreeBSD.org>2011-01-29 07:30:35 +0800
commit505029db2152be13104e19df3eea259db9069251 (patch)
treebc6e42b9d05f7c8a87105a4bef824be49857bc97
parentbe3c91930a608dfb6673ccf0ace4989190cfe0d6 (diff)
downloadfreebsd-ports-gnome-505029db2152be13104e19df3eea259db9069251.tar.gz
freebsd-ports-gnome-505029db2152be13104e19df3eea259db9069251.tar.zst
freebsd-ports-gnome-505029db2152be13104e19df3eea259db9069251.zip
- Fix the handling of CPPFLAGS in the context of CONFIGURE_ENV / MAKE_ENV.
PR: ports/153625 Submitted by: gerald Feature safe: yes
-rw-r--r--net/wire/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/net/wire/Makefile b/net/wire/Makefile
index d18b9450f327..782845f4a74c 100644
--- a/net/wire/Makefile
+++ b/net/wire/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wire
PORTVERSION= 1.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://mirror.mcx2.org/ \
${MASTER_SITE_LOCAL}
@@ -17,19 +17,29 @@ MAINTAINER= dhn@FreeBSD.org
COMMENT= Wire is a screen-oriented command line Wired client
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= CPPFLAGS=${CPPFLAGS} LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --libdir="${LOCALBASE}/lib" --includedir="${LOCALBASE}/include"
-CFLAGS+= "-I${LOCALBASE}/include"
+MAKE_ENV= CPPFLAGS=${CPPFLAGS}
+
USE_GMAKE= yes
+USE_OPENSSL= yes
USE_ICONV= yes
PLIST_FILES= bin/wire
MAN1= wire.1
-.include <bsd.port.pre.mk>
+#.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libreadline.so.6)
LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
-.include <bsd.port.post.mk>
+#.include <bsd.port.post.mk>
+
+#TODO this is fucking dirty :(
+do-build:
+ cd ${WRKSRC} ;${GMAKE}
+
+.include <bsd.port.mk>