aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-10-15 21:18:21 +0800
committerflz <flz@FreeBSD.org>2005-10-15 21:18:21 +0800
commit5569ae47d1f6d1f26bbd473e48bdb792f8ecfa56 (patch)
tree7b0e21fb306ac2e15d87f80d09bb7718795ea303
parent03814a25fe45df426a7679967bdc15e00b4ecb60 (diff)
downloadfreebsd-ports-gnome-5569ae47d1f6d1f26bbd473e48bdb792f8ecfa56.tar.gz
freebsd-ports-gnome-5569ae47d1f6d1f26bbd473e48bdb792f8ecfa56.tar.zst
freebsd-ports-gnome-5569ae47d1f6d1f26bbd473e48bdb792f8ecfa56.zip
- Since (ipw|iwi)control are started late in the boot process, we need to
mark interfaces as up manually. Noticed by: sem
-rw-r--r--net/ipw-firmware/Makefile2
-rw-r--r--net/ipw-firmware/files/ipw.sh.in1
-rw-r--r--net/iwi-firmware/Makefile2
-rw-r--r--net/iwi-firmware/files/iwi.sh.in1
4 files changed, 4 insertions, 2 deletions
diff --git a/net/ipw-firmware/Makefile b/net/ipw-firmware/Makefile
index 2e86df7a3964..c83a19f6cfc0 100644
--- a/net/ipw-firmware/Makefile
+++ b/net/ipw-firmware/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= ipw-firmware
RELNAME?= ipw2100
PORTVERSION?= 1.3
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= net sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= flz/ipw
diff --git a/net/ipw-firmware/files/ipw.sh.in b/net/ipw-firmware/files/ipw.sh.in
index b20894b99a0a..f92d01d6b420 100644
--- a/net/ipw-firmware/files/ipw.sh.in
+++ b/net/ipw-firmware/files/ipw.sh.in
@@ -51,6 +51,7 @@ command="/usr/local/sbin/%%DRIVERNAME%%control"
eval _file=\$_%%DRIVERNAME%%_file_${i}
echo -n " [${i}:${_mode:=bss}]"
${command} -i ${i} -f %%DATADIR%%/${_file}
+ ifconfig ${i} up
done
echo "."
}
diff --git a/net/iwi-firmware/Makefile b/net/iwi-firmware/Makefile
index 9305187f7277..9b7c74be93b2 100644
--- a/net/iwi-firmware/Makefile
+++ b/net/iwi-firmware/Makefile
@@ -8,7 +8,7 @@
PORTNAME= iwi-firmware
RELNAME= ipw2200
PORTVERSION= 2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net sysutils
MAINTAINER= flz@FreeBSD.org
diff --git a/net/iwi-firmware/files/iwi.sh.in b/net/iwi-firmware/files/iwi.sh.in
index f3f2748d1e8a..602dd8efd3df 100644
--- a/net/iwi-firmware/files/iwi.sh.in
+++ b/net/iwi-firmware/files/iwi.sh.in
@@ -44,6 +44,7 @@ command="/usr/local/sbin/%%DRIVERNAME%%control"
eval _mode=\$_%%DRIVERNAME%%_file_${i}
echo -n " [${i}:${_mode:=bss}]"
${command} -i ${i} -d %%DATADIR%% -m ${_mode:=bss}
+ ifconfig ${i} up
done
echo "."
}