aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-26 14:55:07 +0800
committerbapt <bapt@FreeBSD.org>2014-05-26 14:55:07 +0800
commit58fd306132807ea61fa3a55874b349555f47f9aa (patch)
tree2266451e8dedf72ded023f5ab6e33cb91292aa8a
parent099d99786c055f7007a59b62fc248df1aef5018c (diff)
downloadfreebsd-ports-gnome-58fd306132807ea61fa3a55874b349555f47f9aa.tar.gz
freebsd-ports-gnome-58fd306132807ea61fa3a55874b349555f47f9aa.tar.zst
freebsd-ports-gnome-58fd306132807ea61fa3a55874b349555f47f9aa.zip
Convert to USES=dos2unix
With hat: portmgr
-rw-r--r--astro/gpstk/Makefile4
-rw-r--r--biology/muscle/Makefile4
-rw-r--r--cad/meshdev/Makefile5
-rw-r--r--cad/openvsp/Makefile3
-rw-r--r--chinese/phpbb-tw/Makefile2
-rw-r--r--comms/openobex/Makefile4
-rw-r--r--comms/usrp/Makefile3
-rw-r--r--converters/p5-WAP-wbxml/Makefile3
-rw-r--r--databases/gigabase/Makefile4
-rw-r--r--deskutils/myitcrm/Makefile3
-rw-r--r--devel/asdlgen/Makefile3
-rw-r--r--devel/common_lib/Makefile4
-rw-r--r--devel/esdl/Makefile4
-rw-r--r--devel/libdwarf/Makefile3
-rw-r--r--devel/oserl/Makefile4
-rw-r--r--devel/pear-PHP_CompatInfo/Makefile2
-rw-r--r--emulators/dynagen/Makefile2
-rw-r--r--emulators/mupen64plus-core/Makefile.common3
-rw-r--r--emulators/visualboyadvance-m/Makefile4
19 files changed, 31 insertions, 33 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 35345b423d08..41b78c10f713 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -14,11 +14,11 @@ BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= dos2unix
NO_STAGE= yes
USE_PYTHON_RUN= yes
USE_LDCONFIG= yes
-USE_DOS2UNIX= yes
-DOS2UNIX_REGEX= ${WRKSRC}/Jamrules
+DOS2UNIX_FILES= ${WRKSRC}/Jamrules
JAM= jam
JAM_ENV= PREFIX="${PREFIX}" \
diff --git a/biology/muscle/Makefile b/biology/muscle/Makefile
index 224eada0040e..436f3066a952 100644
--- a/biology/muscle/Makefile
+++ b/biology/muscle/Makefile
@@ -22,8 +22,8 @@ COMMENT= Multiple Sequence Comparison by Log-Expectation
FETCH_ARGS= -A
-USES= gmake
-USE_DOS2UNIX= *.cpp
+USES= dos2unix gmake
+DOS2UNIX_FILES= *.cpp
PLIST_FILES= bin/muscle
diff --git a/cad/meshdev/Makefile b/cad/meshdev/Makefile
index e898030efaf7..27d83e1c3fd1 100644
--- a/cad/meshdev/Makefile
+++ b/cad/meshdev/Makefile
@@ -8,9 +8,10 @@ MASTER_SITES= ${MASTER_SITE_LOCAL}/gahr/ \
http://people.freebsd.org/~gahr/distfiles/
MAINTAINER= gahr@FreeBSD.org
-COMMENT= A mesh comparison software
+COMMENT= Mesh comparison software
-USE_DOS2UNIX= src/MeshDev.h
+USES= dos2unix
+DOS2UNIX_FILES= src/MeshDev.h
BUILD_WRKSRC= ${WRKSRC}/build
INSTALL_WRKSRC= ${WRKSRC}/bin
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 1706990046e2..f898f17aacd4 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -32,8 +32,7 @@ GH_TAGNAME= ${GH_PROJECT}_${PORTVERSION}
GH_COMMIT= 568c424
CMAKE_SOURCE_PATH= ${WRKSRC}/src
-USES= cmake:outsource iconv
-USE_DOS2UNIX= yes
+USES= cmake:outsource dos2unix iconv
USE_XORG= ice sm x11 xau xcb xdamage xdmcp xext xfixes xft \
xinerama xrender xxf86vm
USE_GL= glu
diff --git a/chinese/phpbb-tw/Makefile b/chinese/phpbb-tw/Makefile
index 30c5ba3591c0..1181bb9b00b7 100644
--- a/chinese/phpbb-tw/Makefile
+++ b/chinese/phpbb-tw/Makefile
@@ -15,7 +15,7 @@ COMMENT= The Traditional Chinese version of phpBB
RUN_DEPENDS= ${LOCALBASE}/share/pear/System.php:${PORTSDIR}/devel/pear
CONFLICTS= phpbb-[0-9]*
-USE_DOS2UNIX= yes
+USES= dos2unix
# Get HOSTNAME
.if exists(/sbin/sysctl)
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index b3cf99b19067..93419a7c9d3a 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -10,8 +10,8 @@ MAINTAINER= madpilot@FreeBSD.org
COMMENT= Open source implementation of the OBEX protocol
USE_LDCONFIG= yes
-USES= pathfix cmake
-USE_DOS2UNIX= CMakeLists.txt
+USES= pathfix cmake dos2unix
+DOS2UNIX_FILES= CMakeLists.txt
CMAKE_ARGS+= -DPKGCONFIG_INSTALL_DIR:STRING="${PREFIX}/libdata/pkgconfig"
OPTIONS_DEFINE= DOXYGEN
diff --git a/comms/usrp/Makefile b/comms/usrp/Makefile
index 4179cedb57d1..aeb4a050ab79 100644
--- a/comms/usrp/Makefile
+++ b/comms/usrp/Makefile
@@ -18,8 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boos
orcc:${PORTSDIR}/devel/orc \
sdcc:${PORTSDIR}/lang/sdcc
-USE_DOS2UNIX= yes
-USES= cmake:outsource gmake pkgconfig
+USES= cmake:outsource dos2unix gmake pkgconfig
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
diff --git a/converters/p5-WAP-wbxml/Makefile b/converters/p5-WAP-wbxml/Makefile
index 62fb16d872e1..7de9945e3d57 100644
--- a/converters/p5-WAP-wbxml/Makefile
+++ b/converters/p5-WAP-wbxml/Makefile
@@ -15,8 +15,7 @@ BUILD_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM \
p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_DOS2UNIX= yes
-USES= perl5
+USES= dos2unix perl5
USE_PERL5= configure
post-patch:
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index efc20fec8d17..dba5abbfc5ff 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -13,8 +13,8 @@ COMMENT= Object-Relational Database Management System
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_DOS2UNIX= Makefile.in
-USE_GMAKE= yes
+USES= dos2unix gmake
+DOS2UNIX_FILES= Makefile.in
USE_AUTOTOOLS= libtool
CPPFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
diff --git a/deskutils/myitcrm/Makefile b/deskutils/myitcrm/Makefile
index 6b820ed6d997..b92f22a605bb 100644
--- a/deskutils/myitcrm/Makefile
+++ b/deskutils/myitcrm/Makefile
@@ -13,7 +13,7 @@ COMMENT= MyIT CRM is a CRM project designed for Computer Servicing and Repairs
LICENSE= GPLv3
-USES= zip
+USES= dos2unix zip
USE_PHP= mysql session xml
NO_BUILD= yes
WRKSRC= ${WRKDIR}/MyITCRM-${PORTVERSION}
@@ -24,7 +24,6 @@ PATCH_STRIP= -p1
WRITEABLE= conf.php.sample log/access.log cache
PORTEXAMPLES= htaccess.txt
PORTDOCS= changelog.txt README.textile
-USE_DOS2UNIX= yes
OPTIONS_DEFINE= APACHE PHPMOD LIGHTTPD NGINX DOCS EXAMPLES
OPTIONS_DEFAULT= APACHE
diff --git a/devel/asdlgen/Makefile b/devel/asdlgen/Makefile
index beca4e0b90ea..80fba58d02a0 100644
--- a/devel/asdlgen/Makefile
+++ b/devel/asdlgen/Makefile
@@ -13,7 +13,8 @@ COMMENT= Interoperable serializers for C,C++,Haskell,Icon,Java,ML
BUILD_DEPENDS= smlnj-devel>=110.65:${PORTSDIR}/lang/sml-nj-devel
-USE_DOS2UNIX= src/icon/libasdl.icn
+USES= dos2unix
+DOS2UNIX_FILES= src/icon/libasdl.icn
OPTIONS_DEFINE= CII EXAMPLES
CII_DESC= libcii for use by generated C and C++ code
diff --git a/devel/common_lib/Makefile b/devel/common_lib/Makefile
index e32e24c3bb4d..fa56d95f0691 100644
--- a/devel/common_lib/Makefile
+++ b/devel/common_lib/Makefile
@@ -19,9 +19,9 @@ GH_PROJECT= common_lib
GH_COMMIT= c242861
GH_TAGNAME= ${PORTVERSION}
-USE_DOS2UNIX= Makefile
+DOS2UNIX_FILES= Makefile
ALL_TARGET= compile doc
-USES= gmake iconv:build
+USES= dos2unix gmake iconv:build
post-extract:
@${REINPLACE_CMD} -e "s@&lt;@<@g" -e "s@&gt;@>@g" ${WRKSRC}/doc/*.ndoc
diff --git a/devel/esdl/Makefile b/devel/esdl/Makefile
index f234a1544c7f..5919bdcb117c 100644
--- a/devel/esdl/Makefile
+++ b/devel/esdl/Makefile
@@ -16,8 +16,8 @@ RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake
-USE_DOS2UNIX= Makefile
+USES= dos2unix gmake
+DOS2UNIX_FILES= Makefile
USE_GL= gl glu
USE_SDL= sdl
ALL_TARGET= target
diff --git a/devel/libdwarf/Makefile b/devel/libdwarf/Makefile
index be022bdf22cd..25607ed655ab 100644
--- a/devel/libdwarf/Makefile
+++ b/devel/libdwarf/Makefile
@@ -17,7 +17,8 @@ GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I. -I${LOCALBASE}/include
-USE_DOS2UNIX= *.h
+USES= dos2unix
+DOS2UNIX_GLOB= *.h
PS_FILES= dwarf.v2.pdf index.v2.pdf libdwarf2.1.pdf libdwarf2p.1.pdf mips_extensions.pdf
diff --git a/devel/oserl/Makefile b/devel/oserl/Makefile
index 1e9463660fcc..3f682fd75ac6 100644
--- a/devel/oserl/Makefile
+++ b/devel/oserl/Makefile
@@ -20,8 +20,8 @@ GH_PROJECT= oserl
GH_COMMIT= f14115d
GH_TAGNAME= ${PORTVERSION}
-USE_DOS2UNIX= Makefile
-USES= gmake iconv
+DOS2UNIX_FILES= Makefile
+USES= dos2unix gmake iconv
ALL_TARGET= compile doc
post-extract:
diff --git a/devel/pear-PHP_CompatInfo/Makefile b/devel/pear-PHP_CompatInfo/Makefile
index a475404673bd..ac5db893cd27 100644
--- a/devel/pear-PHP_CompatInfo/Makefile
+++ b/devel/pear-PHP_CompatInfo/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
PORTSCOUT= skipv:1.9.0a1,1.9.0b1,1.9.0b2
USE_PHP= tokenizer
-USE_DOS2UNIX= yes
+USES= dos2unix
PEAR_AUTOINSTALL= yes
LATEST_LINK= pear-PHP_CompatInfo
diff --git a/emulators/dynagen/Makefile b/emulators/dynagen/Makefile
index d7d67bfd7d21..dfa1c809ec19 100644
--- a/emulators/dynagen/Makefile
+++ b/emulators/dynagen/Makefile
@@ -41,10 +41,10 @@ PORTDOCS= *
PORTEXAMPLES= *
PORTDATA= *
+USES= dos2unix
USE_PYTHON= yes
USE_PYDISTUTILS= yes
ALL_TARGET= # empty
-USE_DOS2UNIX= yes
NO_STAGE= yes
post-install:
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index ea4a6f5ce676..5219140a912e 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -1,4 +1,5 @@
-USE_DOS2UNIX= *.c *.cpp *.h *.H *.ini *.conf
+USES+= dos2unix
+DOS2UNIX_GLOB= *.c *.cpp *.h *.H *.ini *.conf
DISTNAME= ${PORTNAME}-bundle-src-${PORTVERSION}
PATCHDIR= ${.CURDIR}/files
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
index 5bc5858b19ab..1389d8dbe4fb 100644
--- a/emulators/visualboyadvance-m/Makefile
+++ b/emulators/visualboyadvance-m/Makefile
@@ -22,14 +22,12 @@ GVBAM_DESC= Build gvbam (GTK2 frontend)
NLS_USES= gettext
-USE_BZIP2= yes
WANT_GNOME= yes
-USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(c|cpp|h)
USE_XORG= x11 xext
USE_GL= gl glu
USE_SDL= sdl
-USES= cmake desktop-file-utils pkgconfig
+USES= cmake desktop-file-utils dos2unix pkgconfig tar:bzip2
CMAKE_ARGS+= -DVERSION:STRING="${PORTVERSION}" -DSYSCONFDIR:STRING="${PREFIX}/etc"
SVN_REV= 1001