aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-13 00:45:51 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-13 00:45:51 +0800
commit5b65e3026dcd5ce55197de852cfffd776e6675e2 (patch)
treea8524115493d1e60ddbec99f1243e1946a54e374
parent7de714f46e8caeba53666f56f1dfc51a1c0103ce (diff)
downloadfreebsd-ports-gnome-5b65e3026dcd5ce55197de852cfffd776e6675e2.tar.gz
freebsd-ports-gnome-5b65e3026dcd5ce55197de852cfffd776e6675e2.tar.zst
freebsd-ports-gnome-5b65e3026dcd5ce55197de852cfffd776e6675e2.zip
- Add p5-Parse-HTTP-UserAgent 0.32
Parse::HTTP::UserAgent implements a rules-based parser and tries to identify MSIE, FireFox, Opera, Safari & Chrome first. It then tries to identify Mozilla, Netscape, Robots and the rest will be tried with a generic parser. There is also a structure dumper, useful for debugging. User agent strings are a complete mess since there is no standard format for them. They can be in various formats and can include more or less information depending on the vendor's (or the user's) choice. Also, it is not dependable since it is some arbitrary identification string. Any user agent can fake another. So, why deal with such a useless mess? You may want to see the choice of your visitors and can get some reliable data (even if some are fake) and generate some nice charts out of them or just want to send an HttpOnly cookie if the user agent seems to support it (and send a normal one if this is not the case). However, browser sniffing for client-side coding is considered a bad habit. WWW: http://search.cpan.org/dist/Parse-HTTP-UserAgent/ Feature safe: yes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Parse-HTTP-UserAgent/Makefile26
-rw-r--r--www/p5-Parse-HTTP-UserAgent/distinfo2
-rw-r--r--www/p5-Parse-HTTP-UserAgent/pkg-descr17
-rw-r--r--www/p5-Parse-HTTP-UserAgent/pkg-plist14
5 files changed, 60 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7c818c436dd3..a07bebf6ca79 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1117,6 +1117,7 @@
SUBDIR += p5-POEx-Role-PSGIServer
SUBDIR += p5-PSGI
SUBDIR += p5-ParallelUA
+ SUBDIR += p5-Parse-HTTP-UserAgent
SUBDIR += p5-Path-Class-URI
SUBDIR += p5-Perlanet
SUBDIR += p5-Perlbal-Plugin-PSGI
diff --git a/www/p5-Parse-HTTP-UserAgent/Makefile b/www/p5-Parse-HTTP-UserAgent/Makefile
new file mode 100644
index 000000000000..f594fee720f6
--- /dev/null
+++ b/www/p5-Parse-HTTP-UserAgent/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Parse-HTTP-UserAgent
+# Date created: 2011-11-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-HTTP-UserAgent
+PORTVERSION= 0.32
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parser for the User Agent string
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::HTTP::UserAgent.3 \
+ Parse::HTTP::UserAgent::Base::Accessors.3 \
+ Parse::HTTP::UserAgent::Base::Dumper.3 \
+ Parse::HTTP::UserAgent::Base::IS.3 \
+ Parse::HTTP::UserAgent::Base::Parsers.3 \
+ Parse::HTTP::UserAgent::Constants.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Parse-HTTP-UserAgent/distinfo b/www/p5-Parse-HTTP-UserAgent/distinfo
new file mode 100644
index 000000000000..b2595168cabb
--- /dev/null
+++ b/www/p5-Parse-HTTP-UserAgent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Parse-HTTP-UserAgent-0.32.tar.gz) = ed9261ac790037e2cb4fbcfb5dde9fa8c115ef59cf4709e08346d4dc56439a2f
+SIZE (Parse-HTTP-UserAgent-0.32.tar.gz) = 71384
diff --git a/www/p5-Parse-HTTP-UserAgent/pkg-descr b/www/p5-Parse-HTTP-UserAgent/pkg-descr
new file mode 100644
index 000000000000..d9cd06be4326
--- /dev/null
+++ b/www/p5-Parse-HTTP-UserAgent/pkg-descr
@@ -0,0 +1,17 @@
+Parse::HTTP::UserAgent implements a rules-based parser and tries to identify
+MSIE, FireFox, Opera, Safari & Chrome first. It then tries to identify Mozilla,
+Netscape, Robots and the rest will be tried with a generic parser. There is also
+a structure dumper, useful for debugging.
+
+User agent strings are a complete mess since there is no standard format for
+them. They can be in various formats and can include more or less information
+depending on the vendor's (or the user's) choice. Also, it is not dependable
+since it is some arbitrary identification string. Any user agent can fake
+another. So, why deal with such a useless mess? You may want to see the choice
+of your visitors and can get some reliable data (even if some are fake) and
+generate some nice charts out of them or just want to send an HttpOnly cookie if
+the user agent seems to support it (and send a normal one if this is not the
+case). However, browser sniffing for client-side coding is considered a bad
+habit.
+
+WWW: http://search.cpan.org/dist/Parse-HTTP-UserAgent/
diff --git a/www/p5-Parse-HTTP-UserAgent/pkg-plist b/www/p5-Parse-HTTP-UserAgent/pkg-plist
new file mode 100644
index 000000000000..695a03feee41
--- /dev/null
+++ b/www/p5-Parse-HTTP-UserAgent/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Parse/HTTP/UserAgent.pm
+%%SITE_PERL%%/Parse/HTTP/UserAgent/Base/Accessors.pm
+%%SITE_PERL%%/Parse/HTTP/UserAgent/Base/Dumper.pm
+%%SITE_PERL%%/Parse/HTTP/UserAgent/Base/IS.pm
+%%SITE_PERL%%/Parse/HTTP/UserAgent/Base/Parsers.pm
+%%SITE_PERL%%/Parse/HTTP/UserAgent/Constants.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/HTTP/UserAgent/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/HTTP/UserAgent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/HTTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse
+@dirrm %%SITE_PERL%%/Parse/HTTP/UserAgent/Base
+@dirrm %%SITE_PERL%%/Parse/HTTP/UserAgent
+@dirrmtry %%SITE_PERL%%/Parse/HTTP
+@dirrmtry %%SITE_PERL%%/Parse