aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-06-19 16:35:21 +0800
committergahr <gahr@FreeBSD.org>2012-06-19 16:35:21 +0800
commit607e6f170aa418867b131e67830050815e8463a3 (patch)
tree37da38218146aabf429ccf3a4222795bbc296ce3
parent5f6d454463fa7de1c2bf795605016dcb62fc772d (diff)
downloadfreebsd-ports-gnome-607e6f170aa418867b131e67830050815e8463a3.tar.gz
freebsd-ports-gnome-607e6f170aa418867b131e67830050815e8463a3.tar.zst
freebsd-ports-gnome-607e6f170aa418867b131e67830050815e8463a3.zip
- Update to 4.0.5589
Changes: see README at http://sf.net/projects/codelite/files/Releases/codelite-4.0
-rw-r--r--editors/codelite/Makefile9
-rw-r--r--editors/codelite/distinfo4
-rw-r--r--editors/codelite/files/patch-Runtime_codelite_xterm19
-rw-r--r--editors/codelite/files/patch-clang3122
-rw-r--r--editors/codelite/pkg-plist4
5 files changed, 42 insertions, 16 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index 29e0a3e32a1a..78a466ea6d7d 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: codelite
+# New ports collection Makefile for: codelite
# Date created: 7 May 2008
# Whom: gahr
#
@@ -6,8 +6,7 @@
#
PORTNAME= codelite
-DISTVERSION= 3.5.${SVN_REVISION}
-PORTREVISION= 1
+DISTVERSION= 4.0.${SVN_REVISION}
CATEGORIES= editors devel
MASTER_SITES= SF/${PORTNAME}/Releases/${PORTNAME}-${PORTVERSION:R}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-gtk.src
@@ -15,7 +14,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-gtk.src
MAINTAINER= gahr@FreeBSD.org
COMMENT= An Open Source IDE for C/C++
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS= xterm:${PORTSDIR}/x11/xterm
OPTIONS= CSCOPE "Enable CScope integration" OFF \
@@ -33,7 +32,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
-SVN_REVISION= 5375
+SVN_REVISION= 5589
.if defined(WITH_CSCOPE)
RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
index 886b724a5219..ce5d239e893b 100644
--- a/editors/codelite/distinfo
+++ b/editors/codelite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (codelite-3.5.5375-gtk.src.tar.gz) = e87b0872a535af2333549b6a8ccda2098bb04dc905c80d1a77eec00fe2f56692
-SIZE (codelite-3.5.5375-gtk.src.tar.gz) = 15857819
+SHA256 (codelite-4.0.5589-gtk.src.tar.gz) = 9b6dc38bdf441eaa77a4cdd6453821771c6773bfe277e8896065555d88f2afe5
+SIZE (codelite-4.0.5589-gtk.src.tar.gz) = 18374651
diff --git a/editors/codelite/files/patch-Runtime_codelite_xterm b/editors/codelite/files/patch-Runtime_codelite_xterm
index 74e693fb30dc..83e64c4638dd 100644
--- a/editors/codelite/files/patch-Runtime_codelite_xterm
+++ b/editors/codelite/files/patch-Runtime_codelite_xterm
@@ -1,16 +1,17 @@
---- Runtime/codelite_xterm.orig 2011-09-24 06:10:58.000000000 +0200
-+++ Runtime/codelite_xterm 2012-02-24 15:33:29.000000000 +0100
+--- Runtime/codelite_xterm.orig 2012-06-18 14:05:30.000000000 +0200
++++ Runtime/codelite_xterm 2012-06-18 14:05:45.000000000 +0200
@@ -1,4 +1,4 @@
-#!/bin/bash
-+#!/bin/sh
++#!/bin/sh
## A wrapper script around the xterm utility
## which allows codelite to export LD_LIBRARY_PATH into the exterm
-@@ -14,6 +14,6 @@
- ## Run xterm without the bash wrapper
- xterm -T "$program_title" -e $2 2> /dev/null
- else
-- xterm -T "$program_title" -e /bin/bash -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH "$@" 2> /dev/null
-+ xterm -T "$program_title" -e /bin/sh -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH "$@" 2> /dev/null
+@@ -17,7 +17,7 @@
+ ## Run xterm without the bash wrapper
+ xterm -T "$program_title" -e $2 2> /dev/null
+ else
+- xterm -T "$program_title" -e /bin/bash -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH "$@" 2> /dev/null
++ xterm -T "$program_title" -e /bin/sh -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH "$@" 2> /dev/null
+ fi
fi
diff --git a/editors/codelite/files/patch-clang31 b/editors/codelite/files/patch-clang31
new file mode 100644
index 000000000000..0cbe62567825
--- /dev/null
+++ b/editors/codelite/files/patch-clang31
@@ -0,0 +1,22 @@
+--- LiteEditor/clang_pch_maker_thread.cpp.orig 2012-06-18 14:58:00.000000000 +0200
++++ LiteEditor/clang_pch_maker_thread.cpp 2012-06-18 14:58:08.000000000 +0200
+@@ -385,7 +385,6 @@
+ | CXTranslationUnit_CXXChainedPCH;
+ } else {
+ flags = CXTranslationUnit_Incomplete
+- | CXTranslationUnit_SkipFunctionBodies
+ | CXTranslationUnit_DetailedPreprocessingRecord;
+ }
+
+--- codelite_clang/clang.cpp.orig 2012-06-18 14:44:20.000000000 +0200
++++ codelite_clang/clang.cpp 2012-06-18 14:44:27.000000000 +0200
+@@ -204,8 +204,7 @@
+ | CXTranslationUnit_PrecompiledPreamble
+ | CXTranslationUnit_Incomplete
+ | CXTranslationUnit_DetailedPreprocessingRecord
+- | CXTranslationUnit_CXXChainedPCH
+- | CXTranslationUnit_SkipFunctionBodies);
++ | CXTranslationUnit_CXXChainedPCH);
+ if(TU) {
+
+ //ClangUtils::printDiagnosticsToLog(TU);
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index c80f0ef37115..16480d116828 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -1,12 +1,15 @@
bin/codelite
+%%CLANG%%bin/codelite-clang
bin/codelite_cppcheck
bin/codelite_exec
bin/codelite_fix_files
bin/codelite_indexer
bin/codelite_kill_children
bin/codelite_xterm
+%%DATADIR%%/LICENSE
%%DATADIR%%/astyle.sample
%%DATADIR%%/codelite-icons.zip
+%%DATADIR%%/codelite-icons-fresh-farm.zip
%%DATADIR%%/config/accelerators.conf.default
%%DATADIR%%/config/build_settings.xml.default
%%DATADIR%%/config/codelite.xml.default
@@ -23,6 +26,7 @@ bin/codelite_xterm
%%DATADIR%%/index.html
%%DATADIR%%/lexers/lexers_black.xml
%%DATADIR%%/lexers/lexers_default.xml
+%%DATADIR%%/plugins/CallGraph.so
%%DATADIR%%/plugins/CodeFormatter.so
%%DATADIR%%/plugins/ContinuousBuild.so
%%DATADIR%%/plugins/Copyright.so