aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2004-01-29 10:53:41 +0800
committerpetef <petef@FreeBSD.org>2004-01-29 10:53:41 +0800
commit686901f2c8bcd350afd5321cc23d5046e99bc10b (patch)
tree8d00093c2e724c54d56e8a543ed36d604fa0ff80
parent354f8b2797819e0c6905fb2c0638c3a7d6e47385 (diff)
downloadfreebsd-ports-gnome-686901f2c8bcd350afd5321cc23d5046e99bc10b.tar.gz
freebsd-ports-gnome-686901f2c8bcd350afd5321cc23d5046e99bc10b.tar.zst
freebsd-ports-gnome-686901f2c8bcd350afd5321cc23d5046e99bc10b.zip
- make COMMENT better
- modify the wrapper script to build a sample application dot-dir on start if it doesn't already exist - add a pkg-message reflecting the above - bump PORTREVISION PR: 62001 Submitted by: maintainer
-rw-r--r--games/wolf3d/Makefile6
-rw-r--r--games/wolf3d/files/wolf3d.in30
-rw-r--r--games/wolf3d/pkg-message8
3 files changed, 42 insertions, 2 deletions
diff --git a/games/wolf3d/Makefile b/games/wolf3d/Makefile
index 55e738cca13e..51129c4b4548 100644
--- a/games/wolf3d/Makefile
+++ b/games/wolf3d/Makefile
@@ -7,13 +7,14 @@
PORTNAME= wolf3d
PORTVERSION= 20011028
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.icculus.org/wolf3d/:wolf \
http://www.liquidx.org/distfiles/:wolfdata
DISTFILES= wolf3d-20011028.tar.gz:wolf wolfdata.tar.gz:wolfdata
MAINTAINER= tlp@liquidx.org
-COMMENT= Wolfenstein 3D by Steven Fuller, based on 1992 id Software game
+COMMENT= "Wolfenstein 3D Linux" by Steven Fuller (1992)
USE_SDL= yes
USE_GZIP= yes
@@ -43,4 +44,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/TODO
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/games/wolf3d/files/wolf3d.in b/games/wolf3d/files/wolf3d.in
index a1992422fe11..31b27a852106 100644
--- a/games/wolf3d/files/wolf3d.in
+++ b/games/wolf3d/files/wolf3d.in
@@ -3,6 +3,33 @@
#
# 2004 Travis Poppe
+USERDIR=$HOME/.wolf3d
+
+if [ -x $USERDIR ]; then
+ echo "wolf3d appears to be installed to $USERDIR/"
+ echo ""
+ echo "Basic options:"
+ echo ""
+ echo "-nowait Skips introduction"
+ echo "-nojoy Disables joystick"
+ echo "-nomouse Disables mouse"
+ echo "-x2 Increases screen size by x2"
+ echo "-x3 Increases screen size by x3"
+ echo "-fullscreen Enables fullscreen mode"
+ echo "-demotest Starts wolf3d in demonstration mode"
+ echo "-version Reports game version"
+ echo ""
+
+ cd $USERDIR
+ ./sdlwolf3d $*
+ exit
+fi
+
+mkdir $USERDIR
+ln -s %%PREFIX%%/libexec/wolf3d/* $USERDIR
+
+echo "Installed wolf3d to $USERDIR/"
+echo ""
echo "Basic options:"
echo ""
echo "-nowait Skips introduction"
@@ -14,5 +41,6 @@ echo "-fullscreen Enables fullscreen mode"
echo "-demotest Starts wolf3d in demonstration mode"
echo "-version Reports game version"
echo ""
-cd %%PREFIX%%/libexec/wolf3d
+
+cd $USERDIR
./sdlwolf3d $*
diff --git a/games/wolf3d/pkg-message b/games/wolf3d/pkg-message
new file mode 100644
index 000000000000..207dcbd8fe1e
--- /dev/null
+++ b/games/wolf3d/pkg-message
@@ -0,0 +1,8 @@
+-------------------------------------------------------------------------------
+This port's wrapper script will install the wolf3d data to your home directory
+the first time you run it. If for some odd reason you already have a directory
+called .wolf3d in your home directory, you must (re)move it before this port
+will function correctly.
+
+-tlp
+-------------------------------------------------------------------------------