aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-12-02 02:33:26 +0800
committerdinoex <dinoex@FreeBSD.org>2013-12-02 02:33:26 +0800
commit68ac860312e1e617bff86b5bd90350cca877b417 (patch)
tree2d345ba82169235e815e6cc979f836e609fac7fb
parenta251027cd1031c4833185c422d00f8e9d4929299 (diff)
downloadfreebsd-ports-gnome-68ac860312e1e617bff86b5bd90350cca877b417.tar.gz
freebsd-ports-gnome-68ac860312e1e617bff86b5bd90350cca877b417.tar.zst
freebsd-ports-gnome-68ac860312e1e617bff86b5bd90350cca877b417.zip
- use STAGEDIR
- USES=gmake
-rw-r--r--news/c-nocem/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/news/c-nocem/Makefile b/news/c-nocem/Makefile
index 5cd230578162..129096840a8b 100644
--- a/news/c-nocem/Makefile
+++ b/news/c-nocem/Makefile
@@ -15,13 +15,12 @@ BUILD_DEPENDS= ${CNEWSWRK}/conf/substitutions:${PORTSDIR}/${CNEWS_PORT}:configur
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcnews.a:${PORTSDIR}/${CNEWS_PORT} \
gpgv:${PORTSDIR}/security/gnupg1
-NO_STAGE= yes
-
-USES= perl5
-USE_GMAKE= yes
+USES= perl5 gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-cnews=${CNEWSWRK}
+CONFIGURE_ENV+= PERL=${PERL}
WRKSRC= ${WRKDIR}/c-nocem
+
PLIST_SUB+= NEWSBIN=${NEWSBIN:S=${PREFIX}/==}
PLIST_FILES= %%NEWSBIN%%/fastcancel %%NEWSBIN%%/c-nocem
@@ -31,4 +30,11 @@ CNEWS_PORT?= news/cnews
CNEWSWRK?= ${WRKDIRPREFIX}${.CURDIR}/../../${CNEWS_PORT}/work
NEWSBIN?= ${PREFIX}/libexec/cnews
+post-patch:
+ ${REINPLACE_CMD} -e 's|@newsbin@|${STAGEDIR}@newsbin@|' \
+ ${WRKSRC}/Makefile.in
+
+pre-install:
+ ${MKDIR} ${STAGEDIR}${NEWSBIN}
+
.include <bsd.port.mk>
-10-291-0/+1 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-241-2/+2 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-121-1/+1