aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-19 22:50:11 +0800
committermiwi <miwi@FreeBSD.org>2009-03-19 22:50:11 +0800
commit68c8ba0c7a5836b7818537fc4d76dafa7acc5e2b (patch)
tree4e3f7b51c0fafcc92447861c68f73e1591b86bb0
parent57843221038b1b12e8547dc31453f23d5e6d5992 (diff)
downloadfreebsd-ports-gnome-68c8ba0c7a5836b7818537fc4d76dafa7acc5e2b.tar.gz
freebsd-ports-gnome-68c8ba0c7a5836b7818537fc4d76dafa7acc5e2b.tar.zst
freebsd-ports-gnome-68c8ba0c7a5836b7818537fc4d76dafa7acc5e2b.zip
GD::Graph::histogram extends the GD::Graph module to create histograms. The
module allow creation of count or percentage histograms. WWW: http://search.cpan.org/dist/GDGraph-histogram/ PR: ports/132362 Submitted by: Fernan Aguero <fernan at iib.unsam.edu.ar>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-GD-Graph-histogram/Makefile27
-rw-r--r--graphics/p5-GD-Graph-histogram/distinfo3
-rw-r--r--graphics/p5-GD-Graph-histogram/pkg-descr4
-rw-r--r--graphics/p5-GD-Graph-histogram/pkg-plist3
5 files changed, 38 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f9fc1f2b5a8a..e91b00e0c496 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -526,6 +526,7 @@
SUBDIR += p5-GD-Arrow
SUBDIR += p5-GD-Barcode
SUBDIR += p5-GD-Graph
+ SUBDIR += p5-GD-Graph-histogram
SUBDIR += p5-GD-Graph3d
SUBDIR += p5-GD-SVG
SUBDIR += p5-GD-TextUtil
diff --git a/graphics/p5-GD-Graph-histogram/Makefile b/graphics/p5-GD-Graph-histogram/Makefile
new file mode 100644
index 000000000000..d2771601b685
--- /dev/null
+++ b/graphics/p5-GD-Graph-histogram/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-GD-Graph-histogram
+# Date created: 6 March 2009
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GD-Graph-histogram
+PORTVERSION= 1.1
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/W/WH/WHIZDOG
+PKGNAMEPREFIX= p5-
+DISTNAME= GDGraph-histogram-${PORTVERSION}
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Histogram plotting module for perl5
+
+BUILD_DEPENDS= ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
+ ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= GD::Graph::histogram.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Graph-histogram/distinfo b/graphics/p5-GD-Graph-histogram/distinfo
new file mode 100644
index 000000000000..0d9fffbc8b47
--- /dev/null
+++ b/graphics/p5-GD-Graph-histogram/distinfo
@@ -0,0 +1,3 @@
+MD5 (GDGraph-histogram-1.1.tar.gz) = 633c97212412d0d85bb3dc7251f5bad9
+SHA256 (GDGraph-histogram-1.1.tar.gz) = 20f752d0e6deb59b29aa2ec3496b5883476d00280b6e83f5b47c33fac4097f8a
+SIZE (GDGraph-histogram-1.1.tar.gz) = 19981
diff --git a/graphics/p5-GD-Graph-histogram/pkg-descr b/graphics/p5-GD-Graph-histogram/pkg-descr
new file mode 100644
index 000000000000..37f60f73e6bc
--- /dev/null
+++ b/graphics/p5-GD-Graph-histogram/pkg-descr
@@ -0,0 +1,4 @@
+GD::Graph::histogram extends the GD::Graph module to create histograms. The
+module allow creation of count or percentage histograms.
+
+WWW: http://search.cpan.org/dist/GDGraph-histogram/
diff --git a/graphics/p5-GD-Graph-histogram/pkg-plist b/graphics/p5-GD-Graph-histogram/pkg-plist
new file mode 100644
index 000000000000..937b2cbfee64
--- /dev/null
+++ b/graphics/p5-GD-Graph-histogram/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/GD/Graph/histogram.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/Graph/histogram/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/Graph/histogram