aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-11-11 02:59:47 +0800
committermarino <marino@FreeBSD.org>2013-11-11 02:59:47 +0800
commit69d3dba742131f75eb93cd273cf94b1d4e883b1c (patch)
tree59164e7fa0c23dc4002f82722c97eabe35aa5fe0
parent97c68090c38acd680c9379b0a497dfa27c19489f (diff)
downloadfreebsd-ports-gnome-69d3dba742131f75eb93cd273cf94b1d4e883b1c.tar.gz
freebsd-ports-gnome-69d3dba742131f75eb93cd273cf94b1d4e883b1c.tar.zst
freebsd-ports-gnome-69d3dba742131f75eb93cd273cf94b1d4e883b1c.zip
x11-toolkits/gtkada: Convert to staging
* Don't install license anymore as it messes up auto-plist * Bump portrevision because of this plist change
-rw-r--r--x11-toolkits/gtkada/Makefile43
1 files changed, 21 insertions, 22 deletions
diff --git a/x11-toolkits/gtkada/Makefile b/x11-toolkits/gtkada/Makefile
index 14dbfefdcd05..5eb8ac6c0821 100644
--- a/x11-toolkits/gtkada/Makefile
+++ b/x11-toolkits/gtkada/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gtkada
PORTVERSION= 2.24.4.0
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -17,15 +18,15 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_PERL5= build
USE_GNOME= gtk20
+NO_MTREE= yes
USES= ada gmake perl5 pkgconfig
-DESTINY= ${WRKDIR}/destino
-MAKE_ENV+= DESTDIR=${DESTINY} \
- PROCESSORS=${MAKE_JOBS_NUMBER}
+MAKE_ENV+= PROCESSORS=${MAKE_JOBS_NUMBER}
+
+NO_LICENSES_INSTALL= yes
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -46,27 +47,25 @@ post-patch:
.endif
do-build:
- # This target is recreated because -j cannot be set, but
- # MAKE_JOBS_SAFE=yes is needed for PROCESSORS value
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gmake all
+# This target is recreated because -j cannot be set, but
+# MAKE_JOBS_SAFE=yes is needed for PROCESSORS value
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} all
post-install:
- @${MKDIR} ${DESTINY}${PREFIX}/libdata
- @${MV} ${DESTINY}${PREFIX}/lib/pkgconfig ${DESTINY}${PREFIX}/libdata/
- ${RM} -rf ${DESTINY}${PREFIX}/share/doc/gtkada/gtkada_ug/_sources
- ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
- @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} > ${WRKDIR}/PLIST.all
- @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libdata
+ @${MV} ${STAGEDIR}${PREFIX}/lib/pkgconfig ${STAGEDIR}${PREFIX}/libdata/
+ ${RM} -rf ${STAGEDIR}${PREFIX}/share/doc/gtkada/gtkada_ug/_sources
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | ${SORT} -r | \
${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' -e '/share\/gps/d' \
-e '/share\/examples$$/d' -e '/libdata\/pkgconfig/d' \
- -e 's/^/@dirrm /g' >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/examples 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+ -e 's/^/@dirrm /g' >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/examples 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${TMPPLIST}
.include <bsd.port.mk>