aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-04-26 20:29:31 +0800
committerjbeich <jbeich@FreeBSD.org>2016-04-26 20:29:31 +0800
commit6d032b99dcd339446d993ac6e076d993f8706e49 (patch)
tree415489c98eeb4a9965bed8388a8041c1e9f4b333
parente8f7353c87db97fbf931ee38f08a6382da9da9af (diff)
downloadfreebsd-ports-gnome-6d032b99dcd339446d993ac6e076d993f8706e49.tar.gz
freebsd-ports-gnome-6d032b99dcd339446d993ac6e076d993f8706e49.tar.zst
freebsd-ports-gnome-6d032b99dcd339446d993ac6e076d993f8706e49.zip
graphics/mypaint: fix minor issues
- Move to new home [1] - Define LICENSE [2] - Strip python C module [3] - Add USES=desktop-file-utils [3] - Apply style (echo, makepatch) [2] Noticed by: portscout [1], portlint [2], stage-qa [3]
-rw-r--r--graphics/mypaint/Makefile26
-rw-r--r--graphics/mypaint/distinfo4
-rw-r--r--graphics/mypaint/files/patch-SConstruct8
-rw-r--r--graphics/mypaint/files/patch-brushlib-SConscript10
-rw-r--r--graphics/mypaint/files/patch-brushlib-tests-SConscript6
-rw-r--r--graphics/mypaint/files/patch-mypaint.py6
-rw-r--r--graphics/mypaint/pkg-descr2
7 files changed, 35 insertions, 27 deletions
diff --git a/graphics/mypaint/Makefile b/graphics/mypaint/Makefile
index f8ea0fd4d9d6..9158098fcdde 100644
--- a/graphics/mypaint/Makefile
+++ b/graphics/mypaint/Makefile
@@ -2,15 +2,20 @@
# $FreeBSD$
PORTNAME= mypaint
-PORTVERSION= 1.1.0
-PORTREVISION= 5
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+PORTREVISION= 6
CATEGORIES= graphics
-MASTER_SITES= http://download.gna.org/mypaint/ \
- http://mirror.amdmi3.ru/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast painting/scribbling program
+LICENSE= GPLv2+ ISCL MIT
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING
+LICENSE_FILE_ISCL= ${WRKSRC}/brushlib/COPYING
+LICENSE_FILE_MIT= ${WRKSRC}/COPYING.cursors
+
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo \
${PYTHON_PKGNAMEPREFIX}protobuf>0:devel/py-protobuf
@@ -20,28 +25,31 @@ BUILD_DEPENDS:= ${RUN_DEPENDS} \
swig:devel/swig13 \
protoc:devel/protobuf
+USE_GITHUB= yes
USE_GNOME= glib20 pygtk2
MAKE_ARGS= prefix="${PREFIX}"
# XXX gcc-c++11-lib to fix runtime issues with old -lgcc_s and Clang
-USES= compiler:gcc-c++11-lib gettext pkgconfig scons tar:bzip2 python
+USES= compiler:gcc-c++11-lib desktop-file-utils gettext \
+ pkgconfig python scons tar:bzip2
INSTALLS_ICONS= yes
SUB_FILES= pkg-install
post-patch:
- ${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/brushlib/operationqueue.c \
${WRKSRC}/brushlib/fifo.c
@${REINPLACE_CMD} 's|-O3||g; s|-g||g' \
${WRKSRC}/SConstruct
pre-install:
- @${RM} -rf ${WRKSRC}/sandbox 2>/dev/null || true
- @cd ${WRKSRC}; ${MAKE_CMD} ${MAKE_ARGS} --install-sandbox=pre-stage
+ @${RM} -rf ${WRKSRC}/sandbox 2>/dev/null || ${TRUE}
+ @(cd ${WRKSRC} && ${DO_MAKE_BUILD} --install-sandbox=pre-stage)
do-install:
.for d in . po brushlib brushlib/po
- @cd ${WRKSRC}/${d}/pre-stage; ${PAX} -rw . ${STAGEDIR}
+ (cd ${WRKSRC}/${d}/pre-stage && ${PAX} -rw . ${STAGEDIR})
.endfor
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mypaint/_mypaintlib.so
.include <bsd.port.mk>
diff --git a/graphics/mypaint/distinfo b/graphics/mypaint/distinfo
index d199d6457860..7a99e4b3b583 100644
--- a/graphics/mypaint/distinfo
+++ b/graphics/mypaint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mypaint-1.1.0.tar.bz2) = 780d57e50dd90afd586873bc5120261930ea4c309d4d0958020916932122e838
-SIZE (mypaint-1.1.0.tar.bz2) = 37416388
+SHA256 (mypaint-mypaint-v1.1.0_GH0.tar.gz) = 59d8323c60423c9a15e02ff93e406d25a7919df3af826089f0cf7f1124c9dbd1
+SIZE (mypaint-mypaint-v1.1.0_GH0.tar.gz) = 37871920
diff --git a/graphics/mypaint/files/patch-SConstruct b/graphics/mypaint/files/patch-SConstruct
index 134c7b9fc834..b0d3ec760916 100644
--- a/graphics/mypaint/files/patch-SConstruct
+++ b/graphics/mypaint/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2012-12-31 19:03:38.000000000 +0200
-+++ SConstruct 2013-01-11 20:45:33.000000000 +0200
-@@ -39,7 +39,7 @@
+--- SConstruct.orig 2012-12-31 16:35:54 UTC
++++ SConstruct
+@@ -39,7 +39,7 @@ opts.Add('python_config', 'python-config
tools = ['default', 'textfile']
@@ -9,7 +9,7 @@
print('building for %r (use scons python_binary=xxx to change)' % env['python_binary'])
print('using %r (use scons python_config=xxx to change)' % env['python_config'])
if sys.platform == "win32":
-@@ -47,9 +47,9 @@
+@@ -47,9 +47,9 @@ if sys.platform == "win32":
env = Environment(tools=tools + ['mingw'], ENV=os.environ, options=opts)
opts.Update(env)
diff --git a/graphics/mypaint/files/patch-brushlib-SConscript b/graphics/mypaint/files/patch-brushlib-SConscript
index 65682237127e..3821a465eb51 100644
--- a/graphics/mypaint/files/patch-brushlib-SConscript
+++ b/graphics/mypaint/files/patch-brushlib-SConscript
@@ -1,6 +1,6 @@
---- brushlib/SConscript.orig 2012-12-31 12:03:38.000000000 -0500
-+++ brushlib/SConscript 2014-08-20 11:36:09.000000000 -0400
-@@ -47,7 +47,7 @@
+--- brushlib/SConscript.orig 2012-12-31 16:35:54 UTC
++++ brushlib/SConscript
+@@ -47,7 +47,7 @@ def create_pkgconfig_files(env, pkgconfi
}
pc_file = env.Substfile('%s.pc' % pkgconfig_name,
"pkgconfig.pc.in", SUBST_DICT=pkg_info)
@@ -9,7 +9,7 @@
return pc_file
-@@ -56,6 +56,7 @@
+@@ -56,6 +56,7 @@ def create_pkgconfig_files(env, pkgconfi
# and also add our own specifics ones without affecting the other builds
top_env = env
env = env.Clone()
@@ -17,7 +17,7 @@
if env['enable_introspection']:
env['use_glib'] = True
-@@ -73,7 +74,7 @@
+@@ -73,7 +74,7 @@ if env['enable_docs']:
env.Append(CPPPATH='./')
diff --git a/graphics/mypaint/files/patch-brushlib-tests-SConscript b/graphics/mypaint/files/patch-brushlib-tests-SConscript
index fd8c7f437d00..e70c91f727ee 100644
--- a/graphics/mypaint/files/patch-brushlib-tests-SConscript
+++ b/graphics/mypaint/files/patch-brushlib-tests-SConscript
@@ -1,6 +1,6 @@
---- brushlib/tests/SConscript.orig 2012-12-31 19:03:38.000000000 +0200
-+++ brushlib/tests/SConscript 2013-03-29 20:06:21.000000000 +0200
-@@ -13,8 +13,9 @@
+--- brushlib/tests/SConscript.orig 2012-12-31 16:35:54 UTC
++++ brushlib/tests/SConscript
+@@ -13,8 +13,9 @@ def is_test(fn):
tests_sources = [fn for fn in os.listdir("./") if is_test(fn) and is_csource(fn)]
testlib_sources = [fn for fn in os.listdir("./") if not is_test(fn) and is_csource(fn)]
diff --git a/graphics/mypaint/files/patch-mypaint.py b/graphics/mypaint/files/patch-mypaint.py
index d21d7253c7d6..d5784a7748ce 100644
--- a/graphics/mypaint/files/patch-mypaint.py
+++ b/graphics/mypaint/files/patch-mypaint.py
@@ -1,6 +1,6 @@
---- mypaint.py.orig 2013-04-16 20:22:02.000000000 +0200
-+++ mypaint.py 2013-04-16 20:22:19.000000000 +0200
-@@ -172,11 +172,6 @@
+--- mypaint.py.orig 2012-12-31 16:35:54 UTC
++++ mypaint.py
+@@ -172,11 +172,6 @@ if __name__ == '__main__':
print "DEBUG: localepath: ", localepath
print "DEBUG: localepath_brushlib: ", localepath_brushlib
diff --git a/graphics/mypaint/pkg-descr b/graphics/mypaint/pkg-descr
index af27c91ab071..87ae511069fe 100644
--- a/graphics/mypaint/pkg-descr
+++ b/graphics/mypaint/pkg-descr
@@ -8,4 +8,4 @@ ink to emulate real media, but the highly configurable brush engine
allows you to experiment with your own brushes and with not-quite-natural
painting.
-WWW: http://mypaint.intilinux.com/
+WWW: http://mypaint.org/