aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2005-02-28 12:23:44 +0800
committerdaichi <daichi@FreeBSD.org>2005-02-28 12:23:44 +0800
commit6ef47208cfd5fb7d48575333569191cbdeef3d69 (patch)
tree2299cd879d07f52be7c62329604d1c285a9e470f
parentba2996d91ac44f2a3b7e17b7dc707b0fbdfa23b7 (diff)
downloadfreebsd-ports-gnome-6ef47208cfd5fb7d48575333569191cbdeef3d69.tar.gz
freebsd-ports-gnome-6ef47208cfd5fb7d48575333569191cbdeef3d69.tar.zst
freebsd-ports-gnome-6ef47208cfd5fb7d48575333569191cbdeef3d69.zip
Add iiimf-le-freewnn , freeWnn language engine for IIIMF.
PR: ports/77927 Submitted by: Masanori OZAWA <ozawa@ongs.co.jp>
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/iiimf-le-freewnn/Makefile67
-rw-r--r--japanese/iiimf-le-freewnn/distinfo2
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-Makefile19
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh93
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_configure.ac32
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am13
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c32
-rw-r--r--japanese/iiimf-le-freewnn/pkg-descr6
-rw-r--r--japanese/iiimf-le-freewnn/pkg-plist2
10 files changed, 267 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index dae4f312e4ae..f22ee172bd55 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -105,6 +105,7 @@
SUBDIR += hns
SUBDIR += ical
SUBDIR += iiimf-le-canna
+ SUBDIR += iiimf-le-freewnn
SUBDIR += im-ja
SUBDIR += ipa-ttfonts
SUBDIR += ipadic
diff --git a/japanese/iiimf-le-freewnn/Makefile b/japanese/iiimf-le-freewnn/Makefile
new file mode 100644
index 000000000000..baf5de97a770
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: iiimf-le-freewnn
+# Date created: 18 Feb 2005
+# Whom: Masanori OZAWA <ozawa@ongs.co.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= le-freewnn
+PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
+CATEGORIES= japanese textproc
+MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
+PKGNAMEPREFIX= iiimf-
+DISTNAME= im-sdk-src-${IIIMF_VER}
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= daichi@freebsd.org
+COMMENT= FreeWnn language engine for IIIMF
+
+LIB_DEPENDS= wnn.0:${PORTSDIR}/japanese/FreeWnn-lib
+RUN_DEPENDS= ${LOCALBASE}/lib/im/htt:${PORTSDIR}/textproc/iiimf-server
+
+IIIMF_VER= r12_1-svn2002
+USE_ICONV= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOME= intltool
+WANT_AUTOCONF_VER=253
+WANT_AUTOHEADER_VER=253
+WANT_AUTOMAKE_VER=15
+WANT_LIBTOOL_VER=15
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}/leif
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 503000
+IGNORE= "It is supported on FreeBSD 5.3 and later"
+.endif
+
+.if ${ARCH} != "i386"
+IGNORE= "${ARCH} is not support."
+.endif
+
+MAKE_ARGS+= LIBTOOL="${LIBTOOL} --tag=CXX"
+UPDATE_ARGS+= ACLOCAL=${ACLOCAL} AUTOMAKE=${AUTOMAKE} \
+ AUTOHEADER=${AUTOHEADER} AUTOCONF=${AUTOCONF} \
+ LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE}
+AUTOGEN_ARGS+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+ --prefix=${PREFIX} --without-x
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ ${WRKSRC}/../acfiles/im_common.m4 \
+ ${WRKSRC}/../lib/CSConv/csconv.h
+
+pre-configure:
+ (cd ${WRKSRC}/../ && ${GMAKE} ${UPDATE_ARGS} update-acfiles)
+ (cd ${WRKSRC}/../acfiles/ && ${TOUCH} ltconfig)
+ (cd ${WRKSRC}/ && ${TOUCH} ltconfig)
+
+do-configure:
+ (cd ${WRKSRC}/ && ./autogen.sh ${AUTOGEN_ARGS})
+
+.include <bsd.port.post.mk>
diff --git a/japanese/iiimf-le-freewnn/distinfo b/japanese/iiimf-le-freewnn/distinfo
new file mode 100644
index 000000000000..440e49d16220
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/distinfo
@@ -0,0 +1,2 @@
+MD5 (im-sdk-src-r12_1-svn2002.tar.bz2) = 51f3f10b11f8d4a206e2b190ec36a32a
+SIZE (im-sdk-src-r12_1-svn2002.tar.bz2) = 18141292
diff --git a/japanese/iiimf-le-freewnn/files/patch-Makefile b/japanese/iiimf-le-freewnn/files/patch-Makefile
new file mode 100644
index 000000000000..85df0e345035
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile Thu Apr 8 03:28:00 2004
++++ Makefile Wed Feb 16 14:09:34 2005
+@@ -2,6 +2,7 @@
+ AUTOMAKE = automake
+ AUTOHEADER = autoheader
+ AUTOCONF = autoconf
++LIBTOOLIZE = libtoolize
+
+ CONFIG_CMD = $(ACLOCAL) -I $${acfilesdir} && \
+ $(AUTOHEADER) && \
+@@ -21,7 +22,7 @@
+
+ update-acfiles:
+ cd acfiles && \
+- $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && libtoolize --force --copy && \
++ $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && $(LIBTOOLIZE) --force --copy && \
+ rm -f Makefile.in aclocal.m4
+
+ config:
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh b/japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh
new file mode 100644
index 000000000000..d38d31e628c7
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh
@@ -0,0 +1,93 @@
+--- leif/autogen.sh Thu Dec 11 15:29:55 2003
++++ leif/autogen.sh Wed Feb 16 16:53:53 2005
+@@ -6,6 +6,14 @@
+
+ DIE=0
+
++LIBTOOL=libtool15
++INTLTOOLIZE=intltoolize
++LIBTOOLIZE=libtoolize15
++ACLOCAL=aclocal15
++AUTOHEADER=autoheader253
++AUTOMAKE=automake15
++AUTOCONF=autoconf253
++
+ ACLOCAL_FLAGS="-I ../acfiles $ACLOCAL_FLAGS"
+
+ if [ -n "$GNOME2_DIR" ]; then
+@@ -22,7 +30,7 @@
+ exit 1
+ }
+
+-(autoconf --version) < /dev/null > /dev/null 2>&1 || {
++(${AUTOCONF} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`autoconf' installed."
+ echo "Download the appropriate package for your distribution,"
+@@ -31,7 +39,7 @@
+ }
+
+ (grep "^AC_PROG_INTLTOOL" $srcdir/configure.ac >/dev/null) && {
+- (intltoolize --version) < /dev/null > /dev/null 2>&1 || {
++ (${INTLTOOLIZE} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`intltool' installed."
+ echo "You can get it from:"
+@@ -41,7 +49,7 @@
+ }
+
+ (grep "^AM_PROG_LIBTOOL" $srcdir/configure.ac >/dev/null) && {
+- (libtool --version) < /dev/null > /dev/null 2>&1 || {
++ (${LIBTOOL} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`libtool' installed."
+ echo "You can get it from: ftp://ftp.gnu.org/pub/gnu/"
+@@ -59,7 +67,7 @@
+ }
+ }
+
+-(automake --version) < /dev/null > /dev/null 2>&1 || {
++(${AUTOMAKE} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`automake' installed."
+ echo "You can get it from: ftp://ftp.gnu.org/pub/gnu/"
+@@ -69,7 +77,7 @@
+
+
+ # if no automake, don't bother testing for aclocal
+-test -n "$NO_AUTOMAKE" || (aclocal --version) < /dev/null > /dev/null 2>&1 || {
++test -n "$NO_AUTOMAKE" || (${ACLOCAL} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: Missing \`aclocal'. The version of \`automake'"
+ echo "installed doesn't appear recent enough."
+@@ -114,24 +122,24 @@
+ fi
+ if grep "^AC_PROG_INTLTOOL" configure.ac >/dev/null; then
+ echo "Running intltoolize..."
+- intltoolize --copy --force --automake
++ ${INTLTOOLIZE} --copy --force --automake
+ fi
+ if grep "^AM_PROG_LIBTOOL" configure.ac >/dev/null; then
+ if test -z "$NO_LIBTOOLIZE" ; then
+ echo "Running libtoolize..."
+- libtoolize --force --copy
++ ${LIBTOOLIZE} --force --copy
+ fi
+ fi
+ echo "Running aclocal $aclocalinclude ..."
+- aclocal $aclocalinclude
++ ${ACLOCAL} $aclocalinclude
+ if grep "^AM_CONFIG_HEADER" configure.ac >/dev/null; then
+ echo "Running autoheader..."
+- autoheader
++ ${AUTOHEADER}
+ fi
+ echo "Running automake --gnu $am_opt ..."
+- automake --add-missing --copy --gnu $am_opt
++ ${AUTOMAKE} --add-missing --copy --gnu $am_opt
+ echo "Running autoconf ..."
+- autoconf
++ ${AUTOCONF}
+ )
+ fi
+ done
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_configure.ac b/japanese/iiimf-le-freewnn/files/patch-leif_configure.ac
new file mode 100644
index 000000000000..b99e2e345198
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/files/patch-leif_configure.ac
@@ -0,0 +1,32 @@
+--- leif/configure.ac Wed Oct 6 23:00:36 2004
++++ leif/configure.ac Fri Feb 18 01:19:12 2005
+@@ -61,25 +61,18 @@
+ IM_CONSTRUCT_FLAGS
+ IM_CONSTRUCT_THREAD_FLAGS
+
+ CFLAGS="${COMMON_CXX_CFLAGS} ${COMMON_CFLAGS} \
+ ${DEBUG_CXX_CFLAGS} ${DEBUG_CFLAGS} \
+- ${THREAD_COMMON_CXX_CFLAGS}"
++ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/local/include -I/usr/X11R6/include"
+
+ CXXFLAGS="${COMMON_CXX_CFLAGS} ${COMMON_CXXFLAGS} \
+ ${DEBUG_CXX_CFLAGS} ${DEBUG_CXXFLAGS} \
+- ${THREAD_COMMON_CXX_CFLAGS}"
++ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/local/include"
+
+-LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS}"
++LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS} -L/usr/local/lib"
+
+-LE_TARGETS="default template sampleja sampleja2 sampleja3 newpy testEIMIL unit hangul chewing"
++LE_TARGETS="freewnn"
+
+-IM_ADD_TARGET(LE_TARGETS, HAVE_CANNA, canna)
+-IM_ADD_TARGET(LE_TARGETS, HAVE_FREEWNN, freewnn)
+-IM_ADD_TARGET(LE_TARGETS, HAVE_X, sampleja3/xaux_common)
+-IM_ADD_TARGET(LE_TARGETS, HAVE_GTK, sampleja3/xaux_gtk)
+-IM_ADD_TARGET(LE_TARGETS, HAVE_MOTIF, newpy/xaux)
+-IM_ADD_TARGET(LE_TARGETS, HAVE_MOTIF, sampleja/xaux)
+-IM_ADD_TARGET(LE_TARGETS, HAVE_MOTIF, sampleja3/xaux_motif)
+
+ dnl --------------------------------------------------------------------------------
+ dnl Section 6: compilation test
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am
new file mode 100644
index 000000000000..8f6397344fe4
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am
@@ -0,0 +1,13 @@
+--- leif/freewnn/Makefile.am.orig Sun Feb 20 14:47:50 2005
++++ leif/freewnn/Makefile.am Sun Feb 20 14:48:49 2005
+@@ -3,8 +3,8 @@
+ -DNO_COLOR_FEEDBACK -DNO_CARET_NEGO \
+ -I$(IM_INCLUDEDIR)/iml \
+ -I$(CSCONV_DIR) \
+- -I/usr/include/wnn
+-FreeWnnLE_la_LDFLAGS = -module -rpath $(IM_LEIFDIR) $(SHLIBLDFLAGS) $(THREAD_LDFLAGS)
++ -I/usr/local/include/wnn
++FreeWnnLE_la_LDFLAGS = -module -rpath $(IM_LEIFDIR) $(SHLIBLDFLAGS) $(THREAD_LDFLAGS) -L/usr/local/lib
+ FreeWnnLE_la_LIBADD = -lwnn $(THREAD_LIBS)
+ FreeWnnLE_la_SOURCES = freewnn.c
+ noinst_LTLIBRARIES = FreeWnnLE.la
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c
new file mode 100644
index 000000000000..84532ed858d6
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c
@@ -0,0 +1,32 @@
+--- leif/freewnn/freewnn.c.orig Mon Oct 4 19:13:52 2004
++++ leif/freewnn/freewnn.c Sun Feb 20 15:43:20 2005
+@@ -59,9 +59,9 @@
+ #define BUFSIZE 1024
+ #endif
+
+-#define WNNRCFILE "/etc/FreeWnn/ja/wnnenvrc"
++#define WNNRCFILE "/usr/local/lib/wnn/ja_JP/wnnenvrc"
+
+-#define CSC_PATH "/usr/lib/im/csconv/csconv.so"
++#define CSC_PATH "/usr/local/lib/im/csconv/csconv.so"
+ #define CSC_OPEN_LOCALE "csconv_open_locale"
+ #define CSC_OPEN "csconv_open"
+ #define CSC_CONV "csconv"
+@@ -163,7 +163,7 @@
+ int count = 0;
+
+ if( str == NULL ) return NULL;
+- if( *str == '\0' ) return NULL;
++ if( *str == '\0' ) return "";
+
+ for(i=0;i<strlen(str);i++) {
+ count++;
+@@ -202,7 +202,7 @@
+
+ if( wstr == NULL ) return NULL;
+
+- if( *wstr == 0 ) return NULL;
++ if( *wstr == 0 ) return "";
+
+ for(i=0;wstr[i] != 0;i++)
+ count++;
diff --git a/japanese/iiimf-le-freewnn/pkg-descr b/japanese/iiimf-le-freewnn/pkg-descr
new file mode 100644
index 000000000000..358e264185b3
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/pkg-descr
@@ -0,0 +1,6 @@
+IIIMF stands for Internet/Intranet Input Method Framework.
+IIIMF is designed to be the next generation of input method framework.
+
+FreeWnnLE - Interface module to the FreeWnn language engine for IIIMF.
+
+WWW: http://www.openi18n.org/subgroups/im/IIIMF/
diff --git a/japanese/iiimf-le-freewnn/pkg-plist b/japanese/iiimf-le-freewnn/pkg-plist
new file mode 100644
index 000000000000..9a469125e284
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/pkg-plist
@@ -0,0 +1,2 @@
+lib/im/leif/FreeWnnLE.so
+@unexec rmdir %D/lib/im/leif > /dev/null 2>&1 || true