aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-09-25 18:39:15 +0800
committermiwi <miwi@FreeBSD.org>2006-09-25 18:39:15 +0800
commit713f40209acca5c036f220ad03f6ef404ad3b834 (patch)
tree069c28838c9df448b7fa9bf0fcf818bd83427a1d
parent4f4b21abdc0c2139b996e2dbc36d932150c4e229 (diff)
downloadfreebsd-ports-gnome-713f40209acca5c036f220ad03f6ef404ad3b834.tar.gz
freebsd-ports-gnome-713f40209acca5c036f220ad03f6ef404ad3b834.tar.zst
freebsd-ports-gnome-713f40209acca5c036f220ad03f6ef404ad3b834.zip
- Fix premissions with pre-existing user's
- Bump PORTREVISION PR: ports/103450 Submitted by: Lupe Christoph <lupe@lupe-christoph.de> (maintainer)
-rw-r--r--sysutils/munin-main/Makefile1
-rw-r--r--sysutils/munin-main/files/patch-Makefile.config4
-rw-r--r--sysutils/munin-main/pkg-install2
-rw-r--r--sysutils/munin-master/Makefile1
-rw-r--r--sysutils/munin-master/files/patch-Makefile.config4
-rw-r--r--sysutils/munin-master/pkg-install2
6 files changed, 8 insertions, 6 deletions
diff --git a/sysutils/munin-main/Makefile b/sysutils/munin-main/Makefile
index dec78d4ace62..3bf4275f78dd 100644
--- a/sysutils/munin-main/Makefile
+++ b/sysutils/munin-main/Makefile
@@ -7,6 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= munin
diff --git a/sysutils/munin-main/files/patch-Makefile.config b/sysutils/munin-main/files/patch-Makefile.config
index 52f43ea968a4..c7097d2ab7e4 100644
--- a/sysutils/munin-main/files/patch-Makefile.config
+++ b/sysutils/munin-main/files/patch-Makefile.config
@@ -78,8 +78,8 @@
-GETENT = $(shell which getent || which true 2>/dev/null)
-CHECKUSER = $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-CHECKGROUP = $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
-+CHECKUSER:= $(shell grep $(USER) /etc/passwd >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-+CHECKGROUP:= $(shell grep $(GROUP) /etc/group >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
++CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
++CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
CHOWN = chown
CHMOD = chmod
diff --git a/sysutils/munin-main/pkg-install b/sysutils/munin-main/pkg-install
index 1208f695a04e..3ce03edb2f51 100644
--- a/sysutils/munin-main/pkg-install
+++ b/sysutils/munin-main/pkg-install
@@ -45,7 +45,7 @@ make_account() {
echo "Done."
else
echo "Please create it, and try again."
- if ! grep -q "^${u}:" /etc/passwd; then
+ if ! /usr/sbin/pw user show ${u} >/dev/null 2>/dev/null; then
echo "While you're at it, please create a user \"${u}\" too,"
echo "with a default group of \"${g}\"."
fi
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index dec78d4ace62..3bf4275f78dd 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -7,6 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= munin
diff --git a/sysutils/munin-master/files/patch-Makefile.config b/sysutils/munin-master/files/patch-Makefile.config
index 52f43ea968a4..c7097d2ab7e4 100644
--- a/sysutils/munin-master/files/patch-Makefile.config
+++ b/sysutils/munin-master/files/patch-Makefile.config
@@ -78,8 +78,8 @@
-GETENT = $(shell which getent || which true 2>/dev/null)
-CHECKUSER = $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-CHECKGROUP = $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
-+CHECKUSER:= $(shell grep $(USER) /etc/passwd >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-+CHECKGROUP:= $(shell grep $(GROUP) /etc/group >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
++CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
++CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
CHOWN = chown
CHMOD = chmod
diff --git a/sysutils/munin-master/pkg-install b/sysutils/munin-master/pkg-install
index 1208f695a04e..3ce03edb2f51 100644
--- a/sysutils/munin-master/pkg-install
+++ b/sysutils/munin-master/pkg-install
@@ -45,7 +45,7 @@ make_account() {
echo "Done."
else
echo "Please create it, and try again."
- if ! grep -q "^${u}:" /etc/passwd; then
+ if ! /usr/sbin/pw user show ${u} >/dev/null 2>/dev/null; then
echo "While you're at it, please create a user \"${u}\" too,"
echo "with a default group of \"${g}\"."
fi