aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-12-10 00:05:31 +0800
committerzi <zi@FreeBSD.org>2014-12-10 00:05:31 +0800
commit721585fb4761e1d299c99a8e280d20527bd3c6bb (patch)
tree94544c7e5f638ad31bdc44a6023719e9dff1a62b
parent17d28a2bdda0661330f991745e15ed0ba1716df7 (diff)
downloadfreebsd-ports-gnome-721585fb4761e1d299c99a8e280d20527bd3c6bb.tar.gz
freebsd-ports-gnome-721585fb4761e1d299c99a8e280d20527bd3c6bb.tar.zst
freebsd-ports-gnome-721585fb4761e1d299c99a8e280d20527bd3c6bb.zip
- Update to 2.2.6
-rw-r--r--net/freeradius2/Makefile40
-rw-r--r--net/freeradius2/distinfo4
-rw-r--r--net/freeradius2/files/patch-src__main__version.c17
-rw-r--r--net/freeradius2/pkg-plist46
4 files changed, 62 insertions, 45 deletions
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index 4ec631592ea9..73cd5cd1a11b 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= freeradius
-DISTVERSION= 2.2.5
-PORTREVISION= 3
+DISTVERSION= 2.2.6
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/%SUBDIR%/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/%SUBDIR%/ \
@@ -28,7 +27,7 @@ CONFLICTS_INSTALL= gnu-radius-[0-9].* openradius-[0-9].* radiusd-cistron-[0-9].*
USE_RC_SUBR= radiusd
-USES= gmake libtool shebangfix tar:bzip2
+USES= gmake libtool shebangfix tar:bzip2 libtool autoreconf
SHEBANG_FILES= scripts/radsqlrelay src/modules/rlm_counter/rad_counter
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader
USE_OPENSSL= yes
@@ -238,21 +237,21 @@ EXPM= yes
.endif
# No SMB option yet; rlm_smb is still unbuildable
-.if ${PORT_OPTIONS:MSMB}
-LIB_DEPENDS= libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient
-CONFIGURE_ARGS+=--with-rlm_smb
-CONFIGURE_ARGS+=--with-rlm-smb-lib-dir=${LOCALBASE}/lib
-CONFIGURE_ARGS+=--with-rlm-smb-include-dir=${LOCALBASE}/include
-PLIST_SUB+= SMB=""
-.else
-CONFIGURE_ARGS+=--without-rlm_smb
-PLIST_SUB+= SMB="@comment "
-.endif
-
-# SMB module is still experimental
-.if ${PORT_OPTIONS:MSMB} && empty(PORT_OPTIONS:MSMB)
-EXPM= yes
-.endif
+#.if ${PORT_OPTIONS:MSMB}
+#LIB_DEPENDS= libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient
+#CONFIGURE_ARGS+=--with-rlm_smb
+#CONFIGURE_ARGS+=--with-rlm-smb-lib-dir=${LOCALBASE}/lib
+#CONFIGURE_ARGS+=--with-rlm-smb-include-dir=${LOCALBASE}/include
+#PLIST_SUB+= SMB=""
+#.else
+#CONFIGURE_ARGS+=--without-rlm_smb
+#PLIST_SUB+= SMB="@comment "
+#.endif
+#
+## SMB module is still experimental
+#.if ${PORT_OPTIONS:MSMB} && empty(PORT_OPTIONS:MSMB)
+#EXPM= yes
+#.endif
# Oracle support is experimental under FreeBSD
.if ${PORT_OPTIONS:MOCI8}
@@ -342,4 +341,9 @@ pre-configure:
@cd ${WRKSRC}/src/modules/rlm_perl && ${AUTOCONF} -I ${WRKSRC}
@cd ${WRKSRC}/src/modules/rlm_python && ${AUTOCONF} -I ${WRKSRC}
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}-${PORTVERSION}/*.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/rlm_* \
+ ${STAGEDIR}${PREFIX}/sbin/rad*
+
.include <bsd.port.post.mk>
diff --git a/net/freeradius2/distinfo b/net/freeradius2/distinfo
index fdfeb95901f9..42f87df8f79c 100644
--- a/net/freeradius2/distinfo
+++ b/net/freeradius2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freeradius-server-2.2.5.tar.bz2) = 86f1ca4ea9638be2797206c3457e320f2678d27d4bd548b5d2878a4283b0bd61
-SIZE (freeradius-server-2.2.5.tar.bz2) = 2790143
+SHA256 (freeradius-server-2.2.6.tar.bz2) = 1d1c3b1292cab37411eb63fbd9441ccef90853854c25fb56a24a80a160d6d577
+SIZE (freeradius-server-2.2.6.tar.bz2) = 2790647
diff --git a/net/freeradius2/files/patch-src__main__version.c b/net/freeradius2/files/patch-src__main__version.c
index 749499d684a4..7262ee3330b9 100644
--- a/net/freeradius2/files/patch-src__main__version.c
+++ b/net/freeradius2/files/patch-src__main__version.c
@@ -1,11 +1,16 @@
---- ./src/main/version.c.orig 2014-08-16 16:17:41.000000000 -0400
-+++ ./src/main/version.c 2014-08-16 16:18:31.000000000 -0400
-@@ -60,21 +60,8 @@
- (unsigned long) ssl_built,
- (unsigned long) ssl_linked);
+--- src/main/version.c.orig 2014-12-09 13:11:34 UTC
++++ src/main/version.c
+@@ -67,7 +67,6 @@ int ssl_check_version(int allow_vulnerab
+ radlog(L_ERR, "libssl version mismatch. built: %lx linked: %lx",
+ (unsigned long) ssl_built, (unsigned long) ssl_linked);
- return -1;
- };
+ }
+
+ /*
+@@ -84,18 +83,6 @@ int ssl_check_version(int allow_vulnerab
+ */
+ } else if ((ssl_built & 0xffffff) != (ssl_linked & 0xffffff)) goto mismatch;
- if (!allow_vulnerable) {
- /* Check for bad versions */
diff --git a/net/freeradius2/pkg-plist b/net/freeradius2/pkg-plist
index 5d375583b84f..1325d7584010 100644
--- a/net/freeradius2/pkg-plist
+++ b/net/freeradius2/pkg-plist
@@ -1,4 +1,3 @@
-@stopdaemon radiusd
@unexec different=0 ; for i in `find %D/%%EXAMPLESDIR%%/raddb/certs/ -type f -print | sed -e 's:^%D/%%EXAMPLESDIR%%/raddb/certs/::g'`; do if ! cmp -hsz %D/%%EXAMPLESDIR%%/raddb/certs/${i} %D/etc/raddb/certs/${i}; then different=1; break; fi; done; if [ ${different} -eq 0 ] && diff -rq --exclude=certs %D/%%EXAMPLESDIR%%/raddb %D/etc/raddb >/dev/null 2>&1; then rm -rf %D/etc/raddb; fi
@unexec if [ -d %D/etc/raddb ]; then echo "You should remove %D/etc/raddb if you don't need it any more."; fi
bin/rad_counter
@@ -588,6 +587,7 @@ sbin/radwatch
%%DATADIR%%/dictionary.azaire
%%DATADIR%%/dictionary.bay
%%DATADIR%%/dictionary.bintec
+%%DATADIR%%/dictionary.bluecoat
%%DATADIR%%/dictionary.bristol
%%DATADIR%%/dictionary.broadsoft
%%DATADIR%%/dictionary.brocade
@@ -601,19 +601,23 @@ sbin/radwatch
%%DATADIR%%/dictionary.cisco.bbsm
%%DATADIR%%/dictionary.cisco.vpn3000
%%DATADIR%%/dictionary.cisco.vpn5000
+%%DATADIR%%/dictionary.citrix
%%DATADIR%%/dictionary.clavister
%%DATADIR%%/dictionary.colubris
%%DATADIR%%/dictionary.columbia_university
%%DATADIR%%/dictionary.compat
+%%DATADIR%%/dictionary.compatible
%%DATADIR%%/dictionary.cosine
%%DATADIR%%/dictionary.dante
%%DATADIR%%/dictionary.dhcp
%%DATADIR%%/dictionary.digium
%%DATADIR%%/dictionary.dlink
+%%DATADIR%%/dictionary.dragonwave
%%DATADIR%%/dictionary.efficientip
%%DATADIR%%/dictionary.eltex
%%DATADIR%%/dictionary.epygi
%%DATADIR%%/dictionary.ericsson
+%%DATADIR%%/dictionary.ericsson.packet.core.networks
%%DATADIR%%/dictionary.erx
%%DATADIR%%/dictionary.extreme
%%DATADIR%%/dictionary.f5
@@ -697,8 +701,12 @@ sbin/radwatch
%%DATADIR%%/dictionary.rfc6677
%%DATADIR%%/dictionary.rfc6911
%%DATADIR%%/dictionary.rfc6930
+%%DATADIR%%/dictionary.rfc7055
+%%DATADIR%%/dictionary.rfc7268
+%%DATADIR%%/dictionary.riverbed
%%DATADIR%%/dictionary.riverstone
%%DATADIR%%/dictionary.roaringpenguin
+%%DATADIR%%/dictionary.ruckus
%%DATADIR%%/dictionary.sg
%%DATADIR%%/dictionary.shasta
%%DATADIR%%/dictionary.shiva
@@ -737,24 +745,24 @@ sbin/radwatch
%%DATADIR%%/dictionary.zyxel
@unexec rmdir "/var/run/radiusd" >/dev/null 2>&1 || :
@unexec rmdir "/var/log/radacct" >/dev/null 2>&1 || :
-@dirrm %%DATADIR%%
-@dirrm %%EXAMPLESDIR%%/raddb/sql/postgresql
-@dirrm %%EXAMPLESDIR%%/raddb/sql/oracle
-@dirrm %%EXAMPLESDIR%%/raddb/sql/ndb
-@dirrm %%EXAMPLESDIR%%/raddb/sql/mysql
-@dirrm %%EXAMPLESDIR%%/raddb/sql/mssql
-@dirrm %%EXAMPLESDIR%%/raddb/sql
-@dirrm %%EXAMPLESDIR%%/raddb/sites-enabled
-@dirrm %%EXAMPLESDIR%%/raddb/sites-available
-@dirrm %%EXAMPLESDIR%%/raddb/modules
-@dirrm %%EXAMPLESDIR%%/raddb/certs
-@dirrm %%EXAMPLESDIR%%/raddb
-@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/rfc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%LIBDIR%%
-@dirrm include/freeradius
+@dir %%DATADIR%%
+@dir %%EXAMPLESDIR%%/raddb/sql/postgresql
+@dir %%EXAMPLESDIR%%/raddb/sql/oracle
+@dir %%EXAMPLESDIR%%/raddb/sql/ndb
+@dir %%EXAMPLESDIR%%/raddb/sql/mysql
+@dir %%EXAMPLESDIR%%/raddb/sql/mssql
+@dir %%EXAMPLESDIR%%/raddb/sql
+@dir %%EXAMPLESDIR%%/raddb/sites-enabled
+@dir %%EXAMPLESDIR%%/raddb/sites-available
+@dir %%EXAMPLESDIR%%/raddb/modules
+@dir %%EXAMPLESDIR%%/raddb/certs
+@dir %%EXAMPLESDIR%%/raddb
+@dir %%EXAMPLESDIR%%
+%%PORTDOCS%%@dir %%DOCSDIR%%/rfc
+%%PORTDOCS%%@dir %%DOCSDIR%%/examples
+%%PORTDOCS%%@dir %%DOCSDIR%%
+@dir %%LIBDIR%%
+@dir include/freeradius
@exec if ! [ -d %D/etc/raddb -o -L %D/etc/raddb ]; then cp -RP %D/%%EXAMPLESDIR%%/raddb %D/etc/raddb; echo '===> Bootstrapping default certificates, please wait...'; %D/etc/raddb/certs/bootstrap >/dev/null 2>&1; fi
@exec chmod -R g-w,o-rwx %D/etc/raddb
@exec if [ ! -d /var/log/radacct ]; then mkdir -p /var/log/radacct; chmod -R go= /var/log/radacct; fi