aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-02-14 09:37:45 +0800
committersobomax <sobomax@FreeBSD.org>2002-02-14 09:37:45 +0800
commit75a9142e5fdb8389dda67679dfe1432bc97b0918 (patch)
tree99f4df33fa3890899305bb04ea1974342fc74b91
parent02d2faa1300c62047360220ab3d6273d0ab1657e (diff)
downloadfreebsd-ports-gnome-75a9142e5fdb8389dda67679dfe1432bc97b0918.tar.gz
freebsd-ports-gnome-75a9142e5fdb8389dda67679dfe1432bc97b0918.tar.zst
freebsd-ports-gnome-75a9142e5fdb8389dda67679dfe1432bc97b0918.zip
Use version of the patch-ltmain.sh which doesn't strip -pthread flags
when linking shared libraries. Bump PORTREVISION.
-rw-r--r--net/linc/Makefile1
-rw-r--r--net/linc/files/patch-ltmain.sh25
2 files changed, 22 insertions, 4 deletions
diff --git a/net/linc/Makefile b/net/linc/Makefile
index a7f35962c834..93293c496fe2 100644
--- a/net/linc/Makefile
+++ b/net/linc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= linc
PORTVERSION= 0.1.16
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
diff --git a/net/linc/files/patch-ltmain.sh b/net/linc/files/patch-ltmain.sh
index 98cb05e4ddb3..91713d2306f8 100644
--- a/net/linc/files/patch-ltmain.sh
+++ b/net/linc/files/patch-ltmain.sh
@@ -1,9 +1,26 @@
$FreeBSD$
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
@@ -13,7 +30,7 @@ $FreeBSD$
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
+@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.