aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2009-02-12 07:55:50 +0800
committernivit <nivit@FreeBSD.org>2009-02-12 07:55:50 +0800
commit76a6590dac3cecc558a6eaa625ec04ba014abe75 (patch)
tree32437201dc5759a9135d96b1606f841bb2d3b330
parentb65724ca918c8b5c5c1b866842608fdf82fbe76f (diff)
downloadfreebsd-ports-gnome-76a6590dac3cecc558a6eaa625ec04ba014abe75.tar.gz
freebsd-ports-gnome-76a6590dac3cecc558a6eaa625ec04ba014abe75.tar.zst
freebsd-ports-gnome-76a6590dac3cecc558a6eaa625ec04ba014abe75.zip
WebOb provides wrappers around the WSGI request environment, and an
object to help create WSGI responses. The objects map much of the specified behavior of HTTP, including header parsing and accessors for other standard parts of the environment. WWW: http://pythonpaste.org/webob/
-rw-r--r--www/Makefile1
-rw-r--r--www/py-webob/Makefile31
-rw-r--r--www/py-webob/distinfo3
-rw-r--r--www/py-webob/pkg-descr8
-rw-r--r--www/py-webob/pkg-plist25
5 files changed, 68 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2a6dbe6834c2..da2b951890d1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1271,6 +1271,7 @@
SUBDIR += py-urljr
SUBDIR += py-utidy
SUBDIR += py-webhelpers
+ SUBDIR += py-webob
SUBDIR += py-webunit
SUBDIR += py-webware
SUBDIR += py-webware-component
diff --git a/www/py-webob/Makefile b/www/py-webob/Makefile
new file mode 100644
index 000000000000..1cc23035ec88
--- /dev/null
+++ b/www/py-webob/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: webob
+# Date created: 2009-02-12
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webob
+PORTVERSION= 0.9.6.1
+#PORTREVISION= 0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PYDISTUTILS_PKGNAME}-${PORTVERSION}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= WSGI request and response Python object
+
+PYDISTUTILS_PKGNAME= WebOb
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR} && cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/py-webob/distinfo b/www/py-webob/distinfo
new file mode 100644
index 000000000000..cfc141d575e4
--- /dev/null
+++ b/www/py-webob/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebOb-0.9.6.1.tar.gz) = 5702ac9c9bfc39e6f04a39e15bd7b435
+SHA256 (WebOb-0.9.6.1.tar.gz) = 75b3ab34f490489fe5f9092c6c8170cd9ab86b0188f672b9b1b694da705c3305
+SIZE (WebOb-0.9.6.1.tar.gz) = 103298
diff --git a/www/py-webob/pkg-descr b/www/py-webob/pkg-descr
new file mode 100644
index 000000000000..75c92fd3d1d5
--- /dev/null
+++ b/www/py-webob/pkg-descr
@@ -0,0 +1,8 @@
+WebOb provides wrappers around the WSGI request environment, and an
+object to help create WSGI responses.
+
+The objects map much of the specified behavior of HTTP, including
+header parsing and accessors for other standard parts of the
+environment.
+
+WWW: http://pythonpaste.org/webob/
diff --git a/www/py-webob/pkg-plist b/www/py-webob/pkg-plist
new file mode 100644
index 000000000000..66bff881c58d
--- /dev/null
+++ b/www/py-webob/pkg-plist
@@ -0,0 +1,25 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTDOCS%%%%DOCSDIR%%/comment-example-code/example.py
+%%PORTDOCS%%%%DOCSDIR%%/comment-example.txt
+%%PORTDOCS%%%%DOCSDIR%%/conf.py
+%%PORTDOCS%%%%DOCSDIR%%/differences.txt
+%%PORTDOCS%%%%DOCSDIR%%/do-it-yourself.txt
+%%PORTDOCS%%%%DOCSDIR%%/file-example.txt
+%%PORTDOCS%%%%DOCSDIR%%/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/jsonrpc-example-code/jsonrpc.py
+%%PORTDOCS%%%%DOCSDIR%%/jsonrpc-example-code/test_jsonrpc.py
+%%PORTDOCS%%%%DOCSDIR%%/jsonrpc-example-code/test_jsonrpc.txt
+%%PORTDOCS%%%%DOCSDIR%%/jsonrpc-example.txt
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/modules/webob.txt
+%%PORTDOCS%%%%DOCSDIR%%/news.txt
+%%PORTDOCS%%%%DOCSDIR%%/reference.txt
+%%PORTDOCS%%%%DOCSDIR%%/test-file.txt
+%%PORTDOCS%%%%DOCSDIR%%/wiki-example-code/example.py
+%%PORTDOCS%%%%DOCSDIR%%/wiki-example.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/wiki-example-code
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/modules
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/jsonrpc-example-code
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/comment-example-code
+%%PORTDOCS%%@dirrm %%DOCSDIR%%